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                                                                                                 Purpose statement 

This competence of advanced spreadsheets provides the advanced for the spreadsheets in computer literacy’s 

practice-based. Is above the skills and knowledge contained within the spreadsheets in computer literacy. Advanced 

spreadsheets anticipates that the candidate has already acquired the skills and knowledge outlined in spread sheets 

in computer literacy. Advanced Spreadsheets requires the candidate to use the spreadsheet application to produce 

advanced spreadsheet outputs. The candidate shall be able to apply advanced formatting options such as conditional 

formatting and customized number formatting and handle worksheets. Use functions such as those associated with 

logical, statistical, financial and mathematical operations. Create charts and apply advanced chart formatting features. 

Work with tables and lists to analyze, filter and sort data. Create and use scenarios. Validate and audit spreadsheet 

data. Enhance productivity by working with named cell ranges, macros and templates. Use linking, embedding and 

importing features to integrate data. Collaborate on, review spreadsheets, and apply spreadsheet security features. 

ADVANCED SPREADSHEETS 
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Learning Unit 1: Apply Advanced Spreadsheet Formatting Options 

L O1.1- Apply Advanced Cells formatting 

 Content/Topic 1: Cell Introduction 

The intersection of rows and columns is called cell. Cell is identified with Combination of column header 

and row number. For example − A1, A2. 

 

 Content/Topic 2:  Formatting Cell 

MS Excel Cell can hold different types of data like Numbers, Currency, Dates, etc. You can set the cell type 

in various ways as shown below − 

1. Right Click on the cell » Format cells » Number. 

2. Click on the Ribbon from the ribbon. 
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 Content/Topic3.Various Cell Formats 

Below are the various cell formats. 

General − This is the default cell format of Cell. 

Number − This displays cell as number with separator. 

Currency − This displays cell as currency i.e. with currency sign. 

Accounting − Similar to Currency, used for accounting purpose. 

Date − Various date formats are available under this like 17-09-2013, 17th-Sep-2013, etc. 

Time − Various Time formats are available under this, like 1.30PM, 13.30, etc. 

Percentage − This displays cell as percentage with decimal places like 50.00%. 

Fraction − This displays cell as fraction like 1/4, 1/2 etc. 

Scientific − This displays cell as exponential like 5.6E+01. 

Text − This displays cell as normal text. 

Special − Special formats of cell like Zip code, Phone Number. 

Custom − You can use custom format by using this. 

Content/Topic 5: Formatting Cells 

In MS Excel, you can apply formatting to the cell or range of cells by Right Click » Format cells » Select the 

tab. Various tabs are available as shown below 

 

Alternative to Placing Background 
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Number − You can set the Format of the cell depending on the cell content. Find tutorial on this at MS 

Excel - Setting Cell Type. 

Alignment − You can set the alignment of text on this tab. Find tutorial on this at MS Excel - Text 

Alignments. 

Font − You can set the Font of text on this tab.Find tutorial on this at MS Excel - Setting Fonts. 

Border − You can set border of cell with this tab.Find tutorial on this at MS Excel - Borders and Shades. 

Fill − You can set fill of cell with this tab. Find tutorial on this at MS Excel - Borders and Shades. 

Protection − You can set cell protection option with this tab. 

Sheet Options in Excel 2010 

Sheet Options 

MS Excel provides various sheet options for printing purpose like generally cell gridlines aren’t printed. If 

you want your printout to include the gridlines, Choose Page Layout » Sheet Options group » Gridlines » 

Check Print. 

 

Options in Sheet Options Dialogue 

Print Area − You can set the print area with this option. 

Print Titles − You can set titles to appear at the top for rows and at the left for columns. 

Print − 

o Gridlines − Gridlines to appear while printing worksheet. 
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o Black & White − Select this check box to have your color printer print the chart in black and 

white. 

o Draft quality − Select this check box to print the chart using your printer’s draft-quality 

setting. 

o Rows & Column Heading − Select this check box to have rows and column heading to print. 

 Page Order − 

o Down, then Over − It prints the down pages first and then the right pages. 

o Over, then Down − It prints right pages first and then comes to print the down pages. 

Conditional Formatting 

MS Excel 2010 Conditional Formatting feature enables you to format a range of values so that the values 

outside certain limits, are automatically formatted. 

Choose Home Tab » Style group » Conditional Formatting dropdown. 

Various Conditional Formatting Options 

 Highlight Cells Rules − It opens a continuation menu with various options for defining the formatting 

rules that highlight the cells in the cell selection that contain certain values, text, or dates, or that 

have values greater or less than a particular value, or that fall within a certain ranges of values. 

Suppose you want to find cell with Amount 0 and Mark them as red.Choose Range of cell » Home Tab » 

Conditional Formatting DropDown » Highlight Cell Rules » Equal To. 

 

After Clicking ok, the cells with value zero are marked as red. 
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 Top/Bottom Rules − It opens a continuation menu with various options for defining the formatting 

rules that highlight the top and bottom values, percentages, and above and below average values 

in the cell selection. 

Suppose you want to highlight the top 10% rows you can do this with these Top/Bottom rules. 

 

 Data Bars − It opens a palette with different color data bars that you can apply to the cell selection 

to indicate their values relative to each other by clicking the data bar thumbnail. 

With this conditional Formatting data Bars will appear in each cell. 
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 Color Scales − It opens a palette with different three- and two-colored scales that you can apply to 

the cell selection to indicate their values relative to each other by clicking the color scale thumbnail. 

See the below screenshot with Color Scales, conditional formatting applied. 

 

 Icon Sets − It opens a palette with different sets of icons that you can apply to the cell selection to 

indicate their values relative to each other by clicking the icon set. 

See the below screenshot with Icon Sets conditional formatting applied. 
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 New Rule − It opens the New Formatting Rule dialog box, where you define a custom conditional 

formatting rule to apply to the cell selection. 

 Clear Rules − It opens a continuation menu, where you can remove the conditional formatting rules 

for the cell selection by clicking the Selected Cells option, for the entire worksheet by clicking the 

Entire Sheet option, or for just the current data table by clicking the This Table option. 

 Manage Rules − It opens the Conditional Formatting Rules Manager dialog box, where you edit and 

delete particular rules as well as adjust their rule precedence by moving them up or down in the 

Rules list box. 

L O 1.2- Apply advanced worksheets formatting 

Insert how to copy, move worksheet between spreadsheet 

Moving and Copying Worksheets 

Moving a Worksheet 

Excel provides a very easy way to move a sheet from one place to another in the same workbook.  

1. Click the sheet tab you want to move.   

2. While holding down the mouse button, drag the sheet tab to its new location.  When you drag a 

sheet, a small worksheet icon appears at the tip of your pointer arrow, another tiny black arrow 

appears at the beginning of the sheet tab.  This tiny black arrow indicates where the sheet will be 

inserted in the tab order. 

3. release your mouse button and the sheet will be inserted into the placement indicated. 

Using this same technique, you can move several sheets at one time.   

1. Select the first sheet you want to move,  

2. while holding down the Shift key, click on the next sheet.  This will indicate a range of sheets to move 

i.e. sheet1:sheet2.   

3. You can then drag the range of sheets to their new location. 

copying a Worksheet 

Using similar mouse techniques as above,  

1. First select the sheet or sheets you want to copy  
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2. Then hold down the Ctrl key while you drag the sheet or sheets to the new location.   

**Note ** 

When you copy an entire sheet, the identical sheet appears in the new location.   

   A number will appear in parentheses to the copy's to distinguish it from the original sheet.   

Moving and copying Sheets Between Workbooks 

Excel has the ability to move and copy sheets from a current workbook to another open workbook by simply 

dragging.  Very neat isn't it. 

Moving Sheets Between Workbooks 

You can use the same methods as above to move a worksheet to another workbook. 

1. Open both workbooks you will be working in. 

2. Click on the sheet tab you wish to move from workbook 1 to workbook2. 

3. Drag the sheet  from workbook 1 to where you want it to be in workbook 2.   

** Note ** 

The entire sheet from workbook 1 will be moved to workbook 2.  It will no longer be in workbook 1. 

copying Sheets Between Workbooks 

To copy rather than move sheets from one workbook to another follow the steps above but simply press 

the Ctrl key while dragging the sheet tab from workbook 1 to workbook 2. 

Filling Across Worksheets 

When working with multiple worksheets within a single workbook, you may find that there is some data on 

sheet1 that you want to appear on sheet2 and 3.  Excel allows you to copy row and column headings, cell 

contents, and formats to other worksheets in the workbook.   It will copy the data to the same cells in every 

worksheet you select, 

Follow these easy instructions: 

1. Select the worksheets you want to fill across. 
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 If the worksheets you want to fill across are continuous, hold down the Shift key, click on the first 

sheet tab, and select the last sheet you want.  Excel selects all worksheets in between as well. 

 If the worksheets you want are not continuous, hold down the Ctrl key, click on the first sheet tab, 

and select the remaining sheets.  Excel selects only those sheets whose tabs you clicked. 

2. Select the range that contains the cells you want to display on the other sheets. 

3. Click on the Edit menu, point to Fill, and click on Across Worksheets. 

Excel will display the Fill Across Worksheets dialog box: 

4. Do one of the following: 

 If you want to copy only contents, click on Contents. 

 If you want to copy only the format, click on Formats. 

 If you want to copy both content and format, click on All. 

5. Click on OK. 

Excel will display the contents of the cells you selected to the same cells on the worksheets you chose. 

 

Insert how to splitting a windows 

Split 
Split your worksheet to view multiple distant parts of your worksheet at once. To split your worksheet (window) into an 

upper and lower part (pane), execute the following steps. 

1. First, select a cell in column A. 

2. On the View tab, in the Window group, click Split. 

3. Notice the two vertical scroll bars. For example, use the lower vertical scroll bar to move to row 49. As you 

can see, the first 6 rows remain visible. 

4. To change the window layout, use the horizontal split bar that divides the panes. 

5. To remove the split, simply double click the split bar. 

Note: in a similar way, you can split your window into a left and right pane by selecting a cell in row 1 before 

you click View, Split. You can even split your window into four panes by selecting a cell that is not column A 

or row 1. Any changes you make to one pane are immediately reflected in the other ones. 

Insert how to moving and removing split bars 
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To insert a single vertical or horizontal split: 

1. Click Design Mode. 

2. Select Window > Split. 

A vertical and horizontal split line will be inserted. 

Note: Alternatively, you can drag a vertical or horizontal split line from the horizontal and vertical scroll 

bars. To do this, click and drag the small rectangle at the left of the Left arrow on the horizontal scroll 

bar, or above the Up arrow on the vertical scroll bar. 

3. Point the cursor at the split line. The cursor changes to two parallel lines. 

4. Drag the splitters into position. 

Note: You can insert a horizontal and vertical split in any report mode, but only splits inserted in Design 

Mode are visible in View Mode and Report Preview. You can fix a split in place only in Design Mode. 

SeeDesign Mode, Debug Mode, and View Mode. 

5. To remove splits, select Window > Remove Split. 

6. To fix a split in position, right-click it and select Fix. Or, select Window > Freeze Panes. 

This creates a single window from the split windows, with one set of scroll bars. The areas to the left of 

a vertical split and above a horizontal split become fixed. You can continue to scroll through the data to 

the right and below. You can only fix one vertical and one horizontal split. 

7. To remove fixed areas select Window > Unfreeze Panes. Or, right-click a fixed split and select Undo 

fixing. 

 Content/Topic 1: Hiding Worksheet 

Here is the step to hide a worksheet. 

Step − Right Click the Sheet Name and select the Hide option. Sheet will get hidden. 

https://docs.infor.com/bi/11.0.x/en-us/biasolh/lsm1431935806935.html
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 Contents/Topic 2: Unhiding Worksheet 

Here are the steps to unhide a worksheet. 

Step 1 − Right Click on any Sheet Name and select the Unhide... option. 

 

Step 2 − Select Sheet Name to unhide in Unhide dialog to unhide the sheet. 

Press the Ok Button. 

Now you will have your hidden sheet back. 
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 Content/ Topic 3: Delete Worksheet in Excel  

Delete Worksheet 

Here is the step to delete a worksheet. 

Step − Right Click the Sheet Name and select the Delete option. 

 

Sheet will get deleted if it is empty, otherwise you'll see a confirmation message. 

 

Press the Delete Button. 

Now your worksheet will get deleted. 

 Content/ Topic 3: Close Workbook in Excel 2010 
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Close Workbook 

Here are the steps to close a workbook. 

Step 1 − Click the Close Button as shown below. 

 

You'll see a confirmation message to save the workbook. 

 

Step 2 − Press the Save Button to save the workbook as we did in MS Excel - Save Workbook chapter. 

Now your worksheet will get closed. 

LO 1.3: Apply advanced row and column formatting 

Content/Topic 1: Row and Column Basics 

MS Excel is in tabular format consisting of rows and columns. 

 Row runs horizontally while Column runs vertically. 

 Each row is identified by row number, which runs vertically at the left side of the sheet. 
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 Each column is identified by column header, which runs horizontally at the top of the sheet. 

For MS Excel 2010, Row numbers ranges from 1 to 1048576; in total 1048576 rows, and Columns ranges 

from A to XFD; in total 16384 columns. 

Navigation with Rows and Columns 

Let us see how to move to the last row or the last column. 

 You can go to the last row by clicking Control + Down Navigation arrow. 

 You can go to the last column by clicking Control + Right Navigation arrow. 

 

Cell Introduction 

The intersection of rows and columns is called cell. 

Cell is identified with Combination of column header and row number. 

For example − A1, A2. 
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Insert how  to Hiding, rows, columns, worksheets Learning Outcome 1.4: Apply advanced table formatting 

Excel identifies the following specific areas in a table that you can format automatically and independently: 

the header row, data rows, totals row, first column, and last column. Follow these steps to apply a new style 

to a table: 

Select any cell in the table and choose Table Tools> Design> Table Styles. The Ribbon shows one row of 

styles, but if you click the bottom of the vertical scrollbar, the table styles group expands. The styles are 

grouped into three categories: Light, Medium, and Dark. Notice that you get a live preview as you move your 

mouse among the styles. When you see one you like, just click to make it permanent. 

For a different set of color choices, use Page Layout> Themes> Themes> to select a different document 

theme. 

If applying table styles is not working, the range was probably already formatted before you converted it to 

a table. (Table formatting doesn't override normal formatting.) To clear the existing background fill colors, 

select the entire table and choose Home> Font> Fill Color> No Fill. To clear the existing font colors, choose 

Home> Font> Font Color> Automatic. After you issue these commands, the table styles should work as 

expected. 

The styles you apply from the Table Styles gallery are based on the theme applied to the workbook. 

Therefore, if you change the workbook theme, both the table style and gallery styles change to match the 

new theme. 

If you would like to make changes to an existing table style, locate it in the Ribbon and rightclick. Choose 

Duplicate from the shortcut menu. Excel displays the Modify Table Quick Style dialog box with all of the 
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settings from the specified table style. Make your changes, give it a new name, and click OK to save it as a 

custom table style 

 L O 1.4 – apply advanced table formatting 

Tables 

One of the most common formatting elements you will use in Microsoft Word are tables, so much so that 

it’s probably a surprise we aren’t covering them until now! 

Tables are a tried-and-true method of presenting data in rows and columns. They are very simple to insert 

and manipulate in Word. When you click on the “Tables” button on the “Insert” tab, you’re given several 

options. 

 

Here you see a grid that allows you to quickly spec out a table but you can also insert, draw, or pick from 

some predefined “Quick Tables”. 

 

The fast way is to simply trace out the table you want using the provided grid. In the screenshot, you see we 

trace out a 6 x 5 table, which is previewed in the document. 
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With your table now placed into your document, you can set out about formatting it, which we’ll cover 

shortly. 

Insert Table 

Secondly, you can “Insert Table,” which means you just input the number of columns and rows and how you 

want the column to “AutoFit.” If you choose fixed column width, you can select “auto” or you can assign a 

size. Alternatively, you can AutoFit columns to fit the contents, or you can have the content AutoFit to the 

window. 

 

Finally, if you intend to reproduce the table or you use that size frequently, you can have the “Insert Table” 

dialog remember those dimensions for new tables. 

Draw Table 

When you draw a table, the cursor is changed to a pencil and you can “draw” out the column and rows. In 

this way you can size the table to your liking. 

Once you draw your first cell, you can then draw further cells, and create the table that is more based on 

how you want it to look than necessarily what it requires. 
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Convert Text to Table 

Let’s imagine you have a bunch of text and numbers, and you realize that it would be easier to read if it were 

in neat columns and rows. Not to fear, text to table will allow you to quickly and easily convert all that data 

into a table that you can then format to your heart’s content. 

So how does this work? Simply, when you want to convert a section of your document to a table, you select 

the section using your mouse pointer and then select “Convert Text to Table.” The resulting dialog box allows 

you to choose how many columns you want. 

 

The number of rows will be automatically determined by line breaks, so for example, if you have a block of 

text divided with flour line breaks, your table will have four rows. 

Columns are determined by commas, tabs, paragraph breaks, or another symbol you can manually assign. 

Quick Tables 

Quick tables are fairly easy to reason out. Let’s say you want to insert a quick calendar, matrix, or a tabular 

list. You can also create your own table and save it to the list for later, quick use. Simply select the table you 

want to save, and select “Save Selection to Quick Tables Gallery.” 
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There’s not a whole lot to master here. Keep in mind, when you insert a quick table, you can then edit and 

format as you would any table that you created from scratch. And, on that note, let’s actually dive into all 

that formatting information we’ve been alluding to throughout this lesson. 

Formatting Tables 

On the Ribbon, the “Table Tools” tabs are contextual tabs that appears whenever you create or click on a 

table. The functions found here give you an easier visual way of quickly manipulating tables where you might 

otherwise use right-click options. 

 

The “Table Tools” are divided into two tabs. “Layout” (pictured above), which lets you add and remove 

columns, adjust height and width, and text alignment. Many of these controls can be accessed directly from 

the right-click context menu, but it’s nice to have all your options arrayed before you. 
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Note though, the context menu you get, will depend on where you click. If you click on the little table control 

in the upper-left corner: 

You get a larger variety of tools at your disposal. Note also, you can delete a table easily this way: 
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Back to the Ribbon, on the far right side of the “Layout” tab, you’ll find some handy controls for controlling 

your “Alignment” and “Data.” 

 

So, for example, if you want your headers to be perfectly centered within their cells, while having your data 

cells left-justified, you’d simply select the cells to affected and click the alignment you desire. 

You can also “Sort” cell data, insert formulas, convert your table to plain text, and repeat header rows. The 

last option is useful if you have a table that spans multiple pages, you can designate “header rows,” which 

will persist as you scroll through the table. This is useful for keep track of what column is what in long tables. 

The “Design” tab by contrast is all about how your table(s) appear. 

 

Note when you click on the scrollbar in “Table Styles” a larger menu appears granting you greater built-in 

options. 

 

At the bottom of this menu, you can modify your table’s style if the current selection of tables doesn’t suit 

you. When you make changes, they will be previewed so you can see them before you commit. 
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While formatting or modifying a table, if the built-in selections aren’t close to what you want, you may just 

want to start from scratch. In this case, you can you the “New Style” dialog, which will be allow you to build 

a new table style based on current table styles. 

There’s little difference to this dialog and the modify dialog except that modifying is based off an existing 

table design. 
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In the end, formatting your tables is going to come down to what kind of data you’re presenting and personal 

preference. We suggest that if you want to fully master tables, you create a blank document and mess 

around to your heart’s content. We are certain you’ll be creating and formatting eye-catching data-sets in 

less than it takes to say “columns and rows!” 
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Learning Unit 2: Use Advanced Spreadsheet Functions and Formulas 

Introduction to Functions in Formula 

Many formulas you create use available worksheet functions. These functions enable you to greatly 

enhance the power of your formulas and perform calculations that are difficult if you use only the operators. 

For example, you can use the LOG or SIN function to calculate the Logarithm or Sin ratio. You can’t do this 

complicated calculation by using the mathematical operators alone. 

Topic 1: Using Functions 

When you type = sign and then type any alphabet you will see the searched functions as below. 

 

Suppose you need to determine the largest value in a range. A formula can’t tell you the answer without 

using a function. We will use formula that uses the MAX function to return the largest value in the range 

B3:B8 as =MAX(A1:D100). 
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Another example of functions. Suppose you want to find if the cell of month is greater than 1900 then we 

can give Bonus to Sales representative. The we can achieve it with writing formula with IF functions 

as =IF(B9>1900,"Yes","No") 

 

Content/Topic 2: Function Arguments 

In the above examples, you may have noticed that all the functions used parentheses. The information 

inside the parentheses is the list of arguments. 

Functions vary in how they use arguments. Depending on what it has to do, a function may use. 

 No arguments − Examples − Now(), Date(), etc. 

 One argument − UPPER(), LOWER(), etc. 

 A fixed number of arguments − IF(), MAX(), MIN(), AVERGAGE(), etc. 

 Infinite number of arguments 
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 Optional arguments 

Learning Outcome 2.1: Use date and time, mathematic and statistical functions 

Content/Topic1: Using Date and Time Functions 

Excel Date and Time functions can be used to extract information from, and perform operations on, Excel 

Dates and Times. 

Some of the Excel Date & Time functions are new to Excel 2010 or Excel 2013, so are not available in earlier 

versions of Excel. You can find this information in the applicability section of the function. 

S.No. Function and Description 

1 DAY 

Converts a serial number to a day of the month. 

2 MONTH 

Converts a serial number to a month. 

3 NOW 

Returns the serial number of the current date and time. 

4 TODAY 

Returns the serial number of today’s date. 

5 YEAR 

Converts a serial number to a year. 

Excel current date and time formulas (dynamic) 

There are two formulas to use, depending on what type of information you’re looking to insert in your 

spreadsheet. Note: These are dynamic formulas and will update whenever a spreadsheet is opened. 

Current date formula: 

=TODAY() 

Current time formula: 

=NOW() 

  

https://www.tutorialspoint.com/advanced_excel_functions/advanced_excel_date_time_day_function.htm
https://www.tutorialspoint.com/advanced_excel_functions/advanced_excel_date_time_month_function.htm
https://www.tutorialspoint.com/advanced_excel_functions/advanced_excel_date_time_now_function.htm
https://www.tutorialspoint.com/advanced_excel_functions/advanced_excel_date_time_today_function.htm
https://www.tutorialspoint.com/advanced_excel_functions/advanced_excel_date_time_year_function.htm
https://corporatefinanceinstitute.com/resources/excel/study/basic-excel-formulas-beginners/
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Excel current date and time example 

Let’s look at a real example in an Excel spreadsheet of how these two formulas work. In the screenshot 

below, you can clearly see how each works and what the corresponding output is. For example, if, at the 

time of creating the formula, it’s May 24, 2018 at 1:36 p.m., then the following information will appear in 

your spreadsheet. NOTE: Excel uses a 24-hour clock when it outputs the time. 

 

As you can see, the =TODAY() formula only includes the day, month and year. The =NOW() function displays 

more information, showing the day, month, year, hour and minutes (using a 24-hour clock). 

Excel current date and time formulas (static) 

You may not always want the figures in the file to update every time you open the file. If this is the case, 

then you’ll want to insert a static version of the formulas. 

Static formulas are: 

 “Ctrl + ;” – inserts the date (Windows) 

 “Ctrl + Shift + ;” – inserts the date and time (Windows) 

 “COMMAND + ;” (Mac) 

 Why insert current date and time in Excel? 

There are many reasons you may want to display the current date and time in Excel. Let’s say that you want 

users to have the current time displayed on a cover page every time you print off a financial model. 

Reasons to include time and date include: 

 Creating an activity log 

 On a cover page 

 When printing a document 

https://en.wikipedia.org/wiki/24-hour_clock


Page 32 of 182 
 

 For version control 

 When showing time-sensitive information 

 When discounting cash flows to the present (Net Present Value and XNPV function) 

  

How to change the date and time formatting 

You may wish to change the format of date or time displayed in the spreadsheet. In order to do this, press 

F1 (or right-click on the cell and click Format Cells). Once you see the Format Cells box appear on the screen, 

you can click on Number and then select Date or Time and choose the formatting you want to appear in your 

spreadsheet. 

 

Content/Topic 2: Using Mathematical Functions 

S.No. Function and Description 

1 ROUND 

Rounds a number to a specified number of digits 

2 ROUNDDOWN 

Rounds a number down, toward 0 

3 ROUNDUP 

Rounds a number up, away from 0 

4 SUM 

Adds its arguments 

5 SUMIF 

Adds the cells specified by a given criteria 

6 SUMIFS 

Adds the cells specified by a multiple criteria 

A very important feature in Excel is the formula. It is used to calculate values based on what is in cells, 

perform operations on a cell content, fetch values after an operation based on your search criteria and much 

more. 

Mathematical Formulas in Excel are used to perform various arithmetic operations like sum, average, count, 

max, min etc. Here is a list of most frequently used mathematical formulas in excel. 

SUM(): 

This function is used to adds all the values within a cell range. 

Syntax: 

https://corporatefinanceinstitute.com/resources/knowledge/valuation/net-present-value-npv/
https://corporatefinanceinstitute.com/resources/excel/study/xnpv-function-in-excel/
https://www.tutorialspoint.com/advanced_excel_functions/advanced_excel_math_trignometric_round_function.htm
https://www.tutorialspoint.com/advanced_excel_functions/advanced_excel_math_trignometric_rounddown_function.htm
https://www.tutorialspoint.com/advanced_excel_functions/advanced_excel_math_trignometric_roundup_function.htm
https://www.tutorialspoint.com/advanced_excel_functions/advanced_excel_math_trignometric_sum_function.htm
https://www.tutorialspoint.com/advanced_excel_functions/advanced_excel_math_trignometric_sumif_function.htm
https://www.tutorialspoint.com/advanced_excel_functions/advanced_excel_math_trignometric_sumifs_function.htm
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sum(cell address : cell address) 

Example: sum(C1:C3)=15 

Here in the example below, we will create a basic function to calculate the sum of working hours generates 

in a day. 

 

 

Select the cell where you want to put the formula, type the equals sign (=) and write the desired function 

name or choose the function from the suggested function list. Here in the example below we write the SUM 

function. 
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Now write the range of sum or you can select the range by using the mouse to drag. 
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Now press Enter key to see the result or press Ctrl+Enter key to stay in the formula cell. Here is the picture 

below. 

 

 

You can use the sum() function in other ways. Here is the syntax. 

sum(number1,number2,number3....) 

Example: sum(4,5,6)=15 

 

 

SUMIF(): 

Here in the example below, we will create a basic function to calculate the sum of working hours generates 

in a day only for female employees. 
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Syntax: 

SUMIF(  range,criteria)  

Type the equals sign and write the desired function in the cell E14. Here is the picture below. 
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Press Enter to see the result and move the cell pointer to below cell or press Ctrl+Enter to stay on the cell. 

 

 

AVERAGE(): 
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Here in the example below, we will create a basic function to calculate the average working hours of each 

employee. 

 

 

Press Enter key and see the result. 
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You can use the AVERAGEIF() and AVERAGEIFS() function in a similar way as SUMIF() function, to average 

cells based on one or multiple criteria. 

COUNT() 

Here in the example below, we will create a basic function to calculate the number of employees. 

 

 

ROUND(): 
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The round function is used to round a number to a specified number of digits. 

Syntax: 

ROUND(number, number_of_digits) 

 

 

RAND(): 

This function is used to returns a random number greater than or equal to 0 and less than 1. 

Syntax: 

RAND() 

 

 

MOD() 

This function is used to find the remainder after dividing a number by another number. 

Syntax: 

MOD(number,divisor) 



Page 41 of 182 
 

 

 

INT(): 

This function is used to converts a decimal number to integer lower than it. 

Syntax: 

INT(decimal number) 

 

 

AVERAGE(): 

Formula: 

This function is used to calculate the average of a range of cells. 

Syntax: 

AVERAGE(number1,number2,.......) 

 

 

ABS(): 
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The abs() function is used to return the absolute value of a given number. The number may be positive or 

negative. Here is the example below. 

 

 

ARABIC(): 

This function is used to convert roman numeral to arabic. This function accepts roman numeral as an 

argument. The picture below shows that you can write the formula in any cell or you can use the function 

wizard or you can select any cell and write the formula in the formula bar and press Ctrl+enter to stay the 

cell or press enter see the result. 

 

 

CEILING.MATH(): 

This function is used to rounds a number upto the nearest integer or to the nearest multiple significance. 

This function accepts three arguments, these are number, significance and mode. Number is a number, 

significance is the multiple to which you want to round and mode is also a number. Here in the example 
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below the number is 6.423 and the significance is 3 and the nearest multiple of 3 of the given number is 9 

and the mode is a nonzero, so this function starts rounding away from zero. 

 

 

Topic 3: Using Statistical Functions 

Statistical functions perform calculations ranging from basic mean, median & mode to the more complex 

statistical distribution and probability tests. 

S.No. Function and Description 

1 COUNT 

Counts how many numbers are in the list of arguments 

2 COUNTBLANK 

Counts the number of blank cells in the argument range 

3 COUNTIF 

Counts the number of cells that meet the criteria you specify in the argument 

4 COUNTIFS 

Counts the number of cells that meet multiple criteria 

5 MAX 

Returns the maximum value in a list of arguments, ignoring logical values and text 

6 MAXA 

Returns the maximum value in a list of arguments, including logical values and text 

https://www.tutorialspoint.com/advanced_excel_functions/advanced_excel_statistical_count_function.htm
https://www.tutorialspoint.com/advanced_excel_functions/advanced_excel_statistical_countblank_function.htm
https://www.tutorialspoint.com/advanced_excel_functions/advanced_excel_statistical_countif_function.htm
https://www.tutorialspoint.com/advanced_excel_functions/advanced_excel_statistical_countifs_function.htm
https://www.tutorialspoint.com/advanced_excel_functions/advanced_excel_statistical_max_function.htm
https://www.tutorialspoint.com/advanced_excel_functions/advanced_excel_statistical_maxa_function.htm
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7 MAXIFS 

Returns the maximum value among cells specified by a given set of conditions or 

criteria. 

8 MEDIAN 

Returns the median of the given numbers 

9 MIN 

Returns the minimum value in a list of arguments, ignoring logical values and text 

 

Average 

To calculate the average of a group of numbers, use the AVERAGE function. 

 

Note: visit our page about the AVERAGE function for many more examples. 

Averageif 

To average cells based on one criteria, use the AVERAGEIF function. For example, to calculate the average 

excluding zeros. 

 

Note: visit our page about the AVERAGEIF function for many more examples. 

Median 

To find the median (or middle number), use the MEDIAN function. 

 

https://www.tutorialspoint.com/advanced_excel_functions/advanced_excel_statistical_maxifs_function.htm
https://www.tutorialspoint.com/advanced_excel_functions/advanced_excel_statistical_median_function.htm
https://www.tutorialspoint.com/advanced_excel_functions/advanced_excel_statistical_min_function.htm
https://www.excel-easy.com/examples/average.html
https://www.excel-easy.com/examples/averageif.html
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Check: 

 

Mode 

To find the most frequently occurring number, use the MODE function. 

 

Note: visit our page about the MODE function to learn more about this Excel function. 

Standard Deviation 

To calculate the standard deviation, use the STEDV function. 

 

Note: standard deviation is a number that tells you how far numbers are from their mean. Learn more about 

this topic on our page about standard deviation. 

Min 

To find the minimum value, use the MIN function. 

 

Max 

To find the maximum value, use the MAX function. 

https://www.excel-easy.com/examples/mode.html
https://www.excel-easy.com/examples/standard-deviation.html
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Large 

To find the third largest number, use the following LARGE function. 

 

Check: 

 

Small 

To find the second smallest number, use the following SMALL function. 

 

Check: 

 

Tip: Excel can generate most of these results with the click of a button. 

 

LO 2.2: Use text financial, lookup and database functions 

Content/Topic 1: Use of Text Functions 
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S.No. Function and Description 

1 CONCATENATE 

Joins two or more text strings into one string. 

2 LEFT 

Returns the first character or characters in a text string, based on the number of 

characters you specify. 

3 LOWER 

Converts all uppercase letters in a text string to lowercase. 

4 MID 

Returns a specific number of characters from a text string, starting at the position 

you specify, based on the number of characters you specify. 

5 RIGHT 

Returns the last character or characters in a text string, based on the number of 

characters you specify. 

6 TEXT 

Converts a numeric value to text and lets you specify the display formatting by 

using special format strings. 

7 TRIM 

Removes all spaces from text except for single spaces between words. Use TRIM 

on text that you have received from another application that may have irregular 

spacing. 

The Excel TEXT Function is used to convert numbers to text within a spreadsheet. Essentially, the function 

will convert a numeric value into a text string. TEXT is available in all versions of Excel. 

Formula 

=Text(Value, format_text) 

Where: 

Value is the numerical value that we need to convert to text 

Format_text is the format we want to apply 

https://www.tutorialspoint.com/advanced_excel_functions/advanced_excel_statistical_concatenate_function.htm
https://www.tutorialspoint.com/advanced_excel_functions/advanced_excel_statistical_left_function.htm
https://www.tutorialspoint.com/advanced_excel_functions/advanced_excel_statistical_lower_function.htm
https://www.tutorialspoint.com/advanced_excel_functions/advanced_excel_statistical_mid_function.htm
https://www.tutorialspoint.com/advanced_excel_functions/advanced_excel_statistical_right_function.htm
https://www.tutorialspoint.com/advanced_excel_functions/advanced_excel_statistical_text_function.htm
https://www.tutorialspoint.com/advanced_excel_functions/advanced_excel_statistical_trim_function.htm
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When is the Excel TEXT Function required? 

We use the TEXT function in the following circumstances: 

1. When we want to display dates in a specified format 

2. When we wish to display numbers in a specified format or in a more legible way 

3. When we wish to combine numbers with text or characters 

  

Examples 

1. Basic example – Excel Text Function 

With the following data, I need to convert the data to “d mmmm, yyyy” format. When we insert the text 

function, the result would look as follows: 

  

 

  

2. Using Excel TEXT with other functions 

We use the old price and the discount given in cells A5 and B5. The quantity is given in C5. We wish to show 

some text along with the calculations. We wish to display the information as follows: 

The final price is $xxx 

Where xxx would be the price in $ terms. 

For this, we can use the formula: 

=”The final price is “&TEXT(A5*B5*C5, “$###,###.00”) 
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The other way to do it by using the CONCATENATE function as shown below: 
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3. Combining the text given with data using TEXT function 

When I use the date formula, I would get the result below:  

Now, if we try to combine today’s date using CONCATENATE, Excel would give a weird result as shown below: 

What happened here was that dates that are stored as numbers by Excel were returned as numbers when 

the CONCATENATE function is used. 

How to fix it? 

To fix it, we need to use the Excel TEXT function. The formula to be used would be: 

 

4. Adding zeros before numbers with variable lengths 

We all know any zero’s added before numbers are automatically removed by Excel. However, if we need to 

keep those zeros then the TEXT function comes handy.  Let’s see an example to understand how to use this 

function. 

We are given a 9-digit product code, but Excel removed the zeros before it. We can use TEXT as shown below 

and convert the product code into a 9-digit number: 

In the above formula, we are given the format code containing 9-digit zeros, where the number of zeros is 

equal to the number of digits we wish to display. 

5. Converting telephone numbers to a specific format 

If we wish to do the same for telephone numbers, it would involve the use of dashes and parentheses in 

format codes. 

Here, I want to ensure the country code comes in brackets (). Hence the formula used is (##) ### ### ###. 

The # is the number of digits we wish to use. 

  

Format Code 
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It is quite easy to use TEXT Function in Excel but it works only when the correct format code is provided. 

Some frequently used format codes include: 

  

Code Description Example 

# (hash) It does not display extra 

zeros 

#.# displays a single decimal point. If we input 5.618, it 

will display 5.6. 

0 (zero) It displays insignificant 

zeros 

#.000 would always display 3 decimals after the 

number. So if we input 5.68, it will display 5.680. 

, (comma) It is a thousand separator ###,### would put a thousands separator. So if we 

input 259890, it will display 259,890. 

  

If the Excel TEXT function isn’t working 

Sometimes, the TEXT function will give an error “#NAME?”. This happens when we skip the quotation marks 

around the format code. 

Let’s take an example to understand this. 

If we input the formula =TEXT(A2, mm-dd-yy). It would give an error because the formula is incorrect and 

should be written this way: =TEXT(A2,”mm-dd-yy”). 

  

Tips 

1. The data converted into text cannot be used for calculations. If needed, we should keep the original 

data in a hidden format and use it for other formulas. 

2. The characters that can be included in the format code are: 

  

+ Plus sign 

- Minus sign 

() Parenthesis 

: Colon 
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{} Curly brackets 

= Equal sign 

~ Tilde 

/ Forward slash 

! Exclamation mark 

<> Less than and greater than 

 

Content/Topic 4: Use of Financial Functions 

 

Excel Financial functions perform many of the common financial calculations, such as the calculation of yield, 

interest rates, duration, valuation and asset depreciation. 

S.No. Function and Description 

1 FV 

Returns the future value of an investment 

2 PMT 

Returns the periodic payment for an annuity 

3 PV 

Returns the present value of an investment 

Excel text functions (string functions) 

There exist a great lot of Microsoft Excel functions to manipulate text strings. Here are the most essential 

ones: 

TEXT function 

TEXT(value, format_text) is used to convert a number or a date into a test string in the specified format, 

where: 

 Value is a numeric value you want to convert to text. 

 Format_text is the desired format. 

The following formulas demonstrate the Excel TEXT function in action: 

=TEXT(A1,"mm/dd/yyyy") - convert a date in cell A1 into a text string in the traditional US date format, such 

as "01/01/2015" (month/day/year). 

https://www.tutorialspoint.com/advanced_excel_functions/advanced_excel_financial_fv_function.htm
https://www.tutorialspoint.com/advanced_excel_functions/advanced_excel_financial_pmt_function.htm
https://www.tutorialspoint.com/advanced_excel_functions/advanced_excel_financial_pv_function.htm
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=TEXT(A1,"€#,##0.00") - converts a number in A1 into a currency text string such as "€3.00". 

 

 

 

TEXT formula examples: 

 TEXT function to convert a date to text format 

 TEXT formulas to convert a number to text 

CONCATENATE function 

CONCATENATE(text1, [text2], …) is designed to join several pieces of text together or combine values from 

several cells into a single cell. An analogues result can be achieved by using the Excel & operator, as 

demonstrated in the following screenshot. 

 

You can find plenty more formula examples in the tutorial CONCATENATE in Excel: combine text strings, cells 

and columns. 

TRIM function 

TRIM(text) removes leading, trailing spaces as well as excess spaces between words. Where text is either a 

text string or reference to the cell containing the text from which you want to remove spaces. The following 

screenshot demonstrates an example of usage: 

 

For more formula examples, see 3 ways to remove spaces between words / numbers in Excel. 

https://www.ablebits.com/office-addins-blog/2015/04/08/convert-date-text-excel/#excel-text-function
https://www.ablebits.com/office-addins-blog/2014/10/10/excel-convert-number-text/#excel-text-function
https://www.ablebits.com/office-addins-blog/2015/07/15/excel-concatenate-strings-cells-columns/
https://www.ablebits.com/office-addins-blog/2015/07/15/excel-concatenate-strings-cells-columns/
https://www.ablebits.com/office-addins-blog/2013/11/15/trim-spaces-between-words/


Page 54 of 182 
 

SUBSTITUTE function 

SUBSTITUTE(text, old_text, new_text, [instance_num]) replaces one set of characters with another in a 

specified cell or a text string. The syntax of the SUBSTITUTE function is as follows: 

 Text - the original text string or reference to a cell where you want to substitute certain characters. 

 Old_text - the characters you want to replace. 

 New_text - the characters you want to replace the old text with. 

 Nth_appearance - an optional parameter that specifies which occurrence of old_text you want to replace 

with new_text. If omitted, then every occurrence of the old text will be replaced with the new text. 

For example, the following SUBSTITUTE formula replaces all commas in cell A1 with semicolons: 

=SUBSTITUTE(A2, ",", ";") 

 

SUBSTITUTE formula examples: 

 Removing line breaks in a cell 

 Converting text strings with custom delimiters to dates 

VALUE function 

VALUE(text) - converts a text string to a number. 

This function is really helpful when it comes to converting text-formatted values representing the numbers 

into numbers that can be used in other Excel formulas and calculations. 

VALUE formula examples: 

 Convert text-formatted digits to number 

 VALUE function to convert text to date 

https://www.ablebits.com/office-addins-blog/2013/12/03/remove-carriage-returns-excel/#delete-line-breaks-excel-formula
https://www.ablebits.com/office-addins-blog/2015/03/26/excel-convert-text-date/#text2date-custom-delimiters
https://www.ablebits.com/office-addins-blog/2014/10/28/excel-convert-text-number/
https://www.ablebits.com/office-addins-blog/2015/03/26/excel-convert-text-date/#excel-value-function
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EXACT function 

EXACT(text1, text2) compares two text strings and returns TRUE if both values are exactly the same, 

including case, FALSE otherwise. 

For example, if A2 is "apples" and B2 is "Apples", the formula =EXACT(A2, B2) will returns FALSE, because 

they are not exact match. 

The EXACT function is rarely used on its own, but it's helpful in more complex tasks such as doing a case-

sensitive Vlookup in Excel. 

Functions to change text's case (UPPER, LOWER, PROPER) 

Microsoft Excel provides 3 text functions to convert between UPPER, lower and Proper case. 

UPPER(text) - converts all characters in a specified text string to upper case. 

LOWER(text) - changes all uppercase letters in a text string to lowercase. 

Proper(text) - capitalizes the first letter of each word and converts all other letters to lowercase (more 

precisely, it capitalizes the letters that follow any character other than a letter). 

In all three functions, the text argument can be a text string enclosed in quotation marks, a reference to a 

cell containing the text or a formula that returns the text. 

 

More formula examples to convert text's case can be found in Changing text case in Excel to UPPER, lower 

or Proper. 

Extract text characters (LEFT, RIGHT, MID) 

If you need a formula to return a certain number of characters from a text string, use one of the following 

Excel functions. 

https://www.ablebits.com/office-addins-blog/2014/08/19/vlookup-case-sensitive-excel/
https://www.ablebits.com/office-addins-blog/2014/08/19/vlookup-case-sensitive-excel/
https://www.ablebits.com/office-addins-blog/2014/04/25/change-case-excel-uppercase-lowercase/
https://www.ablebits.com/office-addins-blog/2014/04/25/change-case-excel-uppercase-lowercase/
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LEFT(text, [num_chars]) - returns a specified number of characters from the beginning of a text string. 

RIGHT(text,[num_chars]) - returns a specified number of characters from the end of a text string. 

MID(text, start_num, num_chars) - returns a specific number of characters from a text string, starting at any 

position that you specify. 

In these functions, you supply the following arguments: 

 Text - a text string or a reference to a cell containing the characters you want to extract. 

 Start_num - indicates where to start (i.e. the position of the first character you want to extract). 

 Num_chars - the number of characters you want to extract. 

 

One of the main uses of these Excel text functions is splitting a cell's content into several cells, as 

demonstrated in Formulas to split cells in Excel. 

Logical functions in Excel 

Microsoft Excel provides a handful of logical functions that evaluate a specified condition(s) and return the 

corresponding value. 

AND, OR, XOR functions 

AND(logical1, [logical2], …) - returns TRUE if all of the arguments evaluate to TRUE, FALSE otherwise. 

OR(logical1, [logical2], …) - returns TRUE if at least one of the arguments is TRUE. 

https://www.ablebits.com/office-addins-blog/2014/02/27/split-cells-excel/#split-cells-formulas
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XOR(logical1, [logical2],…) - returns a logical Exclusive Or of all arguments. This function was introduced in 

Excel 2013 and is not available in earlier versions. 

 

 

 

Logical functions formula examples: 

 AND formula examples 

 OR formula examples 

 XOR formula examples 

NOT function 

NOT(logical) - reverses a value of its argument, i.e. if logical evaluates to FALSE, the NOT function returns 

TRUE and vice versa. 

For instance, both of the following formulas will return FALSE: 

=NOT(TRUE) 

=NOT(2*2=4) 

For more NOT function examples, see Using the NOT function in Excel. 

IF function 

The Excel IF function is sometimes called a "conditional function" because it returns a value based on the 

condition that you specify. IF's syntax is as follows: 

IF(logical_test, [value_if_true], [value_if_false]) 

An IF formula tests the condition(s) expressed in the logical_test argument and returns one value 

(value_if_true) if the condition is met and another value (value_if_false) if the condition is not met. 

For example, the formula =IF(A1<>"", "good", "bad") returns "good" if there's any value in cell A1, "bad" 

otherwise. 

https://www.ablebits.com/office-addins-blog/2014/12/17/excel-and-or-xor-not-functions/#excel-and-function
https://www.ablebits.com/office-addins-blog/2014/12/17/excel-and-or-xor-not-functions/#excel-or-function
https://www.ablebits.com/office-addins-blog/2014/12/17/excel-and-or-xor-not-functions/#excel-xor-function
https://www.ablebits.com/office-addins-blog/2014/12/17/excel-and-or-xor-not-functions/#excel-not-function
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And here's an example of the nested IF formula that "deciphers" the exam score in cell A2: 

=IF(A2>80, "Brilliant", IF(A2>50, "Good", IF(A2>30, "Fair", "Poor"))) 

 

IF formula examples: 

 IF formulas for numbers, text, dates, blank cells 

 IF statement with multiple AND/OR conditions 

 Nested IF functions in Excel 

 IF function in array formulas 

 Using IF with other Excel functions 

IFERROR and IFNA functions 

Both functions are used to check if a certain formula evaluates to an error, and if it does, the MS Excel 

functions return a specified value instead. 

IFERROR(value, value_if_error) - checks if the formula or expression evaluates to an error. If it does, the 

formula returns the value supplied in the value_if_error argument, otherwise, the result of the formula is 

returned. This function handles all possible Excel errors, including VALUE, N/A, NAME, REF, NUM, and others. 

It is available in Excel 2007 and higher. 

IFNA(value, value_if_na) - introduced in Excel 2013, it works similarly to IFERROR, but handles #N/A errors 

only. 

The following examples demonstrate the simplest IFERROR formula: 

 

IFERROR / IFNA formula examples: 

 Using the IFERROR and IFNA functions in Excel 

https://www.ablebits.com/office-addins-blog/2014/11/26/if-function-excel/#if-formula-examples
https://www.ablebits.com/office-addins-blog/2014/12/03/excel-if-function-iferrror-ifna/#excel-if-multiple-and-or
https://www.ablebits.com/office-addins-blog/2016/12/07/nested-if-excel-multiple-conditions/
https://www.ablebits.com/office-addins-blog/2014/12/03/excel-if-function-iferrror-ifna/#excel-if-array
https://www.ablebits.com/office-addins-blog/2014/12/03/excel-if-function-iferrror-ifna/#if-other-excel-functions
https://www.ablebits.com/office-addins-blog/2014/12/03/excel-if-function-iferrror-ifna/#iferror-ifna
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 Excel VLOOKUP with IFERROR / ISERROR 

Excel math functions 

Excel has a ton of basic and advanced functions to perform mathematical operations, calculate exponentials, 

logarithms, factorials and the like. It would take several pages just to publish the functions list. So, let us 

discuss only a few basic math functions that may prove useful for solving your daily tasks. 

Finding the sum of cells 

Four essential Excel functions to add up the values of cells in a specified range follow below. 

SUM function 

SUM(number1,[number2],…) returns the sum of its arguments. The arguments can be numbers, cells 

references or formula-driven numeric values. 

For example, the simplest math formula =SUM(A1:A3, 1) adds up the values in cells A1, A2 and A3, and then 

adds 1 to the result. 

SUM formula examples: 

 SUM function to sum a column In Excel 

 Excel SUM in array formulas 

SUMIF and SUMIFS functions (conditional sum) 

Both functions add up the cells in a specified range that meet a certain condition. The difference is that 

SUMIF can evaluate only a single criteria, while SUMIFS, introduced in Excel 2007, allows for multiple criteria. 

Please pay attention that the order of arguments is different in each function: 

SUMIF(range, criteria, [sum_range]) 

  

SUMIFS(sum_range, criteria_range1, criteria1, [criteria_range2, criteria2], …) 

 range / criteria_range - the range of cells to be evaluated by the corresponding criteria. 

 criteria - the condition that must be met. 

 sum_range - the cells to sum if the condition is met. 

https://www.ablebits.com/office-addins-blog/2014/08/27/excel-vlookup-not-working/#vlookup-iferror
https://www.ablebits.com/office-addins-blog/2014/10/31/excel-sum-column/#sum-function
https://www.ablebits.com/office-addins-blog/2014/11/12/excel-sumifs-sumif-multiple-criteria/#sum-array-formula
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The following screenshot gives an idea of how the SUMIF and SUMIFS functions can be used on real-life data: 

 

SUMIF and SUMIFS formula examples: 

 SUMIF in Excel - formulas to conditionally sum cells 

 Sum cells with multiple criteria 

SUMPRODUCT function 

SUMPRODUCT(array1,array2, …) is one of the few Microsoft Excel functions that handle arrays. It multiplies 

the supplied array components and returns the sum of the products. 

The essence of the SUMPRODUCT function may be difficult to grasp, and hopefully the following examples 

will shed some light on its major uses. 

SUMPRODUCT formula examples: 

 SUMPRODUCT formula for a case-sensitive Vlookup 

 Count duplicates between two columns 

 Sum cells with multiple criteria 

Generating random numbers (RAND and RANDBETWEEN) 

Microsoft Excel provides 2 functions to generate random numbers. Both are volatile functions, meaning that 

a new number is returned every time the worksheet calculate s. 

RAND() - returns a random real (decimal) number between 0 and 1. 

RANDBETWEEN(bottom, top) - returns a random integer between the bottom and top numbers that you 

specify. 

https://www.ablebits.com/office-addins-blog/2014/11/04/excel-sumif-function-formula-examples/
https://www.ablebits.com/office-addins-blog/2014/11/12/excel-sumifs-sumif-multiple-criteria/
https://www.ablebits.com/office-addins-blog/2014/08/19/vlookup-case-sensitive-excel/#SUMPRODUCT-case-sensitive
https://www.ablebits.com/office-addins-blog/2014/07/02/excel-countif-examples/#duplicates-two-columns
https://www.ablebits.com/office-addins-blog/2014/11/12/excel-sumifs-sumif-multiple-criteria/#sumproduct-sumif
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The following tutorial makes a pretty good job explaining the nuts and bolts of each function with formula 

examples: How to use RAND and RANDBETWEEN functions in Excel. 

Rounding functions 

There exist a variety of functions to round off numbers in Excel, and our Excel Rounding Tutorial makes a 

good job explaining how to use those functions based on your criteria. Please click on the function's name 

to learn its syntax and examples of uses. 

 ROUND - round the number to the specified number of digits. 

 ROUNDUP - round the number upward to the specified number of digits. 

 ROUNDDOWN - round the number downward to the specified number of digits. 

 MROUND - rounds the number upward or downward to the specified multiple. 

 FLOOR - round the number down to the specified multiple. 

 CEILING - round the number up to the specified multiple. 

 INT - round the number down to the nearest integer. 

 TRUNC - truncate the number to a specified number of decimal places. 

 EVEN - round the number up to the nearest even integer. 

 ODD - round the number up to the nearest odd integer. 

Getting the remainder after division (MOD function) 

MOD(number, divisor) returns the remainder after the number argument is divided by divisor. 

The function comes in really handy in many scenarios, for example: 

 Sum values in every other or Nth row 

 Alternating row colors in Excel 

Statistical functions in Excel 

Among a variety of highly specific Excel statistical functions, there are a few ones that everyone can 

understand and leverage for professional data analysis. 

Finding the largest, smallest and average values 

MIN(number1, [number2], …) - returns the minimal value from the list of arguments. 

https://www.ablebits.com/office-addins-blog/2015/07/08/random-number-generator-excel/
https://www.ablebits.com/office-addins-blog/2015/08/06/excel-round-functions/#ROUND-function
https://www.ablebits.com/office-addins-blog/2015/08/06/excel-round-functions/#ROUNDUP-function
https://www.ablebits.com/office-addins-blog/2015/08/06/excel-round-functions/#ROUNDDOWN-function
https://www.ablebits.com/office-addins-blog/2015/08/06/excel-round-functions/#MROUND-function
https://www.ablebits.com/office-addins-blog/2015/08/06/excel-round-functions/#FLOOR-function
https://www.ablebits.com/office-addins-blog/2015/08/06/excel-round-functions/#CEILING-function
https://www.ablebits.com/office-addins-blog/2015/08/06/excel-round-functions/#INT-function
https://www.ablebits.com/office-addins-blog/2015/08/06/excel-round-functions/#TRUNC-function
https://www.ablebits.com/office-addins-blog/2015/08/06/excel-round-functions/#EVEN-function
https://www.ablebits.com/office-addins-blog/2015/08/06/excel-round-functions/#ODD-function
https://www.ablebits.com/office-addins-blog/2015/03/04/excel-array-formula-examples/#sum-every-nth-row
https://www.ablebits.com/office-addins-blog/2014/03/13/alternate-row-column-colors-excel/
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MAX(number1, [number2], …) - returns the maximum value from the list of arguments 

AVERAGE(number1, [number2], …) - returns the average of the arguments. 

SMALL(array, k) - returns the k-th smallest value in the array. 

LARGE(array, k) - returns the k-th largest value in the array. 

The following screenshot demonstrates the basic statistical functions in action. 

 

Formula examples: 

 Using IF with AVERAGE, MIN and MAX functions 

 Calculating the average of the top N items in the list - Example 1. Calculate average of the top N items in the 

list 

 VLOOKUP with AVERAGE, MAX, MIN (array formulas) 

 Sum N largest / smallest numbers in a range (array formula) 

Counting cells 

Below is a list of Excel functions that let you count the cells containing a certain data type or based on the 

condition(s) that you specify. 

COUNT(value1, [value2], …) - returns the number of numerical values (numbers and dates) in the list of 

arguments. 

COUNTA(value1, [value2], …) - returns the number of non-empty cells in the list of arguments. It counts cells 

containing any information, including error values and empty text strings ("") returned by other formulas. 

COUNTBLANK(range) - counts the number of empty cells in a specified range. Cells with empty text strings 

("") are also counted as blank cells. 

COUNTIF(range, criteria) - counts the number of cells within the range that meet the specified criteria. 

https://www.ablebits.com/office-addins-blog/2014/12/03/excel-if-function-iferrror-ifna/#if-other-excel-functions
https://www.ablebits.com/office-addins-blog/2015/02/18/excel-index-function/#index-other-functions
https://www.ablebits.com/office-addins-blog/2014/08/05/excel-vlookup-sum-sumif/#vlookup-average-max-min
https://www.ablebits.com/office-addins-blog/2015/02/25/array-formulas-functions-excel/#sum-n-largest
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COUNTIFS(criteria_range1, criteria1, [criteria_range2, criteria2]…) - counts the number of cells that meet 

all of the specified criteria. 

The following screenshot demonstrates the counting cells functions in action: 

 

Note. Since dates are stores as numbers in Excel, they are also counted by Excel statistical functions. For 

example, the formula =COUNTIF(A2:A9, ">5") counts the date in cell A8 in the screenshot above because it 

is stored as 42005 in the internal Excel system. 

Counting cells formula examples: 

 Counting cells with text (COUNTA and COUNT functions) 

 Counting empty cells in Excel (COUNTBLANK) 

 Counting blank or not blank cells (COUNTIF) 

 Using COUNTIF in Excel 

 Counting cells with multiple criteria (COUNTIFS) 

Excel lookup and reference functions 

These MS Excel functions comes in handy when you need to find certain information in a table based on a 

value in one column, or return a reference to a certain cell. 

VLOOKUP function 

The VLOOKUP function looks for a specified value in the first column and pulls the matching data from the 

same row in another column. It requires the following arguments: 

VLOOKUP (lookup_value, table_array, col_index_num, [range_lookup]) 

 lookup_value - the value to search for. 

 table_array - two or more columns of data. 

 col_index_num - the number of the column to pull the data from. 

https://www.ablebits.com/office-addins-blog/2015/02/19/excel-count-text-characters/#count-text-cells
https://www.ablebits.com/office-addins-blog/2014/06/19/excel-count-blank-cells/#count-empty-formulas
https://www.ablebits.com/office-addins-blog/2014/07/02/excel-countif-examples/#countif-blank
https://www.ablebits.com/office-addins-blog/2014/07/02/excel-countif-examples/
https://www.ablebits.com/office-addins-blog/2014/07/10/excel-countifs-multiple-criteria/
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 range_lookup - determines whether to search with exact match (FALSE) or approximate match (TRUE or 

omitted). 

For example, the formula =VLOOKUP("apples", A2:C10, 3) searches for "apples" in cells A2 through A10 and 

returns a matching value from column C: 

VLOOKUP formula examples: 

 Excel VLOOKUP tutorial for beginners 

 How to use VLOOKUP & SUM or SUMIF functions in Excel 

 Two-way lookup, nested Vlookup with multiple criteria 

 4 ways to do a case-sensitive Vlookup in Excel 

 Excel VLOOKUP not working - solutions for N/A, NAME and VALUE errors 

INDEX function 

INDEX(array, row_num, [column_num]) - returns a reference to a cell within array based on the row and 

column numbers that you specify. 

Here is a simple INDEX formula: =INDEX(A1:C10, 3 ,4) that searches in cells A1 through C10 and returns a 

value at the intersection of the 3rd row and 4th column, which is cell D3. 

The following tutorial explains the INDEX function in full detail: 6 most efficient uses of the INDEX function 

in Excel. 

MATCH function 

MATCH(lookup_value, lookup_array, [match_type]) - searches for lookup_value in lookup_array, and then 

returns the relative position of that item in the range. 

The combination of the MATCH and INDEX functions can be used as a more powerful and versatile alternative 

to Excel's VLOOKUP, as demonstrated in the following tutorial: INDEX & MATCH - a better alternative to 

VLOOKUP in Excel. 

INDIRECT function 

INDIRECT(ref_text, [a1]) - returns a cell or range reference specified by a text string. 

https://www.ablebits.com/office-addins-blog/2014/07/17/excel-vlookup-tutorial-beginner/
https://www.ablebits.com/office-addins-blog/2014/08/05/excel-vlookup-sum-sumif/
https://www.ablebits.com/office-addins-blog/2014/07/29/vlookup-formula-examples/
https://www.ablebits.com/office-addins-blog/2014/08/19/vlookup-case-sensitive-excel/
https://www.ablebits.com/office-addins-blog/2014/08/27/excel-vlookup-not-working/
https://www.ablebits.com/office-addins-blog/2015/02/18/excel-index-function/
https://www.ablebits.com/office-addins-blog/2015/02/18/excel-index-function/
https://www.ablebits.com/office-addins-blog/2014/08/13/excel-index-match-function-vlookup/
https://www.ablebits.com/office-addins-blog/2014/08/13/excel-index-match-function-vlookup/
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Here's an example of the simplest INDIRECT formula to get the general idea: 

 

In real worksheets, INDIRECT formulas are often used to dynamically refer to another sheet or workbook, to 

lock a cell reference or to create dependent drop down lists. 

INDIRECT formula examples: 

 How to use the INDIRECT function in Excel 

 How to make a dependent drop down list in Excel 

OFFSET function 

OFFSET(reference, rows, cols, [height], [width]) - returns a reference to a range of cells that is offset from a 

starting cell or a range of cells by the specified number of rows and columns. 

For example, =OFFSET(A1, 1, 2) returns the value in cell C2 because it's 1 row down and 2 columns to the 

left from A1. 

For more OFFSET formula examples, please see: Using OFFSET function in Excel. 

TRANSPOSE function 

TRANSPOSE(array) - transforms a horizontal range of cells into a vertical range and vice versa, i.e. converts 

rows to columns and columns to rows. 

The following tutorial provides formula examples and explains the strong and weak points of the TRANSPOSE 

function: How to transpose in Excel - convert row to column and vice versa. 

HYPERLINK function 

HYPERLINK(link_location, [friendly_name]) - Creates a hyperlink to a document stored on a local network 

or the Internet. 

For the step-by-step guidance in using the HYPERLINK function, please see: How to add a hyperlink to 

another Excel sheet. 

https://www.ablebits.com/office-addins-blog/2015/02/10/excel-indirect-function/
https://www.ablebits.com/office-addins-blog/2014/09/30/dependent-cascading-dropdown-lists-excel/
https://www.ablebits.com/office-addins-blog/2015/02/11/excel-offset-function/
https://www.ablebits.com/office-addins-blog/2014/03/06/transpose-excel-rows-columns/#transpose-excel-formulas
https://www.ablebits.com/office-addins-blog/2014/05/15/excel-insert-hyperlink/#hyperlink-function
https://www.ablebits.com/office-addins-blog/2014/05/15/excel-insert-hyperlink/#hyperlink-function
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Excel financial functions 

Microsoft Excel provides a host of functions to simplify the work of accounting managers, financial analysts 

and banking specialists. On this blog, we have discussed only one financial function so far, which can be used 

to calculate compound interest. 

FV function 

FV(rate, nper ,pmt ,[pv], [type]) - calculates the future value of an investment based on a constant interest 

rate. 

The following tutorial explains each of the arguments in detail and guides you in creating a universal 

compound interest calculator in your worksheets: Creating an advanced compound interest calculator for 

Excel. 

Excel date functions 

For everyone who deals with Excel dates on a regular basis, I'd recommend our comprehensive 12-part Excel 

Date tutorial that covers each date function in depth. This page only provides the functions list along with 

the links to more resources. 

Creating dates 

 DATE - returns the serial number of a specified date. 

 DATEVALUE - converts a text string representing the date to date format. 

Current date and time 

 TODAY - returns the current date. 

 NOW - returns the current date and time. 

Extracting dates and date components 

 DAY - returns the day of the month. 

 MONTH - returns the month of a specified date. 

 YEAR - returns the year of a specified date. 

 EOMONTH - returns the last day of the month. 

https://www.ablebits.com/office-addins-blog/2015/01/21/compound-interest-formula-excel/#excel-compound-interest-calculator
https://www.ablebits.com/office-addins-blog/2015/01/21/compound-interest-formula-excel/#excel-compound-interest-calculator
https://www.ablebits.com/office-addins-blog/2015/06/10/excel-date-functions/
https://www.ablebits.com/office-addins-blog/2015/06/10/excel-date-functions/
https://www.ablebits.com/office-addins-blog/2015/06/10/excel-date-functions/#DATE-function
https://www.ablebits.com/office-addins-blog/2015/06/10/excel-date-functions/#DATEVALUE
https://www.ablebits.com/office-addins-blog/2015/06/10/excel-date-functions/#TODAY
https://www.ablebits.com/office-addins-blog/2015/06/10/excel-date-functions/#NOW
https://www.ablebits.com/office-addins-blog/2015/06/10/excel-date-functions/#DAY
https://www.ablebits.com/office-addins-blog/2015/06/10/excel-date-functions/#MONTH
https://www.ablebits.com/office-addins-blog/2015/06/10/excel-date-functions/#YEAR
https://www.ablebits.com/office-addins-blog/2015/06/10/excel-date-functions/#EOMONTH
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 WEEKDAY - returns the day of the week. 

 WEEKNUM - returns the week number of a date. 

Calculating date difference 

 DATEDIF - returns the difference between two dates. 

 EDATE - returns a date that is the specified number of months before or after the start date. 

 YEARFRAC - calculates the fraction of the year between 2 dates. 

Calculate workdays 

 WORKDAY - calculates a date that is a specified number of working days before or after the start date. 

 WORKDAY.INTL - calculates a date that is a specified number of weekdays before or after the start date, with 

custom weekend parameters. 

 NETWORKDAYS - returns the number of working days between two dates. 

 NETWORKDAYS.INTL - returns the number of workdays between two dates with custom weekends. 

Excel time functions 

Below follows a list of the major Excel functions to work with times. 

TIME(hour, minute, second) - returns a serial number representing the time. 

TIMEVALUE(time_text) - converts a time entered in the form of a text string to a serial number representing 

the time. 

NOW() - returns the serial number corresponding to the current date and time. 

HOUR(serial_number) - converts a specified serial number to an hour. 

MINUTE(serial_number) - converts a specified serial number to minutes. 

SECOND(serial_number) - converts a specified serial number to seconds. 

Time formula examples: 

 Converting time to decimal number, hours, minutes or seconds 

 Calculating times in Excel - time difference, adding / subtracting times 

https://www.ablebits.com/office-addins-blog/2015/06/10/excel-date-functions/#WEEKDAY
https://www.ablebits.com/office-addins-blog/2015/06/10/excel-date-functions/#WEEKNUM
https://www.ablebits.com/office-addins-blog/2015/06/10/excel-date-functions/#DATEDIF
https://www.ablebits.com/office-addins-blog/2015/06/10/excel-date-functions/#EDATE
https://www.ablebits.com/office-addins-blog/2015/06/10/excel-date-functions/#YEARFRAC
https://www.ablebits.com/office-addins-blog/2015/06/10/excel-date-functions/#WORKDAY
https://www.ablebits.com/office-addins-blog/2015/06/10/excel-date-functions/#WORKDAY.INTL
https://www.ablebits.com/office-addins-blog/2015/06/10/excel-date-functions/#NETWORKDAYS
https://www.ablebits.com/office-addins-blog/2015/06/10/excel-date-functions/#NETWORKDAYS.INTL
https://www.ablebits.com/office-addins-blog/2015/07/01/excel-convert-time-decimal/
https://www.ablebits.com/office-addins-blog/2015/06/24/calculate-time-excel/
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 NOW and TIME functions to insert time in Excel 

Count and sum cells by color (user defined functions) 

Microsoft Excel does not have any built-in function to count and sum cells by color, so we took a step forward 

and created a few custom ones. These functions are written in VBA, and you can add them to your 

worksheets though Excel's programming environment - Visual Basic for Applications editor. Here's our 

custom Excel functions list: 

 GetCellColor(cell) - returns the color code of the background color of a specified cell. 

 GetCellFontColor(cell) - returns the color code of the font color of a specified cell. 

 CountCellsByColor(range, color code) - counts cells with the specified background color. 

 CountCellsByFontColor(range, color code) - counts cells with the specified font color. 

 SumCellsByColor(range, color code) - calculates the sum of cells with a certain background color. 

 SumCellsByFontColor(range, color code) - returns the sum of cells with a certain font color. 

 WbkCountCellsByColor(cell) - counts cells with the specified background color in the entire workbook. 

 WbkSumCellsByColor(cell) - sums cells with the specified background color in the entire workbook. 

You can download the VBA code of the above functions along with detailed instructions on how to use them 

from the following page: How to count and sum cells by color in Excel. 

 

Content/Topic 5: Use of Lookup Functions 

Lookup functions help you to work with arrays of data, and are particularly useful when you need to cross 

reference between different data sets. They perform tasks such as providing information about a range, 

returning the location of a given address or value, or looking up specific values. 

S.No. Function and Description 

1 HLOOKUP 

Searches for a value in the top row of a table and then returns a value in the same 

column from a row you specify in the table 

2 VLOOKUP 

Searches for a value in the leftmost column of a table and then returns a value in 

the same row from a column you specify in the table 

 

https://www.ablebits.com/office-addins-blog/2015/06/23/excel-time-format-now-time-functions/
https://www.ablebits.com/office-addins-blog/2013/12/12/count-sum-by-color-excel/
https://www.tutorialspoint.com/advanced_excel_functions/advanced_excel_lookup_reference_hlookup_function.htm
https://www.tutorialspoint.com/advanced_excel_functions/advanced_excel_lookup_reference_vlookup_function.htm
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Example (as Worksheet Function) 

Let's look at some Excel LOOKUP function examples and explore how to use the LOOKUP function as a 

worksheet function in Microsoft Excel: 

 

Based on the Excel spreadsheet above, the following LOOKUP examples would return: 

=LOOKUP(10251, A1:A6, B1:B6) 

Result: "Pears" 

=LOOKUP(10251, A1:A6) 

Result: 10251 

=LOOKUP(10246, A1:A6, B1:B6) 

Result: #N/A 

=LOOKUP(10248, A1:A6, B1:B6) 

Result: "Apples" 

LOOKUP Function (Syntax #2) 

In Syntax #2, the LOOKUP function searches for the value in the first row or column of the array and returns 

the corresponding value in the last row or column of the array. 

The syntax for the LOOKUP function in Microsoft Excel is: 

LOOKUP( value, array ) 
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Parameters or Arguments 

value 

The value to search for in the array. The values must be in ascending order. 

array 

An array of values that contains both the values to search for and return. 

Returns 

The LOOKUP function returns any datatype such as a string, numeric, date, etc. If the LOOKUP function can 

not find an exact match, it chooses the largest value in the lookup_range that is less than or equal to 

the value. 

If the value is smaller than all of the values in the lookup_range, then the LOOKUP function will return #N/A. 

If the values in the array are not sorted in ascending order, the LOOKUP function will return the incorrect 

value. 

Applies To 

 Excel for Office 365, Excel 2019, Excel 2016, Excel 2013, Excel 2011 for Mac, Excel 2010, Excel 2007, Excel 2003, 

Excel XP, Excel 2000 

Type of Function 

 Worksheet function (WS) 

Example (as Worksheet Function) 

Let's look at some Excel LOOKUP function examples and explore how to use the LOOKUP function as a 

worksheet function in Microsoft Excel: 

=LOOKUP("T", {"s","t","u","v";10,11,12,13}) 

Result: 11 

=LOOKUP("Tech on the Net", {"s","t","u","v";10,11,12,13}) 

Result: 11 

=LOOKUP("t", {"s","t","u","v";"a","b","c","d"}) 

Result: "b" 

=LOOKUP("r", {"s","t","u","v";"a","b","c","d"}) 

Result: #N/A 
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=LOOKUP(2, {1,2,3,4;511,512,513,514}) 

Result: 512 

Frequently Asked Questions 

Question: In Microsoft Excel, I have a table of data in cells A2:D5. I've tried to create a simple LOOKUP to 

find CB2 in the data, but it always returns 0. What am I doing wrong? 

Answer: Using the LOOKUP function can sometimes be a bit tricky so let's look at an example. Below we 

have a spreadsheet with the data that you described. 

 

In cell F1, we've placed the following formula: 

=LOOKUP("CB2",A2:A5,D2:D5) 

And yes, even though CB2 exists in the data, the LOOKUP function returns 0. 

Now, let's explain what is happening. At first, it looks like the function isn't finding CB2 in the list, but in fact, 

it is finding something else. Let's fill in the empty cells in D3:D5 to explain better. 
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If we place the values TEST1, TEST2, TEST3 in cells D3, D4, 5, respectively, we can see that the LOOKUP 

function is in fact returning the value TEST2. So we ask ourselves, when we are looking up CB2 in the data 

and CB2 exists in the data, why is it returning the value for CB19? Good question. The LOOKUP function 

assumes that the data in column A is sorted in ascending order. 

If you look closer at column A, it is not in fact sorted in ascending order. If we quickly sorted column A, it 

would look like this: 

 

Now the LOOKUP function correctly returns 3A when it is looking up CB2 in the data. 
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To avoid these sorting problems with your data, we recommend using VLOOKUP function in this case. Let's 

show you how we would do this. If we changed our formula below (but left our data in column A in the 

original sort order): 

 

The following VLOOKUP formula would return the correct value of 3A. 

=VLOOKUP("CB2",$A$2:$D$5,4,FALSE) 

The VLOOKUP function does not require us to have the data sorted in ascending order since we used FALSE 

as the last parameter - which means that it is looking for an exact match. 

Question: I have the following LOOKUP formula: 

=LOOKUP(C2,{"A","B","C","D","E","F","G","H","I","K","X","Z"}, 

{"1","2","3","4","5","6","7","8","9","10","12","1"}) 

I also need to add zero to the lookup vector and result vector. How do I do this? 

Answer: Using numbers in Excel can be tricky, as you can enter them either as numeric or text values. 

Because of this, there are 2 possible solutions. 

Numeric Solution 

If you have entered your zero as a numeric value, then the following formula will work: 

=LOOKUP(C2,{0,"A","B","C","D","E","F","G","H","I","K","X","Z"}, 

{0,"1","2","3","4","5","6","7","8","9","10","12","1"}) 

https://www.techonthenet.com/excel/formulas/vlookup.php
https://www.techonthenet.com/excel/formulas/vlookup.php
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Text Solution 

If you have entered your zero as a text value, then the following formula will work: 

=LOOKUP(C2,{"0","A","B","C","D","E","F","G","H","I","K","X","Z"}, 

{"0","1","2","3","4","5","6","7","8","9","10","12","1"}) 

Question: For the following function in Microsoft Excel: 

=LOOKUP(M14,Sheet2!A2:A2240,Sheet2!B2:B2240) 

How do I get it to return a blank cell if the LOOKUP value (M14) is blank? 

Answer: To check for a blank value in cell M14, you can use the IF function and ISBLANK function as follows: 

=IF(ISBLANK(M14),"",LOOKUP(M14,Sheet2!A2:A2240,Sheet2!B2:B2240)) 

Now if the value in cell M14 is blank, the formula will return a blank. Otherwise it will perform the LOOKUP 

function as before. 

 Content/Topic 6: Using VLOOKUP Function 

The syntax of the VLOOKUP function is 

VLOOKUP (lookup_value, table_array, col_index_num, [range_lookup]) 

Where 

 lookup_value − is the value you want to look up. Lookup_value can be a value or a reference to a 

cell. Lookup_value must be in the first column of the range of cells you specify in table_array 

 table_array − is the range of cells in which the VLOOKUP will search for the lookup_value and the 

return value. table_array must contain 

o the lookup_value in the first column, and 

o the return value you want to find 

Note − The first column containing the lookup_value can either be sorted in ascending order 

or not. However, the result will be based on the order of this column. 

 col_index_num − is the column number in the table_array that contains the return value. The 

numbers start with 1 for the left-most column of table-array 

 range_lookup − is an optional logical value that specifies whether you want VLOOKUP to find an 

exact match or an approximate match. range_lookup can be 

o omitted, in which case it is assumed to be TRUE and VLOOKUP tries to find an approximate 

match 

o TRUE, in which case VLOOKUP tries to find an approximate match. In other words, if an exact 

match is not found, the next largest value that is less than lookup_value is returned 

https://www.techonthenet.com/excel/formulas/if.php
https://www.techonthenet.com/excel/formulas/isblank.php
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o FALSE, in which case VLOOKUP tries to find an exact match 

o 1, in which case it is assumed to be TRUE and VLOOKUP tries to find an approximate match 

o 0, in which case it is assumed to be FALSE and VLOOKUP tries to find an exact match 

Note − If range_lookup is omitted or TRUE or 1, VLOOKUP works correctly only when the first column in 

table_array is sorted in ascending order. Otherwise, it may result in incorrect values. In such a case, use 

FALSE for range_lookup. 

Using VLOOKUP Function with range_lookup TRUE 

Consider a list of student marks. You can obtain the corresponding grades with VLOOKUP from an array 

containing the marks intervals and pass category. 

table_array − 

 

Note that the first column marks based on which the grades are obtained is sorted in ascending order. 

Hence, using TRUE for range_lookup argument you can get approximate match that is what is required. 

Name this array as Grades. 

It is a good practice to name arrays in this way so that you need not remember the cell ranges. Now, you 

are ready to look up the grade for the list of marks you have as follows − 

 

As you can observe, 



Page 76 of 182 
 

 col_index_num − indicates the column of the return value in table_array is 2 

 the range_lookup is TRUE 

o The first column containing the lookup value in the table_array grades is in ascending order. 

Hence, the results will be correct. 

o You can get the return value for approximate matches also. i.e. VLOOKUP computes as 

follows − 

Marks Pass Category 

< 35 Fail 

>= 35 and < 50 Third Class 

>= 50 and < 60 Second Class 

>=60 and < 75 First Class 

>= 75 First Class with Distinction 

You will get the following results − 

 

 

Using VLOOKUP Function with range_lookup FALSE 

Consider a list of products containing the Product ID and price for each of the products. The product ID and 

price will be added to the end of the list whenever a new product is launched. This would mean that the 

product IDs need not be in ascending order. The product list might be as shown below − 

table_array − 



Page 77 of 182 
 

 

Name this array as ProductInfo. 

You can obtain the price of a product given the product ID with the VLOOKUP function as the product ID is 

in the first column. The price is in column 3 and hence col_index_ num should be 3. 

 Use VLOOKUP Function with range_lookup as TRUE 

 Use VLOOKUP Function with range_lookup as FALSE 

 

The correct answer is from the ProductInfo array is 171.65. You can check the results. 
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You observe that you got − 

 The correct result when range_lookup is FALSE, and 

 A wrong result when range_lookup is TRUE. 

This is because, the first column in the ProductInfo array is not sorted in ascending order. Hence, remember 

to use FALSE whenever the data is not sorted. 

1. USE OF DATABASE FUNCTIONS 

The Excel Database functions work with an Excel Database. This typically takes the form of a large table of 

Data, where each row in the table stores an individual record. Each column in the Worksheet table stores a 

different field for each record. 

The Database functions perform basic operations, such as Sum, Average, Count, etc., and additionally use 

criteria arguments, that allow you to perform the calculation only for a specified subset of the records in 

your Database. Other records in the Database are ignored. 

S.No. Function and Description 

1 DAVERAGE 

Averages the values in a column of a list or database that match conditions you 

specify. 

2 DCOUNT 

Counts the cells that contain numbers in a column of a list or database that match 

conditions you specify. 

5 DMAX 

https://www.tutorialspoint.com/advanced_excel_functions/advanced_excel_database_daverage_function.htm
https://www.tutorialspoint.com/advanced_excel_functions/advanced_excel_database_dcount_function.htm
https://www.tutorialspoint.com/advanced_excel_functions/advanced_excel_database_dmax_function.htm
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Returns the largest number in a column of a list or database that matches 

conditions you specify. 

6 DMIN 

Returns the smallest number in a column of a list or database that matches 

conditions you specify. 

10 DSUM 

Adds the numbers in a column of a list or database that match conditions you 

specify. 

 

Insert related example 

 

2. USE OF OTHER FUNCTIONS  

 Create a two-level nested function  

Another example of functions. Suppose you want to find if the cell of month is greater than 1900 then we 

can give Bonus to Sales representative. The we can achieve it with writing formula with IF functions 

as =IF(B9>1900,"Yes","No") 

 

 

 Use a 3-D reference within a sum function  

Copying Formulas in MS Excel 

Copying formulas is one of the most common tasks that you do in a typical spreadsheet that relies primarily 

on formulas. When a formula uses cell references rather than constant values, Excel makes the task of 

copying an original formula to every place that requires a similar formula. 

https://www.tutorialspoint.com/advanced_excel_functions/advanced_excel_database_dmin_function.htm
https://www.tutorialspoint.com/advanced_excel_functions/advanced_excel_database_dsum_function.htm


Page 80 of 182 
 

Relative Cell Addresses 

MS Excel does it automatically adjusting the cell references in the original formula to suit the position of 

the copies that you make. It does this through a system known as relative cell addresses, where by the 

column references in the cell address in the formula change to suit their new column position and the row 

references change to suit their new row position. 

Let us see this with the help of example. Suppose we want the sum of all the rows at last, then we will write 

a formula for first column i.e. B. We want sum of the rows from 3 to 8 in the 9th row. 

 

After writing formula in the 9th row, we can drag it to remaining columns and the formula gets copied. After 

dragging we can see the formula in the remaining columns as below. 

 column C : =SUM(C3:C8) 

 column D : =SUM(D3:D8) 

 column E : =SUM(E3:E8) 

 column F : =SUM(F3:F8) 

 column G : =SUM(G3:G8) 
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Cell References in Formulas 

Most formulas you create include references to cells or ranges. These references enable your formulas to 

work dynamically with the data contained in those cells or ranges. For example, if your formula refers to 

cell C2 and you change the value contained in C2, the formula result reflects new value automatically. If you 

didn’t use references in your formulas, you would need to edit the formulas themselves in order to change 

the values used in the formulas. 

When you use a cell (or range) reference in a formula, you can use three types of references − relative, 

absolute, and mixed references. 

Relative Cell References 

The row and column references can change when you copy the formula to another cell because the 

references are actually offsets from the current row and column. By default, Excel creates relative cell 

references in formulas. 
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Absolute Cell References 

The row and column references do not change when you copy the formula because the reference is to an 

actual cell address. An absolute reference uses two dollar signs in its address: one for the column letter and 

one for the row number (for example, $A$5). 

 

 

 Use mixed references in formulas 

Mixed Cell References 

Both the row or column reference is relative and the other is absolute. Only one of the address parts is 

absolute (for example, $A5 or A$5). 

 

 

LO 2.3: Create spreadsheet Charts 

Content/Topic 1. Creation of combined column and line chart 
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Suppose you have the target and actual profits for the fiscal year 2015-2016 that you obtained from 

different regions. 

 

We will create a Clustered Column Chart for these results. 

 

As you observe, it is difficult to visualize the comparison quickly between the targets and actual in this chart. 

It does not give a true impact on your results. 

A better way of distinguishing two types of data to compare the values is by using Combination Charts. In 

Excel 2013 and versions above, you can use Combo charts for the same purpose. 

Use Vertical Columns for the target values and a Line with Markers for the actual values. 

 Click the DESIGN tab under the CHART TOOLS tab on the Ribbon. 

 Click Change Chart Type in the Type group. The Change Chart Type dialog box appears. 
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 Click Combo. 

 Change the Chart Type for the series Actual to Line with Markers. The preview appears under Custom 

Combination. 

 Click OK. 

 

Your Customized Combination Chart will be displayed. 
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As you observe in the chart, the Target values are in Columns and the Actual values are marked along the 

line. The data visualization has become better as it also shows you the trend of your results. 

However, this type of representation does not work well when the data ranges of your two data values vary 

significantly. 

Content/Topic 2:  Adding a Secondary Axis to A Chart 

Suppose you have the data on the number of units of your product that was shipped and the actual profits 

for the fiscal year 2015-2016 that you obtained from different regions. 

 

If you use the same combination chart as before, you will get the following − 
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In the chart, the data of No. of Units is not visible as the data ranges are varying significantly. 

In such cases, you can create a combination chart with secondary axis, so that the primary axis displays one 

range and the secondary axis displays the other. 

 Click the INSERT tab. 

 Click Combo in Charts group. 

 Click Create Custom Combo Chart from the drop-down list. 

 

The Insert Chart dialog box appears with Combo highlighted. 

For Chart Type, choose − 

 Line with Markers for the Series No. of Units 

 Clustered Column for the Series Actual Profits 

 Check the Box Secondary Axis to the right of the Series No. of Units and click OK. 

A preview of your chart appears under Custom Combination. 
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Your Combo chart appears with Secondary Axis. 

 

You can observe the values for Actual Profits on the primary axis and the values for No. of Units on the 

secondary axis. 

A significant observation in the above chart is for Quarter 3 where No. of Units sold is more, but the Actual 

Profits made are less. This could probably be assigned to the promotion costs that were incurred to increase 

sales. The situation is improved in Quarter 4, with a slight decrease in sales and a significant rise in the Actual 

Profits made 
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Content/Topic 4: Change of the Chart Type for A Defined Data Series 

Suppose you want to project the Actual Profits made in Years 2013-2016. 

 

Create a clustered column for this data. 

 

As you observe, the data visualization is not effective as the years are not displayed. You can overcome this 

by changing year to category. 

Remove the header year in the data range. 
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Now, year is considered as a category and not a series. Your chart looks as follows − 

 

Insert how to add , delete a data series in a chart 

LO 2. 4: Format the spreadsheet Charts 

Content/Topic 1: Chart Elements and Chart Styles 

Chart Elements give more descriptions to your charts, thus helping visualizing your data more meaningfully. 

 Click the Chart 

Three buttons appear next to the upper-right corner of the chart − 

  Chart Elements 

  Chart Styles 

  Chart Filters 

For a detailed explanation of these, refer to Excel Charts tutorial. 

 Click Chart Elements. 
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 Click Data Labels. 

 

 Click Chart Styles 

 Select a Style and Color that suits your data. 

 

You can use Trendline to graphically display trends in data. You can extend a Trendline in a chart beyond 

the actual data to predict future values. 
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Content/Topic 2: DATA LABELS 

Excel 2013 and later versions provide you with various options to display Data Labels. You can choose one 

Data Label, format it as you like, and then use Clone Current Label to copy the formatting to the rest of the 

Data Labels in the chart. 

The Data Labels in a chart can have effects, varying shapes and sizes. 

It is also possible to display the content of a cell as part of the Data Label with Insert Data Label Field. 

 

 

Insert how to re-position chart title, legend and data labels 
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Learning Unit 3: Analyze data using tables and list 

LO 3.1: Analyze data using tables  

Content/Topic 1: PivotTables 

Data analysis on a large set of data is quite often necessary and important. It involves summarizing the data, 

obtaining the needed values and presenting the results. 

Excel provides PivotTable to enable you summarize thousands of data values easily and quickly so as to 

obtain the required results. 

Consider the following table of sales data. From this data, you might have to summarize total sales region 

wise, month wise, or salesperson wise. The easy way to handle these tasks is to create a PivotTable that 

you can dynamically modify to summarize the results the way you want. 

 

 

Content/Topic 2: Creating Pivot  table 

To create PivotTables, ensure the first row has headers. 

 Click the table. 

 Click the INSERT tab on the Ribbon. 

 Click PivotTable in the Tables group. The PivotTable dialog box appears. 
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As you can see in the dialog box, you can use either a Table or Range from the current workbook or use an 

external data source. 

 In the Table / Range Box, type the table name. 

 Click New Worksheet to tell Excel where to keep the PivotTable. 

 Click OK. 

 

A Blank PivotTable and a PivotTable fields list appear. 
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Content/Topic 3: Recommended PivotTables 

In case you are new to PivotTables or you do not know which fields to select from the data, you can use 

the Recommended PivotTables that Excel provides. 

 Click the data table. 

 Click the INSERT tab. 

 Click on Recommended PivotTables in the Tables group. The Recommended PivotTables dialog box 

appears. 

 

In the recommended PivotTables dialog box, the possible customized PivotTables that suit your data are 

displayed. 

 Click each of the PivotTable options to see the preview on the right side. 

 Click the PivotTable Sum of Order Amount by Salesperson and month. 



Page 95 of 182 
 

 

Click OK. The selected PivotTable appears on a new worksheet. You can observe the PivotTable fields that 

was selected in the PivotTable fields list. 

 

 

Content/Topic 4: PivotTable Fields 

The headers in your data table will appear as the fields in the PivotTable. 
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You can select / deselect them to instantly change your PivotTable to display only the information you want 

and in a way that you want. For example, if you want to display the account information instead of order 

amount information, deselect Order Amount and select Account. 

 

 

Content/Topic 4: PivotTable Areas 

You can even change the Layout of your PivotTable instantly. You can use the PivotTable Areas to 

accomplish this. 

 

In PivotTable areas, you can choose − 

 What fields to display as rows 

 What fields to display as columns 

 How to summarize your data 
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 Filters for any of the fields 

 When to update your PivotTable Layout 

o You can update it instantly as you drag the fields across areas, or 

o You can defer the update and get it updated only when you click on UPDATE 

An instant update helps you to play around with the different Layouts and pick the one that suits your report 

requirement. 

You can just drag the fields across these areas and observe the PivotTable layout as you do it. 

 

Content/Topic 5: Nesting in the PivotTable 

If you have more than one field in any of the areas, then nesting happens in the order you place the fields 

in that area. You can change the order by dragging the fields and observe how nesting changes. In the above 

layout options, you can observe that 

 Months are in columns. 

 Region and salesperson in rows in that order. i.e. salesperson values are nested under region values. 

 Summarizing is by Sum of Order Amount. 

 No filters are chosen. 

The resulting PivotTable is as follows − 
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In the PivotTable Areas, in rows, click region and drag it below salesperson such that it looks as follows − 

 

The nesting order changes and the resulting PivotTable is as follows − 
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Note − You can clearly observe that the layout with the nesting order – Region and then Salesperson yields 

a better and compact report than the one with the nesting order – Salesperson and then Region. In case 

Salesperson represents more than one area and you need to summarize the sales by Salesperson, then the 

second layout would have been a better option. 

Content/Topic 6 Filters 

You can assign a Filter to one of the fields so that you can dynamically change the PivotTable based on the 

values of that field. 

Drag Region from Rows to Filters in the PivotTable Areas. 
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The filter with the label as Region appears above the PivotTable (in case you do not have empty rows above 

your PivotTable, PivotTable gets pushed down to make space for the Filter. 

 

You can see that −  

 Salesperson values appear in rows. 

 Month values appear in columns. 

 Region Filter appears on the top with default selected as ALL. 

 Summarizing value is Sum of Order Amount 

o Sum of Order Amount Salesperson-wise appears in the column Grand Total 

o Sum of Order Amount Month-wise appears in the row Grand Total 

Click the arrow in the box to the right of the filter region. A drop-down list with the values of the field region 

appears. 

 

 Check the option Select Multiple Items. Check boxes appear for all the values. 

 Select South and West, deselect the other values, and click OK. 
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The data pertaining to South and West Regions only will be summarized as shown in the screen shot given 

below − 

 

You can see that next to the Filter Region, Multiple Items is displayed, indicating that you have selected 

more than one item. However, how many items and / or which items are selected is not known from the 

report that is displayed. In such a case, using Slicers is a better option for filtering. 

Content/Topic 6: Slicers 

You can use Slicers to have a better clarity on which items the data was filtered. 

 Click ANALYZE under PIVOTTABLE TOOLS on the Ribbon. 

 Click Insert Slicer in the Filter group. The Insert Slicers box appears. It contains all the fields from your 

data. 

 Select the fields Region and month. Click OK. 
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Slicers for each of the selected fields appear with all the values selected by default. Slicer Tools appear on 

the Ribbon to work on the Slicer settings, look and feel. 

 

 Select South and West in the Slicer for Region. 

 Select February and March in the Slicer for month. 

 Keep Ctrl key pressed while selecting multiple values in a Slicer. 

Selected items in the Slicers are highlighted. PivotTable with summarized values for the selected items will 

be displayed. 
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Content/Topic 7: Summarizing Values by other Calculations 

In the examples so far, you have seen summarizing values by Sum. However, you can use other calculations 

also if necessary. 

In the PivotTable Fields List 

 Select the Field Account. 

 Unselect the Field Order Amount. 

 

 Drag the field Account to Summarizing Values area. By default, Sum of Account will be displayed. 

 Click the arrow on the right side of the box. 

 In the drop-down that appears, click Value Field Settings. 
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The Value Field Settings box appears. Several types of calculations appear as a list under Summarize value 

field by − 

 Select Count in the list. 

 The Custom Name automatically changes to Count of Account. Click OK. 

 

The PivotTable summarizes the Account values by Count. 
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Content/Topic 8: PivotTable Tools 

Follow the steps given below to learn to use the PivotTable Tools. 

 Select the PivotTable. 

The following PivotTable Tools appear on the Ribbon − 

 ANALYZE 

 DESIGN 

 

Content/Topic 9: ANALYZE 

Some of the ANALYZE Ribbon commands are − 

 Set PivotTable Options 

 Value Field Settings for the selected Field 

 Expand Field 
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 Collapse Field 

 Insert Slicer 

 Insert Timeline 

 Refresh Data 

 Change Data Source 

 Move PivotTable 

 Solve Order (If there are more calculations) 

 PivotChart 

Content/Topic 10: DESIGN 

Some of the DESIGN Ribbon commands are − 

 PivotTable Layout 

o Options for Sub Totals 

o Options for Grand Totals 

o Report Layout Forms 

o Options for Blank Rows 

 PivotTable Style Options 

 PivotTable Styles 

Content/Topic 11: Expanding and Collapsing Field 

You can either expand or collapse all items of a selected field in two ways − 

 By selecting the symbol  or  to the left of the selected field. 

 By clicking the Expand Field or Collapse Field on the ANALYZE Ribbon. 

By selecting the Expand symbol  or Collapse symbol  to the left of the selected field 

 Select the cell containing East in the PivotTable. 

 Click on the Collapse symbol  to the left of East. 
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All the items under East will be collapsed. The Collapse symbol  to the left of East changes to the Expand 

symbol . 

 

You can observe that only the items below East are collapsed. The rest of the PivotTable items are as they 

are. 

Click the Expand symbol  to the left of East. All the items below East will be displayed. 

Content/Topic 12: Using ANALYZE on the Ribbon 

You can collapse or expand all items in the PivotTable at once with the Expand Field and Collapse Field 

commands on the Ribbon. 

 Click the cell containing East in the PivotTable. 

 Click the ANALYZE tab on the Ribbon. 

 Click Collapse Field in the Active Field group. 
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All the items of the field East in the PivotTable will collapse. 

 

Click Expand Field in the Active Field group. 

 

All the items will be displayed. 

Content/Topic 13: Report Presentation Styles 

You can choose the presentation style for your PivotTable as you would be including it as a report. Select a 

style that fits into the rest of your presentation or report. However, do not get over bored with the styles 
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because a report that gives an impact in showing the results is always better than a colorful one, which does 

not highlight the important data points. 

 Click East in the PivotTable. 

 Click ANALYZE. 

 Click Field Settings in Active Field group. The Field Settings dialog box appears. 

 Click the Layout & Print tab. 

 Check Insert blank line after each item label. 

 

Blank rows will be displayed after each value of the Region field. 

You can insert blank rows from the DESIGN tab also. 

 

 Click the DESIGN tab. 

 Click Report Layout in Layout group. 

 Select Show in Outline Form in the drop-down list. 



Page 110 of 182 
 

 

 Hover the mouse over the PivotTable Styles. A preview of the style on which the mouse is placed will 

appear. 

 Select the Style that suits your report. 

PivotTable in Outline Form with the selected Style will be displayed. 
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Content/Topic 14: WHAT-IF ANALYSIS WITH DATA TABLES 

With a Data Table in Excel, you can easily vary one or two inputs and perform What-if analysis. A Data Table 

is a range of cells in which you can change values in some of the cells and come up with different answers 

to a problem. 

There are two types of Data Tables − 

 One-variable Data Tables 

 Two-variable Data Tables 

If you have more than two variables in your analysis problem, you need to use Scenario Manager Tool of 

Excel. For details, refer to the chapter – What-If Analysis with Scenario Manager in this tutorial. 

Content/Topic 15: One-variable Data Tables 

A one-variable Data Table can be used if you want to see how different values of one variable in one or 

more formulas will change the results of those formulas. In other words, with a one-variable Data Table, 

you can determine how changing one input changes any number of outputs. You will understand this with 

the help of an example. 

Example 

There is a loan of 5,000,000 for a tenure of 30 years. You want to know the monthly payments (EMI) for 

varied interest rates. You also might be interested in knowing the amount of interest and Principal that is 

paid in the second year. 

Analysis with One-variable Data Table 

Analysis with one-variable Data Table needs to be done in three steps − 

Step 1 − Set the required background. 

Step 2 − Create the Data Table. 

Step 3 − Perform the Analysis. 

Let us understand these steps in detail − 

Step 1: Set the required background 

 Assume that the interest rate is 12%. 

 List all the required values. 

 Name the cells containing the values, so that the formulas will have names instead of cell references. 

 Set the calculations for EMI, Cumulative Interest and Cumulative Principal with the Excel functions – 

PMT, CUMIPMT and CUMPRINC respectively. 

Your worksheet should look as follows − 

https://www.tutorialspoint.com/excel_data_analysis/what_if_analysis_with_scenario_manager.htm
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You can see that the cells in column C are named as given in the corresponding cells in column D. 

Step 2: Create the Data Table 

 Type the list of values i.e. interest rates that you want to substitute in the input cell down the column 

E as follows − 

 

As you observe, there is an empty row above the Interest Rate values. This row is for the formulas 

that you want to use. 

 Type the first function (PMT) in the cell one row above and one cell to the right of the column of 

values. Type the other functions (CUMIPMT and CUMPRINC) in the cells to the right of the first 

function. 

Now, the two rows above the Interest Rate values look as follows − 

 

The Data Table looks as given below − 
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Step 3: Do the analysis with the What-If Analysis Data Table Tool 

 Select the range of cells that contains the formulas and values that you want to substitute, i.e. select 

the range – E2:H13. 

 Click the DATA tab on the Ribbon. 

 Click What-if Analysis in the Data Tools group. 

 Select Data Table in the dropdown list. 

 

Data Table dialog box appears. 

 Click the icon in the Column input cell box. 

 Click the cell Interest_Rate, which is C2. 

 

You can see that the Column input cell is taken as $C$2. Click OK. 

The Data Table is filled with the calculated results for each of the input values as shown below − 
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If you can pay an EMI of 54,000, you can observe that the interest rate of 12.6% is suitable for you. 

3.15. Two-variable Data Tables 

A two-variable Data Table can be used if you want to see how different values of two variables in a formula 

will change the results of that formula. In other words, with a twovariable Data Table, you can determine 

how changing two inputs changes a single output. You will understand this with the help of an example. 

Example 

There is a loan of 50,000,000. You want to know how different combinations of interest rates and loan 

tenures will affect the monthly payment (EMI). 

Analysis with Two-variable Data Table 

Analysis with two-variable Data Table needs to be done in three steps − 

Step 1 − Set the required background. 

Step 2 − Create the Data Table. 

Step 3 − Perform the Analysis. 

Step 1: Set the required background 

 Assume that the interest rate is 12%. 

 List all the required values. 

 Name the cells containing the values, so that the formula will have names instead of cell references. 

 Set the calculation for EMI with the Excel function – PMT. 

Your worksheet should look as follows − 

 

You can see that the cells in the column C are named as given in the corresponding cells in the column D. 

Step 2: Create the Data Table 
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 Type =EMI in cell F2. 

 

 Type the first list of input values, i.e. interest rates down the column F, starting with the cell below 

the formula, i.e. F3. 

 Type the second list of input values, i.e. number of payments across row 2, starting with the cell to 

the right of the formula, i.e. G2. 

The Data Table looks as follows − 

 

Do the analysis with the What-If Analysis Tool Data Table 

 Select the range of cells that contains the formula and the two sets of values that you want to 

substitute, i.e. select the range – F2:L13. 

 Click the DATA tab on the Ribbon. 

 Click What-if Analysis in the Data Tools group. 

 Select Data Table from the dropdown list. 



Page 116 of 182 
 

 

Data Table dialog box appears. 

 Click the icon in the Row input cell box. 

 Click the cell NPER, which is C3. 

 Again, click the icon in the Row input cell box. 

 Next, click the icon in the Column input cell box. 

 Click the cell Interest_Rate, which is C2. 

 Again, click the icon in the Column input cell box. 

 

You will see that the Row input cell is taken as $C$3 and the Column input cell is taken as $C$2. Click OK. 

The Data Table gets filled with the calculated results for each combination of the two input values − 
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If you can pay an EMI of 54,000, the interest rate of 12.2% and 288 EMIs are suitable for you. This means 

the tenure of the loan would be 24 years. 

Data Table Calculations 

Data Tables are recalculated each time the worksheet containing them is recalculated, even if they have 

not changed. To speed up the calculations in a worksheet that contains a Data Table, you need to change 

the calculation options to Automatically Recalculate the worksheet but not the Data Tables, as given in the 

next section. 

Speeding up the Calculations in a Worksheet 

You can speed up the calculations in a worksheet containing Data Tables in two ways − 

 From Excel Options. 

 From the Ribbon. 

From Excel Options 

 Click the FILE tab on the Ribbon. 

 Select Options from the list in the left pane. 

Excel Options dialog box appears. 

 From the left pane, select Formulas. 

 Select the option Automatic except for data tables under Workbook Calculation in the Calculation 

options section. Click OK. 
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From the Ribbon 

 Click the FORMULAS tab on the Ribbon. 

 Click the Calculation Options in the Calculations group. 

 Select Automatic Except for Data Tables in the dropdown list. 

 

 

LO 3.2: Analyze data using sorting and filtering 
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Content/Topic 1: Filtering Data  

In addition to sorting, you may find that adding a filter allows you to better analyze your data. When data is 

filtered, only rows that meet the filter criteria will display and other rows will be hidden. With filtered data, 

you can then copy, format, print, etc., your data, without having to sort or move it first. To use a filter, 

 Go to the Home ribbon, click the arrow below the Sort & Filtering icon in the Editing group and choose 

Filter.  

 

 

OR 

 Go to the Data ribbon, and then click Filter in the Sort & Filter group. 

 

You will notice that all of your column headings now have an arrow next to the heading name. Click on the 

arrow next to the heading with which you want to filter, and you will see a list of all the unique values in that 

column. Check the box next to the criteria you wish to match and click OK. Click on the arrow next to another 

heading to further filter the data. 

 

To clear the filter, choose one of these options: 

 Click on the Filter icon next to the heading and choose Clear Filter from “Name of Heading”. 

 Go to the Data ribbon and click the Clear icon in the Sort & Filter group. 
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 Go to the Home ribbon, click the arrow below the Sort & Filter icon in the Editing group and choose 

Clear. 

Advanced Filter  

In the Sort & Filter group of the Data ribbon, there is an Advanced icon, which evokes the Advanced Filter 

dialog box. This dialog box allows you to set a particular criteria, copy results to another location (other 

location must be in the same sheet), and capture unique values.  

Content/Topic 3: Sorting Data  

For a quick sort, click the arrow below the Sort & Filtering icon in the Editing group of the Home ribbon and 

choose the Sort A to Z / Z to A icons in the Sort & Filter group of the Data ribbon. In Excel 2013, these are 

labeled Sort Smallest to Largest and vice versa. 

 

 

For a more complex sort, go to the Home ribbon, click the arrow below the Sort & Filter icon in the Editing 

group and choose Custom Sort. This takes you to the same Sort dialog box you get with the Sort icon in the 

Sort & Filter group of the Data ribbon. 
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1. Under Column, choose the first column that you would like to sort. If you want to sort multiple columns, 

click the Add Level button. 

2. Under Sort On, choose how you would like to sort. Note that Excel can sort by cell or font color in addition 

to values. 

3. Under Order, choose A to Z (ascending), Z to A (descending), or Custom List. 

4. Click OK to perform the sort. 

 

LO 3.3: Analyze data by creating scenarios 

Introduction 

Scenarios 

A scenario is a set of values that Excel saves and can substitute automatically on your worksheet. You can 

create and save different groups of values as scenarios on a worksheet and then switch between these 

scenarios to view the different results. 

For example, you can have several different budget scenarios that compare various possible income levels 

and expenses. You can also have different loan scenarios from different sources that compare various 

possible interest rates and loan tenures. 

If the information that you want to use in scenarios is from different sources, you can collect the information 

in separate workbooks, and then merge the scenarios from the different workbooks into one. 

After you have all the scenarios you need, you can create a scenario summary report − 

 That incorporates information from all the scenarios. 

 That lets you compare the scenarios side-by-side. 

Scenario Manager 

Scenario Manager is one of the What-if Analysis tools in Excel. 

To create an analysis report with Scenario Manager, you have to follow these steps − 

Step 1 − Define the set of initial values and identify the input cells that you want to vary, called the changing 

cells. 

Step 2 − Create each scenario, name the scenario and enter the value for each changing input cell for that 

scenario. 

Step 3 − Select the output cells, called the result cells that you want to track. These cells contain formulas 

in the initial set of values. The formulas use the changing input cells. 
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The Scenario Manager creates a report containing the input and the output values for each scenario. 

Initial Values for Scenarios 

Before you create several different scenarios, you need to define a set of initial values on which the 

scenarios will be based. 

The steps for setting up the initial values for Scenarios are − 

 Define the cells that contain the input values. 

 Name the input cells appropriately. 

 Identify the input cells with constant values. 

 Specify the values for the constant inputs. 

 Identify the input cells with changing values. 

 Specify the initial values for the changing inputs. 

 Define the cells that contain the results. The result cells contain formulas. 

 Name the result cells appropriately. 

 Place the formulas in the result cells. 

Consider the previous example of loan. Now, proceed as follows − 

 Define a cell for Loan Amount. 

o This input value is constant for all the scenarios. 

o Name the cell Loan_Amount. 

o Specify the value as 5,000,000. 

 Define the cells for Interest Rate, No. of payments and Type (Payment at the beginning or end of the 

month). 

o These input values will be changing across the scenarios. 

o Name the cells Interest_Rate, NPER and Type. 

o Specify the initial values for the analysis in these cells as 12%, 360 and 0 respectively. 

 Define the cell for the EMI. 

o This is the result value. 

o Name the cell EMI. 

o Place the formula in this cell as − 

=PMT (Interest_Rate/12, NPER, Loan_Amount, 0, Type) 

Your worksheet looks as shown below − 
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As you can see that the input cells and the result cells are in column C with the names as given in column 

D. 

Content/Topic 1: Creating Scenarios  

After setting up the initial values for the Scenarios, you can create the scenarios using Scenario Manager as 

follows − 

 Click the DATA tab on the Ribbon. 

 Click What-if Analysis in the Data Tools group. 

 Select Scenario Manager from the dropdown list. 

 

The Scenario Manager Dialog box appears. You can observe that it contains a message − 

“No Scenarios defined. Choose Add to.” 

 

You need to create scenarios for each set of changing values in the Scenario Manager. It is good to have the 

first scenario defined with initial values, as it enables you to switch back to initial values whenever you want 

while displaying different scenarios. 

Create the first scenario with the initial values as follows − 
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 Click the Add button in the Scenario Manager Dialog box. 

The Add Scenario dialog box appears. 

 Under Scenario Name, type Scenario 1. 

 Under Changing Cells, enter the references for the cells i.e. C3, C4 and C5 with the Ctrl key pressed. 

The name of the dialog box changes to Edit Scenario. 

 Edit the text in the Comment as – Initial Values box. 

 Select the option Prevent changes under Protection and then click OK. 

 

The Scenario Values dialog box appears. The initial values that you have defined appear in each of the 

changing cells boxes. 

 

Scenario 1 with the initial values is created. 

Create three more scenarios with varying values in the changing cells as follows − 

 Click the Add button in the Scenario Values dialog box. 

Add Scenario dialog box appears. Note that C3, C4, C5 appear in the Changing cells box. 

 In the Scenario Name box, type Scenario 2. 

 Edit the text in the Comment as – Different Interest Rate. 

 Select Prevent changes under Protection and click OK. 
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The Scenario Values dialog box appears. The initial values appear in the changing cells. Change the value 

of Interest_Rate to 0.13 and click Add. 

 

The Add Scenario dialog box appears. Note that C3, C4, C5 appear in the box under changing cells. 

 In the Scenario Name box, type Scenario 3. 

 Edit the text in the Comment box as – Different no. of Payments. 

 Select Prevent changes under Protection and click OK. 
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The Scenario Values dialog box appears. The initial values appear in the changing cells. Change the value of 

NPER to 300 and click Add. 

 

The Add Scenario dialog box appears. Note that C3, C4, C5 appear in the Changing cells box. 

 In the Scenario Name box, type Scenario 4. 

 Edit the text in the Comment box as – Different Type of Payment. 

 Select Prevent changes under Protection and click OK. 
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The Scenario Values dialog box appears. The initial values appear in the changing cells. Change the value of 

Type to 1. Click OK as you have added all the scenarios that you wanted to add. 

 

The Scenario Manager dialog box appears. In the box under Scenarios, You will find the names of all the 

scenarios that you have created. 

 Click Scenario 1. As you are aware, Scenario 1 contains the initial values. 
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Now, click Summary. The Scenario Summary dialog box appears. 

Content/Topic 2:  Scenario Summary Reports 

Excel provides two types of Scenario Summary reports − 

 Scenario summary. 

 Scenario PivotTable report. 

In the Scenario Summary dialog box, you can find these two Report types. 

Select Scenario summary under Report type. 

 

3.3. Scenario Summary 

In the Result cells box, select the cell C6 (Here, we had put the PMT function). Click OK. 

Scenario Summary report appears in a new worksheet. The worksheet is named as Scenario Summary. 
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You can observe the following in the Scenario Summary report − 

 Changing Cells − Enlists all the cells used as changing cells. As you have named the cells, 

Interest_Rate, NPER and Type, these appear to make the report meaningful. Otherwise, only cell 

references will be listed. 

 Result Cells − Displays the result cell specified, i.e. EMI. 

 Current Values − It is the first column and enlists the values of that scenario which is selected in the 

Scenario Manager Dialog box before creating the summary report. 

 For all the scenarios you have created, the changing cells will be highlighted in gray. 

 In the EMI row, the result values for each scenario will be displayed. 

You can make the report more meaningful by displaying the comments that you added while creating the 

scenarios. 

 Click the + button to the left of the row containing the scenario names. The comments for the 

scenarios appear in the row under the scenario names. 
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Learning Unit 4 : Validate and Audit Spreadsheet Data 

Learning Outcome 4.1: Validate spreadsheet data 

Content/Topic1: Setting, editing validation criteria for data entry in a cell range like Whole number, 

Decimal, List, Date,  Time 

 DATA VALIDATION 

MS Excel data validation feature allows you to set up certain rules that dictate what can be entered into 

a cell. For example, you may want to limit data entry in a particular cell to whole numbers between 0 and 

10. If the user makes an invalid entry, you can display a custom message as shown below. 

 

VALIDATION CRITERIA 

To specify the type of data allowable in a cell or range, follow the steps below, which shows all the three 

tabs of the Data Validation dialog box. 

 Select the cell or range. 

 Choose Data » Data Tools » Data Validation. Excel displays its Data Validation dialog box having 3 

tabs settings, Input Message and Error alert. 

SETTINGS TAB 

Here you can set the type of validation you need. Choose an option from the Allow drop-down list. The 

contents of the Data Validation dialog box will change, displaying controls based on your choice. 
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1. Any Value − Selecting this option removes any existing data validation. 

2. Whole Number − The user must enter a whole number. For example, you can specify that the entry 

must be a whole number greater than or equal to 50. 

3. Decimal − The user must enter a number. For example, you can specify that the entry must be 

greater than or equal to 10 and less than or equal to 20. 

4. List − The user must choose from a list of entries you provide. You will create drop-down list with 

this validation. You have to give input ranges then those values will appear in the drop-down. 

5. Date − The user must enter a date. You specify a valid date range from choices in the Data drop-

down list. For example, you can specify that the entered data must be greater than or equal to 

January 1, 2013, and less than or equal to December 31, 2013. 

6. Time − The user must enter a time. You specify a valid time range from choices in the Data drop-

down list. For example, you can specify that the entered data must be later than 12:00 p.m. 

 

 

Content/Topic 2:  Entering Input Message and Error Alert 

Input Message Tab 

You can set the input help message with this tab. Fill the title and Input message of the Input message tab 

and the input message will appear when the cell is selected. 
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ERROR ALERT TAB 

You can specify an error message with this tab. Fill the title and error message. Select the style of the error 

as stop, warning or Information as per you need. 

 

 

LO 4.2: Audit spreadsheet data 

Content/Topic 1: Formula Auditing 

You might want to check formulas for accuracy or find the source of an error. Excel Formula Auditing 

commands provide you an easy way to find 
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 Which cells are contributing in the calculation of a formula in the active cell. 

 Which formulas are referring to the active cell. 

These findings are shown graphically by arrow lines that makes the visualization easy. You can display all 

the formulas in the active worksheet with a single command. If your formulas refer to cells in a different 

workbook, open that workbook also. Excel cannot go to a cell in a workbook that is not open. 

Setting the Display Options 

You need to check whether the display options for the workbooks you are using are correctly set. 

 Click FILE > Options. 

 In the Excel Options dialog box, click Advanced. 

 In Display options for the workbook − 

o Select the workbook. 

o Check that under For objects, show, All is selected. 

 Repeat this step for all the workbooks you are auditing. 

 

4.2.1. Tracing precedent, dependent cells. Identification of cells with missing dependents 

Tracing Precedents 

Precedent cells are those cells that are referred to by a formula in the active cell. 

In the following example, the active cell is C2. In C2, you have the formula =B2*C4. 
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B2 and C4 are precedent cells for C2. 

 

To trace the precedents of the cell C2, 

 Click in the cell C2. 

 Click the Formulas tab. 

 Click Trace Precedents in the Formula Auditing group. 

 

Two arrows, one from B2 to C2 and another from C4 to C2 will be displayed, tracing the precedents. 

 

Note that for tracing precedents of a cell, the cell should have a formula with valid references. Otherwise, 

you will get an error message. 

 Click in a cell that does not contain a formula or click in an empty cell. 

 Click Trace Precedents in the Formula Auditing group. 

You will get a message. 
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Removing Arrows 

Click Remove Arrows in the Formula Auditing group. 

 

All the arrows in the worksheet will disappear. 

Tracing Dependents 

Dependent cells contain formulas that refer to other cells. That means, if the active cell contributes to a 

formula in another cell, the other cell is a dependent cell on the active cell. 

In the example below, C2 has the formula =B2*C4. Therefore, C2 is a dependent cell on the cells B2 and C4 

 

To trace the dependents of the cell B2, 

 Click in the cell B2. 

 Click the Formulas tab. 

 Click Trace Dependents in the Formula Auditing group. 
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An arrow appears from B2 to C2, showing C2 is dependent on B2. 

To trace the dependents of the cell C4 − 

 Click in the cell C4. 

 Click the Formula tab > Trace Dependents in the Formula Auditing group. 

Another arrow appears from C4 to C2, showing C2 is dependent on C4 also. 

 

Click Remove Arrows in the Formula Auditing group. All the arrows in the worksheet will disappear. 

Note − For tracing dependents of a cell, the cell should be referenced by a formula in another cell. 

Otherwise, you will get an error message. 

 Click in the cell B6 is not referenced by any formula or click in any empty cell. 

 Click Trace Dependents in the Formula Auditing group. You will get a message. 
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Content/Topic 2: Working with Formulae 

You have understood the concept of Precedents and Dependents. Now, consider a worksheet with several 

formulae. 

 

 Click in a cell under Pass Category in Exam Results table. 

 Click Trace Precedents. The cell to its left (Marks) and the range E4:F8 will be mapped as the 

precedents. 

 Repeat for all the cells under Pass Category in Exam Results table. 
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 Click in a cell under Pass Category in Student Grades table. 

 Click Trace Dependents. All the cells under Pass Category in Exam Results table will be mapped as 

the dependents. 

 

Content/Topic 3: Showing all formulas in a worksheet, rather than the resulting values 

The worksheet below contains the summary of sales by the salespersons in the regions East, North, South, 

and West. 
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 Click the FORMULAS tab on the Ribbon. 

 Click Show Formulas in the Formula Auditing group. The Formulas in the worksheet will appear, so 

that you will know which cells contain formulas and what the formulas are. 

 

 Click in a cell under TotalSales. 

 Click Trace Precedents. A worksheet icon appears at the end of the arrow. The worksheet icon 

indicates that the precedents are in a different worksheet. 

 

Double-click on the arrow. A Go TO dialog box appears, showing the precedents. 
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As you observe, there are four precedents, on four different worksheets. 

 Click a reference of one of the precedents. 

 The reference appears in the Reference box. 

 Click OK. The worksheet containing that precedent appears. 

Define how to (insert, edit, delete, hide) comments/notes 

 

LO 4.3: Name spreadsheet cells 

Naming cells in Excel can be done in two ways. The first is by changing the name directly on the name box 

and the other one is by defining names under the Formulas menu. The difference is that when naming a cell 

through the define name feature of the menu you can select its specific scope. 

This determines where the specific name will be recognized as having the same value, such as in the entire 

workbook or in a specific spreadsheet only. Changing the name in the name box will automatically determine 

the workbook as its scope rather than the whole spreadsheet. 

Content/Topic 1: Changing a cell name in the name box: 

1. Select the cell that you want to name. 

2. Go to the name box and type the name you prefer. 

3. Hit enter on your keyboard. 
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Content/Topic 2: Defining a cell name: 

1. Select the cell that you wish to name. 

2. Click the Formulas menu. 

3. Choose Define Name. 

4. Type the name of the cell in the new window that pops up. 

5. Select the Scope. 

6. Click OK. 

Remember that a cell name should not contain any spaces. The uppercase and lowercase letters R and C are 

also not available as cell names, since they represent column and row. Furthermore, aside from letters, the 

first character of a cell name can also be a backslash or an underscore. The rest can be a combination of 

letters, underscores, periods and numbers, which can be up to 255 characters. 
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Learning unit 5: Enhance spreadsheet productivity 

LO 5.1: Apply special paste and use for templates 

There are a couple of ways you can access the Excel Paste Special features. 

The first step is to copy the cells that you want to paste. Once you copy it, here are three different ways to 

access paste special in Excel: 

 Using the Ribbon: Go to Home –> Clipboard –> Paste –> Paste Special. This will open the Excel Paste 

Special Dialogue box. 

 

  Using Keyboard Shortcut: Use the Excel Paste Special Shortcut – Alt + E + S + V. 

  Using Right-click Menu: Right Click in the cell where you want to paste, and then select paste special. 
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All these three options would open a Paste Special dialogue box, as shown below: 

 

Content/Topic 1: Understanding Excel Paste Special Dialogue Box 

It could be overwhelming to see so many options for something as simple as copying and pasting in Excel. 

However, when you go through these, it makes a lot of sense to have these options available. 
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If you have a good grip on these Excel Paste Special options, it can save you a lot of time (and you know time 

is money!). 

So let’s learn more about these options: 

Paste Options in the Paste Special Dialogue Box: 

 

These options enable you to paste selectively. For example, you can choose to only paste formulas, or values, 

or formats, or comments, etc. 

To use these, simply copy the cells, go the cell where you want to paste it, open the paste special dialogue 

box, and select the desired option. 

For example, suppose you have a data set where you have formatted the data using borders and fill colors. 

If you want to copy only the values, copy the data, go to the destination cell where you want the data to be 

copied, open the Excel Paste Special dialog box, and select Values. This will only copy the data and not the 

formatting. 

Operation Options in the Paste Special Dialogue Box: 

Operations options give you a quick way to perform the given operations without applying a formula or 

directly changing the cell contents. 
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For example, let’s say you have some numbers that are in millions, and you want to convert it into billions. 

One way of doing this would be to create a formula where you divide the number with 1000. 

Here is a better way: 

 In an empty cell, enter 1000. 

 Select this cell and copy it (Control + C). 

 Select the cells that you want to convert from million to billion. 

 Open the Paste Special Dialogue box and select the Divide option. 

That’s it! It will convert the numbers into billions. 

In a similar way, you can use other operations as well – Add, Subtract, or Multiply using Paste Special. 

Additional Excel Paste Special Options 

Apart from the Paste and Operation option, there are two additional options in the Excel Paste Special 

dialogue box. 
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 Skip Blanks: This would skip copying and 

pasting the blanks. A practical use if this could be when you have data split into 2 columns and you 

want to combine it in a single column. Something as shown below: 

 Transpose: As the name suggests, if this is checked, it transposes the data when you paste it. 

Learning Outcome 5.2: Use of linking, embedding and importing 

When you insert content as an object, you create a dynamic link between the content that you insert and 

the content that was created in another Microsoft Office program. Unlike when you paste content (such as 

by pressing CTRL+V), when you insert it as a linked or embedded object, you can work with it in the original 

program. 

For example, if you insert worksheet cells into the document as an Excel object, Microsoft Office Word runs 

Excel when you double-click the cells, and you can use Excel commands to work with the worksheet content. 

Content/Topic 1: Understand the differences between linked objects and embedded objects 

The main differences between linked objects and embedded objects are where the data is stored and how 

you update the data after you place it in the Word file. 

You place either a link to the object or a copy of the object in the document. You can insert objects this way 

from any program that supports the technology of linking and embedding objects (object linking and 

embedding, or OLE). 

For example, a monthly status report may contain information that is separately maintained in an Excel 

worksheet. If you link the report to the worksheet, the data in the report can be updated whenever the 

source file is updated. If you embed the worksheet in the report, your report contains a static copy of the 

data. 

https://trumpexcel.com/transpose-data-excel/
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1. Embedded object 

2. Linked object 

3. Source file 

Content/Topic2: Linked objects 

When an object is linked, information can be updated if the source file is modified. Linked data is stored in 

the source file. The Word file, or destination file, stores only the location of the source file, and it displays a 

representation of the linked data. Use linked objects if file size is a consideration. 

Linking is also useful when you want to include information that is maintained independently, such as data 

collected by a different department, and when you need to keep that information up-to-date in a Word 

document. 

Content/Topic 2: Embedded objects 

When you embed an Excel object, information in the Word file doesn't change if you modify the source Excel 

file. Embedded objects become part of the Word file and, after they are inserted, they are no longer part of 

the source file. 

Because the information is totally contained in one Word document, embedding is useful when you don't 

want the information to reflect changes in the source file, or when you don't want the document recipients 

to be concerned with updating the linked information. 

Content/Topic 3: Importing Data into Excel 

First highlight the table that you wish to import into Excel, then right-click and select Copy from the menu. 

Open Excel, click the cell where you want your spreadsheet to appear, then right-click your mouse for the 

right-click menu, and select Paste. 

Show related example on each topic above 

LO5.3: Use spreadsheet automation 
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Introduction to Macros in MS Excel 

Macros enable you to automate almost any task that you can undertake in Excel 2010. By using macro 

recorder from View Tab » Macro Dropdown to record tasks that you perform routinely, you not only speed 

up the procedure considerably but you are assured that each step in a task is carried out the same way each 

and every time you perform a task. 

To view macros, choose View Tab » Macro dropdown. 

 

Content/Topic 1: Macro Options 

View tab contains a Macros command button to which a dropdown menu containing the following three 

options. 

 View Macros − Opens the Macro dialog box where you can select a macro to run or edit. 

 Record Macro − Opens the Record Macro dialog box where you define the settings for your new 

macro and then start the macro recorder; this is the same as clicking the Record Macro button on 

the Status bar. 

 Use Relative References − Uses relative cell addresses when recording a macro, making the macro 

more versatile by enabling you to run it in areas of a worksheet other than the ones originally used 

in the macro’s recording. 

Content/Topic 2: Creating Macros 

You can create macros in one of two ways − 

 Use MS Excel’s macro recorder to record your actions as you undertake them in a worksheet. 

 Enter the instructions that you want to be followed in a VBA code in the Visual Basic Editor. 

Now let's create a simple macro that will automate the task of making cell content Bold and apply cell color. 

 Choose View Tab » Macro dropdown. 

 Click on Record Macro as below. 
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 Now Macro recording will start. 

 Do the steps of action, which you want to perform repeatedly? Macro will record those steps. 

 You can stop the macro recording once done with all steps. 

 

Content/Topic 3: Edit Macro 

You can edit the created Macro at any time. Editing macro will take you to the VBA programming editor. 
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Macros Are Tools in Your Toolbelt 

Macros are simply pieces of code that automate tasks and procedures.  They make things faster and easier 

and are tools that accomplish specific tasks.  But like any tool, they should be kept near at hand so that they 

can be used right when you need them.  One way to make your macros more accessible is by storing them in 

your Personal Macro Workbook and then creating buttons for them, so that they can run with just a simple 

click. 

Creating buttons for macros basically requires you to customize either the Excel Ribbon or the Quick Access 

Toolbar.  The ribbon is the tabbed menu that is found just above the formula bar.  The Quick Access Toolbar 

is the line of icons found at the very top of the Excel page. 

 
Again, you will most likely want to store the macros for these buttons in your Personal Macro Workbook 

because that file opens every time you open Excel. Checkout my post & video on the Personal Macro 

Workbook if you don't have yours setup yet. 
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Adding Macro Buttons to the Excel Ribbon 

To add a button to the ribbon, start by right-clicking anywhere on the ribbon or ribbon tabs.  Then 

select Customize the Ribbon. 

 
This will open the Excel Options page, and Customize Ribbon should already be highlighted on the left-hand 

side.  In the right-hand side of the Excel Options page, you will see a list of all the tabs that are currently 

available to you.  

1. Create a New Tab 

We will be making a new tab.  To do that, just select the tab that you want your new tab to come after.  Then 

hit the button that says New Tab. 
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2. Create Groups 

Within each tab, you can have subcategories called groups.  You'll be able to place your macro buttons in 

groups according to their function.  After you've added your new tab and/or group you can change the name 

of it using the Rename button. 

When you choose the Rename option a small window appears allowing you to type in the name of the new 

tab or group.  In my example, I am naming my new tab “Tool Belt.” 

 

3. Add Macro Buttons 

Once you've named both your new tab and the group or groups underneath the new tab, you can start 

adding buttons that correspond with your existing macros.  To view the macros that are available, select 

Macros from the drop-down list under Choose commands from. 

 
Choose the macro that you want to add as a button to your tab.  Then hit Add.  You will see it added to the 

list on the right. 
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Click to Enlarge 

4. Customizing the Button 

Rename the macro so that the file name is not displayed on the button, but whatever title you choose 

instead.  You can also further customize the button by choosing from the icon menu.  This menu is presented 

to you when you click the Rename button. 

 
And that's it!  The new button has been added to the Tool Belt tab.  It runs the macro called Add 3 Sheets 

when pressed.  Here's how it looks on the ribbon: 

https://www.excelcampus.com/wp-content/uploads/2018/11/Select-a-macro-to-add-to-your-ribbon.jpg
https://www.excelcampus.com/wp-content/uploads/2018/11/Add-custom-icon-and-display-name-for-macro-button.jpg
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Adding Macro Buttons to the Quick Access Toolbar 

The process for adding the macro button to the Quick Access Toolbar is essentially the same. However, 

instead of choosing Customize the Ribbon after right-clicking on the ribbon, choose Customize the Quick 

Access Toolbar.  This option is highlighted on the menu below. 

 
If you already have a button for the macro that you want to add to the Quick Access Toolbar, you can right-

click directly on it.  Then choose Add to Quick Access Toolbar (the first option in the menu shown above). 

Export and Import Your Customizations 

If you would like to transfer your customized buttons and tabs to another computer or user, you can do so 

easily.  In the Excel Options window, there is a button on the bottom that says Import/Export.  If you 

choose Export all customizations, they will be placed in a UI file.  You will be prompted to save this file to 

your computer.  If you choose the Import customization file option, a browsing window will appear. This 

will allow you to indicate which file you want to import. 

https://www.excelcampus.com/wp-content/uploads/2018/11/The-new-macro-button-has-been-added-to-the-new-tab.jpg
https://www.excelcampus.com/wp-content/uploads/2018/11/Menu-to-customize-the-Quick-Access-Toolbar.jpg
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Creating a Safety Check for You Macro Buttons 

Now that you've created buttons that run your macros, it's important that you don't accidentally hit one of 

them and inadvertently mess up your worksheet.  To guard against this we can create a Yes/No pop-up 

box just to verify your intentions before proceeding. 

  

https://www.excelcampus.com/vba/personal-macro-workbook-video-series/
https://www.excelcampus.com/vba/personal-macro-workbook-video-series/
https://www.excelcampus.com/wp-content/uploads/2018/11/Import-or-Export-Customizations-to-the-Ribbon-or-Toolbar.jpg
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Learning Unit 6: Collaborate with Spreadsheet Editing 

LO 6.1: Track and review of spreadsheet document 

If you work with an Excel file that needs to be updated or reviewed by other people, the option to track 

changes can come in handy. 

Content/Topic 1: Enabling the Track Changes in Excel Feature 

By default, this feature is disabled in Excel. 

Here are the steps to enable track changes in Excel: 

 Go to the Review tab. 

 

  In the Changes group, click on the Track Changes option and select Highlight Changes. 

 

  In the Highlight Changes dialog box, check the option – ‘Track changes while editing. This also shares your 

workbook’. You can also specify the ‘When’, ‘Who’, and ‘Where’ options. For this tutorial, I will go with the 

default settings.  
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 Click OK. 

The above steps would enable ‘Track Changes’ in Excel and now it will highlight any change done to the workbook. 

Note: For this option to work, you need to have the workbook saved on your system or a network drive. If 

the file has not been saved, it will first ask you to save it before enabling the ‘Track Changes’ option. If the 

file is already saved, it will still save it before enabling the tracking. 

How do ‘Track Changes’ work in Excel? 

Once you have enabled the tracking, whenever you or anybody who accesses the workbook makes any 

changes to it, it will get highlighted with a blue border and get a small blue triangle in the top left of the cell. 

This is similar to the red triangle you see when you insert a comment in a cell. 

Note that when ‘track changes’ option is enabled in Excel, the workbook is shared and some of the features 

are automatically disabled. For example, you will not be able to protect a sheet when ‘track changes’ are 

ON. You will notice that some of the options in the ribbon are grayed out. 

Content/Topic 2: Getting a List of All the Changes 

If you have a workbook that has a lot of changes made to it, you may want to get a list of all the changes 

separately as a list. 

Here are the steps to get a list of all the changes in a new worksheet: 

 Save the workbook so that the changes that are made are saved as well. 

 Go to the Review tab. 

 In the Changes group, click on Track Changes and select Highlight Changes. 

 

  In the ‘Highlight Changes’ dialog box, check the option – ‘List changes on a new sheet’. In the ‘When’ 

option, you can specify if you want all changes or changes that are not reviewed or ‘changes since last saved’. 

https://trumpexcel.com/insert-delete-comments-excel/
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  Click Ok. 

 

This will instantly create a new worksheet that will list all the changes that you have made. 

Content/Topic 3: Accepting/Rejecting Changes 

When the changes are made, these are not final until you review these changes. This can be useful when 

you have the reviewed file from your colleague/boss/client, and you have to decide on what changes are to 

be kept and which ones are to be rejected. 

Here are the steps to accept/reject changes in Excel: 

 Go to the Review tab. 

 In the Changes group, click on the ‘Track Changes’ and select ‘Accept/Reject Changes’. 
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  In the ‘Select Changes to be Accepted or Rejected’ dialog box, specify the When, Who, and, Where options.  

 In ‘When’ you can select all changes that have not been reviewed or specify a date. 

 In ‘Who’ you can select whose changes you want to review. 

 In ‘Where’, you can select a range of cells in which you want to review the changes. 

 

  Click Ok. This will open the ‘Accept or Reject Changes’ dialog box.  

  In the ‘Accept or Reject Changes’ dialog box, you can accept changes one by one, or accept/reject all 

changes at once. 

 

If you reject a change, it will revert back to the original value. 

Note that when you accept a change, you can not undo it. 

Content/Topic 4: Disabling Track Changes in Excel 

Once your work is finalized, you can disable the track changes feature in Excel. That will remove any existing 

blue box in the cells and will stop tracking any further changes. 
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Here are the steps to disable ‘track changes’ in Excel: 

 Go to the Review tab. 

 In the Changes group, click on the ‘Track Changes’ and select ‘Highlight changes’. 

 

 In the ‘Highlight Changes’ dialog box, uncheck the option – ‘Track changes while editing. This also shares 

your workbook’. 

 Click OK.  

 you will see a prompt as shown below. Click on Yes. 

Difference between Comments and Track Changes 

Many people prefer adding comments while reviewing other people’s work in Excel. 

Here are the major differences in ‘comments’ and the ‘track changes’ functionality: 

 You don’t need to edit a cell’s content in order to leave a comment. Track changes, on the other 

hand, would insert a note whenever there is any change in the cell. 

 Adding comment is a manual process, while track changes, when enabled, would automatically 

record everything that happens in the worksheet. 

 You can not get a list of all the comments separately in a worksheet while you can get it with the 

tracking functionality with a simple click. 

 When you enable track changes in Excel, some of the functionalities are disabled. This is not the case 

with comments. 

LO 6.2: Master spreadsheet documents 

Content/Topic 1: Master Documents in Excel: 

If you have a large number of excel files, you will go through each file one by one and enter. It would be 

great if you could link all these files to a single excel file which contained all excel files. So, you can then 

update this single file and all the other files would update. 
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Usually, I open a blank workbook and choose from the upper ribbon the Insert Option, and click on a 

Hyperlink tab that will lead to open Insert Hyperlink dialog box. It is easily to find the list of other files of 

excel which can be selected and highlighted as main links on this master workbook.  

By use of hyperlink, you can create a shortcut or jump that opens a document stored on a network server, 

an intranetor the Internet. You can open the workbook that is stored in the another directory  

A-                 Merging Excel Data Into Word Documents 

It’s probably not surprising that going from one Microsoft Office program to another is simple, as the pieces 

of software were built to interact with each other. Not only are Word, Excel and the other programs strikingly 

similar in the way they flow and work, but also you can actually merge different documents from different 

programs together in one, then make edits in the merged-from program directly in the merged-to program.  

1-                 You have to open Microsoft Word. In order to merge Excel data into an existing Word document, 

click the File tab and browse to the document. Scroll to the section where the Excel spreadsheet should be 

merged. It may be helpful to press “Enter” a few times for some blank space or press “Enter-Ctrl” for a blank 

page. 

2-                 Click the Insert tab, and then click the small "Object" menu within the Text group on the Ribbon. 

3-                 Choose “Object” from the two drop-down options, and then click the “Create from File” tab. 

4-                 Browse to and double-click the Excel spreadsheet to merge. When you are returned to the Object 

window, click “OK” to merge the data into the Word document. 

5-                 Although you’ve completed the merge from Excel to Word, you can perform functions such as 

formatting how the text looks – such as if your spreadsheet was created in one set of fonts and colors and 

you prefer it match your Word document – as well as actually changing the cell contents.  

6-                 This is helpful if you need to redact information that was in the Excel spreadsheet or numbers 

and figures have changed between the time you created the spreadsheet and when you merged it with 

Word. To do this, double-click anywhere on the merged spreadsheet. This opens an Excel window-within-a-

window directly on the Word page. Make your changes, then click off the spreadsheet and the changes are 

set. 

B-                  Consolidate data from multiple worksheets in a single worksheet 
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To summarize and report results from data on separate worksheets, you can consolidate the data from each 

separate worksheet into one worksheet (or master worksheet). The worksheets you consolidate can be in 

the same workbook as the master worksheet or in other workbooks. When you consolidate data in one 

worksheet, you can more easily update and aggregate it on a regular or ad hoc basis.  

There are two main ways to consolidate data: to consolidate by position (to combine data from multiple 

source areas that is arranged in the same order and uses the same row and column labels) or by category 

(to combine data from multiple source areas that is arrange differently, but the same row and column labels 

are used). 

You can consolidate data by using the Consolidate command (Data tab, Data Tools group). You can also 

consolidate data by using a formula or a PivotTable report. 

In each worksheet that contains the data that you want to consolidate, set up the data and make sure of 

that:  

-                     Each range of data is in list format: each column has a label in the first row and contains similar 

facts, and there are no blank rows or columns within the list.  

-                     Put each range on a separate worksheet, but don't put any ranges on the worksheet where you 

plan to put the consolidation.  

-                     Make sure that each range has the same layout.  

-                     By Position or Category Consolidation: 

1-                 In the master worksheet, click the upper-left cell of the area where you want the consolidated 

data to appear. To avoid overwriting existing data in the destination worksheet with the data you are 

consolidating, make sure that you leave enough cells to the right and below this cell for the consolidated 

data. 

2-                 On the Data tab, in the Data Tools group, click Consolidate. 

3-                 In the Function box, click the summary function  that you want Microsoft Excel to use to 

consolidate the data. The file path is entered in the Reference box followed by an exclamation point. 

4-                 If the worksheet that contains the data that you want to consolidate is in another workbook, click 

Browse to locate that workbook, and then click OK to close the Browse dialog box.  
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5-                 Then, in the Reference box, click the Collapse Dialog button to select the data in the worksheet, 

and click the Expand Dialog button later on of your selection 

6-                 In the Consolidate dialog box, click Add to add all of the ranges that you want. 

7-                 To specify how you want to update the consolidation, select Create links to source data Check 

box to set up the consolidation so that it updates automatically when the source data in another workbook 

changes, or clear this check box to update manually. 

8-                 In Category consolidation, select the check boxes under Use labels in that indicate where the 

labels are located in the source ranges: the Top row, the Left column, or both.  Any labels that don't match 

up with labels in the other source areas result in separate rows or columns in the consolidation. Make sure 

that any categories that you don't want to consolidate have unique labels that appear in only one source 

range. 

Insert how to create new master document 

Insert h 

LO 6.3: Apply spreadsheet documents security 

INTRODUCTION TO WORKBOOK SECURITY 

We can apply security to the workbook by the concept of protection available in the Review Tab of ribbon. 

MS Excel's protection-related features fall into three categories. 

 Worksheet protection − Protecting a worksheet from being modified, or restricting the 

modifications to certain users. 

 Workbook protection − Protecting a workbook from having sheets inserted or deleted, and also 

requiring the use of password to open the workbook. 

Content/Topic 1:  Protecting and unprotecting worksheet cells with a password 

Protect Worksheet 

You may want to protect a worksheet for a variety of reasons. One reason is to prevent yourself or others 

from accidentally deleting the formulas or other critical data. A common scenario is to protect a worksheet, 

so that the data can be changed, but the formulas can’t be changed. 

To protect a worksheet, choose Review » Changes group » Protect Sheet. Excel displays the Protect Sheet 

dialog box. Note that providing a password is optional. If you enter a password, that password will be 

required to unprotect the worksheet. You can select various options in which the sheet should be protected. 

Suppose we checked Format Cells option then Excel will not allow to format cells. 
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When somebody tries to format the cells, he or she will get the error as shown in the screenshot below. 

 

To unprotect a protected sheet, choose Review » Changes group » Unprotect Sheet. If the sheet was 

protected with a password, you’re prompted to enter that password. 

Content/Topic 2:  Adding, removing password protection for a spreadsheet Opening, Modifying 

Protecting a Workbook 

Excel provides three ways to protect a workbook. 

 Requires a password to open the workbook. 

 Prevents the users from adding sheets, deleting sheets, hiding sheets, and unhiding sheets. 

 Prevents users from changing the size or position of windows. 

Requiring a Password to Open a Workbook 

Excel lets you save a workbook with a password. After doing so, whoever tries to open the workbook, must 

enter the password. To add a password to a workbook, follow these steps. 

 Choose File » Info » Protect Workbook » Encrypt With Password. Excel displays the Encrypt 

Document dialog box. 

 Type a password and click OK. 
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 Type the password again and click OK. 

 Save the workbook. 

 

To remove a password from a workbook, repeat the same procedure. In Step 2, however, delete the existing 

password symbols. 

Protecting Workbook’s Structure and Windows 

To prevent others (or yourself) from performing certain actions in a workbook, you can protect the 

workbook’s structure and windows. When a workbook’s structure and windows are protected, the user 

may not Add a sheet, Delete a sheet, Hide a sheet, unhide a sheet, etc., and may not be allowed to change 

the size or position of a workbook’s windows respectively. 

To protect a worksheet’s structure and windows, follow the below mentioned steps. 

 Choose Review » Changes group » Protect Workbook to display the Protect Workbook dialog box. 

 In the Protect Workbook dialog box, select the Structure check box and Windows check box. 

 (Optional) Enter a password. 

 Click OK. 



Page 166 of 182 
 

 

 

Content/Topic 3: Hiding and unhiding formulas   

Showing Formulas in Excel 

Showing formulas in Excel, especially for accomplished and proficient Excel users is of paramount 

importance, as it helps in studying the relationships that exist among data without any complexity and also 

facilitates the procedure of error deduction in the application of the mathematical or statistical formulae or 

the cells upon which it operates. 

Using ‘Show Formulas’ option in Excel 

This method to show formulas in Excel is extremely easy to understand and comprehend and involves a 

typical procedure. 

The following steps need to performed sequentially in order to display applied formulae in Excel: 

1. Open the desired Excel sheet and click on ‘Formulas’ tab available on Menu Bar. 

2. Click on ‘Show Formulas’ option in Formulas tab, available under Formula Auditing Section. 

3. Clicking on the option once will display all the formulas at once, whereas clicking on them once again, 

will hide the formulas. However, clicking on specific cells wherein the formula is applied, will display 

formula to user. 
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Using Shortcut Keys in Excel to display Formula 

The above method of displaying formulas is a bit long and can be replaced by a shorter route of displaying 

formulas, namely, pressing ‘Ctrl + `’ keys simultaneously on keyboard , wherein (`) key is known as the grace 

accent key is available furthest on the keyboard, on the left hand side of key 1 on keyboard or above Tab 

key. 

Alternatively, pressing Ctrl+` together can be considered as shortcut key for Show Formulas option as it gets 

highlighted alongwith subsequent display of formulas when the shortcut keys are pressed. 

The Show Formulas shortcut keys operate between displaying cell values and cell formulas and hiding them. 

Thus, once the formulas are displayed by pressing shortcut keys, they can be hidden back once again, by 

pressing the shortcut again.  

However, as evident, that this method is not completely applicable as the standard method for displaying 

and hiding formula due to the fact that when the specific cells upon which formula is applied are selected, 

the formula is still visible in the top formula bar (Formula bar is the bar just below Menu Bar).  

Using ‘Show formulas in cells instead of their results’ Excel option 

An Excel option of ‘Show formulas in cells instead of their results’ available in Excel options can be used to 

display Excel formula. 

Perform the following steps sequentially to display mathematical and statistical formulas in Excel: 

1. In Excel model of2010, Excel 2013 and Excel 2016, click on File tab available on Menu Bar, and then 

click on Options.  

In Excel 2007, click on Office Button available on Menu Bar, and further click on Excel options at the 

bottom. 

2. When Excel Options dialog box opens up, click on Advanced tab available on the left pane of dialog 

box and scroll down to the ‘Display options for this worksheet’ section.  

3. Select the option ‘Show formulas in cells instead of their calculated results’ by clicking the check box 

against it. 

Though, the mentioned method, initially, may seem to look long and tedious, however, in the long run, this 

method is extremely useful when you want to views formulas in a number of Excel spreadsheets, within the 
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currently open Excel workbooks . In that case, you can just select the sheet name from the dropdown list 

available against ‘Display options for this Workbook’ section of Advanced tab and check the ‘Show formulas 

in cells instead of their calculated results option. 

Notes: 

1. Whichever of the aforementioned method of displaying cells you use, Microsoft Excel will show all 

formulas of the current worksheet. To display formulas in other sheets and workbooks, you will need 

to repeat the process for each sheet individually. 

2. If you click a specific cell on which a formula is applied, but the formula is not displayed in the formula 

bar, then the most likely case is that formula is hidden from the user’s accessibility and the worksheet 

is protected. This might be a way of implementing data abstraction and hide the complexities of a 

program. While this might suit to a large variety of users, proficient and skilled Excel users may find 

it unsuitable for which Worksheet protection needs to be removed.  

The following steps needs to be performed for removing Worksheet protection: 

 Click on Review Tab on Menu Bar. 

 Click on Unprotect Sheet option available under Change Section.Uncheck the hidden option in the 

‘Protection’ tab of format cells. 

The Excel formulas would be visible again. 

Hiding Excel Formulas 

Excel formulas can be hidden to implement data abstraction, hide the complexities of Excel Spreadsheets, 

and make the sheets informative, presentable and comprehensive for the end user. 

Replacing Excel formula with computed values 

Excel formulas can be easily replaced by their computed resultant values, which can, in a way, be used to 

hide the complexities of the sheet from the end user and implement data abstraction. This method is also 

essential to understand and comprehend, as it is the only method which considers a vital aspect: Not using 

those formulas again. 

The following steps need to be performed in order to replace Excel formulas with their corresponding 

computed values: 

1. Select the range of cells where you have applied the Excel formula. 
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2. Right click on those cells and click on Paste Special… option. 

3. After the Paste Special window is opened, click on spreadsheet labeled as 123, under Paste Values 

section and click on OK. 

This method replaces the Excel formulas with their corresponding values. 

Note: This method is unsuitable if the Excel formulas need to be reused again. 

Hiding Excel formulas by protecting the Excel sheet 

If you want to hide your formulas temporarily such that they need to be reused again, as desired, the 

following method of Protecting Excel sheet needs to be adopted. In this method, we will first hide the Excel 

formulas and then lock the complete excel sheet, such that the sheet cannot be edited by end user, while at 

the same time, hiding the Excel formulas. Following steps need to be adopted sequentially for the same: 

1. Select the range of cells wherein formula has been applied. 

2. Right click on the range of cells and click on Format Cells option. 

3. Next, in the ‘Format Cells’ dialog box, click on the ‘Protection’ tab. 

4. In Protection Tan, check or click on Hidden checkbox and further click on OK. 

5. Further, to protect the Excel sheet, click on the ‘Review’ tab available on Menu bar and select the 

option ‘Protect Sheet’ under Changes option. 

6. Type a user-defined password to protect the sheet, which is only known to users, who have the 

authority to further access and edit the requisite worksheet. 

7. Click on OK. 

The worksheet is in protected mode, with the Excel formulas hidden. 

In order to view the formulas again, the following steps needs to be performed for removing Worksheet 

protection: 

 Click on Review Tab on Menu Bar. 

 Click on Unprotect Sheet option available under Change Section. 

 Uncheck the hidden option in the ‘Protection’ tab of format cells. 

The Excel formulas would be visible again. 
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Learning Unit 7: Prepare for spreadsheet document outputs 

LO 7.1: Apply spreadsheet document sections 

Introduction to Page Breaks 

If you do not want a row to print on a page by itself or you do not want a table header row to be the last 

line on a page. MS Excel gives you precise control over page breaks. 

MS Excel handles page breaks automatically, but sometimes you may want to force a page break either a 

vertical or a horizontal one. so that the report prints the way you want. 

For example, if your worksheet consists of several distinct sections, you may want to print each section on 

a separate sheet of paper. 

 

Content/Topic 1: Inserting Page Breaks 

Insert Horizontal Page Break − For example, if you want row 14 to be the first row of a new page, select 

cell A14. Then choose Page Layout » Page Setup Group » Breaks» Insert Page Break. 

 

Insert vertical Page break − In this case, make sure to place the pointer in row 1. Choose Page Layout » 

Page Setup » Breaks » Insert Page Break to create the page break. 
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Content/Topic 2: Removing Page Breaks 

 Remove a page break you’ve added − Move the cell pointer to the first row beneath the manual 

page break and then choose Page Layout » Page Setup » Breaks » Remove Page Break. 

 Remove all manual page breaks − Choose Page Layout » Page Setup » Breaks » Reset All Page Breaks. 

Learning Outcome 7.2: Apply spreadsheet document page orientation 

content/Topic 1: Page Orientation 

Page orientation refers to how output is printed on the page. If you change the orientation, the onscreen 

page breaks adjust automatically to accommodate the new paper orientation. 

Types of Page Orientation 

 Portrait − Portrait to print tall pages (the default). 

 Landscape − Landscape to print wide pages. Landscape orientation is useful when you have a wide 

range that doesn’t fit on a vertically oriented page. 

Changing Page Orientation 

 Choose Page Layout » Page Setup » Orientation » Portrait or Landscape. 

 

 Choose File » Print. 
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Content/Topic 2:  Changing margins for sections of a document 

Margins 

Margins are the unprinted areas along the sides, top, and bottom of a printed page. All printed pages in 

MS Excel have the same margins. You can’t specify different margins for different pages. 

You can set margins by various ways as explained below. 

 Choose Page Layout » Page Setup » Margins drop-down list, you can select Normal, Wide, Narrow, 

or the custom Setting. 

 

 These options are also available when you choose File » Print. 

 

If none of these settings does the job, choose Custom Margins to display the Margins tab of the Page Setup 

dialog box, as shown below. 
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Center on Page 

By default, Excel aligns the printed page at the top and left margins. If you want the output to be centered 

vertically or horizontally, select the appropriate check box in the Center on Page section of the Margins tab 

as shown in the above screenshot. 

LO 7.3: Apply spreadsheet document Setup 

In Docs, you can go to "file > page setup" to set the orientation, etc  of a doc, but in Sheets, I do not 

have  "Page setup" under "file". Where do I go in Sheets to set page orientation, margins, etc. 

LO 7.4: Export spreadsheets document 

Export spreadsheets 

content/Topic 1: Print spreadsheets 
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Excel:  

Print 

Sheets:  

Print 

 

Excel 2013 

  

 

Excel 2010 

To print your spreadsheet, click File Print or click Print . 

You can choose which sheets to print, what features to include, and which 

layout you want. 

 

Content/Topic 2: Download in different formats 

Excel: 

Save As 

Sheets: 

Download 

 

Excel 2010, 2013 

You can download your spreadsheet and open it in other 

programs. 

  

 

Content/Topic 3: Make a copy 
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Excel: 

Move or Copy 

Sheets: 

Make a copy 

 

Excel 2013 and 2010 

Copying a spreadsheet is useful for creating templates. For 

example, if you write a lot of project plans, make copies of one plan. 

Then, update each copy for a new project without having to format 

it again. 

1. Click File Make a copy. 

2. (Optional) You can rename the copy, change where you save 

it in Drive, and share it with the same collaborators. 

 

Content/Topic 4: Email a copy 

 

Excel: 

Send as Attachment 

Sheets: 

Email as attachment 

 

Excel 2013 

  

If you need to collaborate with someone on your 

spreadsheet in your old program or format, such as PDF or 

Excel, you can email it as an attachment. 

1. Open the spreadsheet and click File Email as 

attachment. 

2. Select a format. 

3. Enter the email addresses or groups you want to 

send copies to. 

4. Add a message. 

5. Click Send. 
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Excel 2010 
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Learning 8: Print the Spreadsheet Document 

LO 8.1: Preview spreadsheet document in print preview mode 

When you select one or more sheets and then click File > Print, you will see a preview of how the data will 

appear on the printout. 

1. Select the worksheet(s) you want to preview. 

2. Click File, and then click Print to display the Preview window and printing options. 

 

Keyboard shortcut    You can also press Ctrl+F2.   

Notes:  

 Unless you're using a color printer, the preview will appear in black-and-white, even if there is color 

in your sheet(s). 

o Next Page and Previous Page are available only when you select more than one sheet, or 

when a sheet contains more than one page of data. To view multiple worksheets, under 

Settings, click Entire workbook. 

o More useful information  
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o To preview the next and previous pages, click the arrows for Next Page and Previous Page at 

the bottom of the Print Preview window—or type the page number. 

o To exit Print Preview and return to your workbook, click any the arrow in the upper-left of 

the Print Preview window. 

o To view page margins, click the Show Margins button in the lower right corner of the Print 

Preview window. 

o To change margins, drag the margins to the height and width that you prefer. You can also 

change the column widths by dragging the handles at the top or bottom of the print preview 

page. For more about page margins,.   

Tip: To make page setup changes, such as changing page orientation and page size, select the appropriate 

options under File > Print > Settings. 

To select one or more sheets  

To select  Do this  

A single sheet 

Click the sheet tab. 

 

If you don't see the tab that you want, click the scrolling buttons to display the tab, and 

then click it.  

 

  

Two or more 

adjacent sheets 

Click the tab for the first sheet. Then hold down the SHIFT key and click the tab for the 

last sheet that you want to select. 

Two or more 

nonadjacent sheets 

Click the tab for the first sheet. Then hold down CTRL while you click the tabs of the 

other sheets that you want to select. 

All sheets in a 

workbook 
Right-click a sheet tab, and then click Select All Sheets. 
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Tip: When selecting multiple sheets, [Group] appears in the title bar at the top of the sheet. To cancel a 

selection of multiple sheets in a workbook, click any unselected worksheet. If no unselected sheet is visible, 

right-click the tab of a selected sheet, and then click Ungroup Sheets. 

LO 8.2: Select printer settings 

Content/Topic 1: Printing of an Excel document 

To print a document in Excel, there are 2 basic ways: 

Quickly and without settings. Click to the «Quick print» tool on the Quick Access toolbar, and the document 

immediately depart to the printer, without any controls fields and parameters. But still after pressing this 

button, the printer does not start immediately, the printer settings dialog box appears only. 

 

With preview and settings. Select «File» – «Print» (or press the combination of hot keys CTRL + P). 



Page 180 of 182 
 

 

The dialog box will appear to configure the print and preview settings.  

How can I set up printing in Excel? 

There is detailed parsing of print parameters and the value of buttons and options of parameters: 

1. Printing – prints the document data to the printer, taking into account all settings and options. 

2. Copies – are the number of exemplars of a printed document. The default is 1. You can enter a value 

from the keyboard or use the arrows. 

3. The printer model – while working on the local network, this item can contain a whole list of printers. 

One computer can also be connected to more than one printer. In addition, this option displays faxes 

and virtual printers for generating PDF files. 

4. Printer Properties – clicking on this link, the dialog box for setting the parameters of the selected 

printer is opened. These parameters are depend from the model and type of the printing device. 

5. Print Active Sheets – the default option is to print only active sheets, but if you click on it, the list of 

additional options will open: «Print the entire book» (to print data for printing the entire Excel 

workbook) and «Print selected fragment» (to print only the data range). These names are spoken for 

their functions. Also in this list is the option «Ignore print area» available. It operates in the switch 

mode and can be activated / deactivated together with any of the above described options. It can be 
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used when a print area is specified, and it needs to be ignored, or it is worth using this function when 

printing a blank page from Excel. This means that the print area is set incorrectly and should be 

ignored. 

6. Pages – here you can set the range of page numbers that you want to print. For example, print only 

from the 5-th to the 12-th page. 

7. Collated – this function is selected by default. This means that if a document is printed in several 

copies, the first copy will be printed first, then the second, the third, and so on. This function can be 

switched to another mode «Uncollated» – this means that first all the first pages of all copies will be 

printed, then only the second pages, the third ones, etc. 

8. Portrait orientation – the choice orientation of the page, which can be changed to landscape 

orientation. 

9. A4 - here you can specify the paper size, on which the printer will be printed. There are many formats 

available for selection in the list, but even if you do not find a suitable format, then for you the option 

is available below the list: «Other page sizes» where you can find your format in the «Page Setup» 

dialog box. There, in the «Paper Size» list, all the formats of the «International Standard ISO 216» are 

provided. Also included are paper formats: «North American Standard» and «Japanese Standard». 

10. Last Custom Margins Setting – by default, this setting provides custom values. For convenience, 3 

ready-made and already customized field templates are provided: «Normal», «Wide», «Narrow». 

11. No scaling – this parameter to adjust the size of the data scale, which will be placed on the sheets of 

paper.  

LO 8.3: Set printer properties and execute spreadsheets document printing 

Content/Topic 1:  Change of print output orientation Portrait, Landscape Change paper size 

Page Orientation 

Page orientation refers to how output is printed on the page. If you change the orientation, the onscreen 

page breaks adjust automatically to accommodate the new paper orientation. 

Types of Page Orientation 

 Portrait − Portrait to print tall pages (the default). 

 Landscape − Landscape to print wide pages. Landscape orientation is useful when you have a wide 

range that doesn’t fit on a vertically oriented page. 

Changing Page Orientation 

 Choose Page Layout » Page Setup » Orientation » Portrait or Landscape. 
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 Choose File » Print. 

 

 

 

 

 

 

 

Reference books:  

1. Official version of ECDL / ICDL Advanced Spreadsheets Syllabus Version 2.0 is the version published on the 

ECDL Foundation website: www.ecdl.org  

2.  http://www.ecdl.ch/  

3. https://products.office.com/en/excel  

4. http://www.pcworld.com/article/3010614/software-productivity/meet-excel-2016-9-of-its-bestnew-

features-from-databases-to-handwriting-tools.html 
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