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Purpose statement 

 

This module describes the skills, knowledge and attitudes required to characterize, assess 

and grade of digital 2D animation creation. At the end of this module, participants must be 

able to produce 2D animation for film and video in both production and post-production 

stages. 

 

 

 



Page 2 of 74 
 

 

Table of Contents 

Elements of competence and performance criteria Page No. 

Learning Unit Performance Criteria 

1. Describe animation 

principles 

 

1.1.Adequate description of computer animation 

history 

3 

1.2.Proper studying of principles and types of 

animation 

1.3.Adequate description of the production 

process of animation 

2. Build 2D character and 

environment for animation 

2.1 Suitable description of illustration design 

software in accordance with project requirements 

19 

2.2 Careful tracing and editing of character and 

environment base project requirements  

2.3 Proper exportation of character and 

environment in dependence of project 

requirements  

3. Create 2D digital 

animation 

3.1 Suitable description of animation software 

based on the project requirements  

38 

3.2 Proper creation of 2D digital animation 

project based on given requirements  

3.3.Appropriate exportation of 2D animation 

based on project requirement 
 

 

 

 

 

Total Number of Pages: 74 

 

 

 

 

 

 



Page 3 of 74 
 

Learning Unit 1: Describe Animation Principles 

Learning outcome 1.1: Describe Computer Animation History 

● History of animation 

History of early animation 

 Pioneers of animation 

 

-J. Stuart Blackton (1875-1941)  

British filmmaker J. Stuart Blackton is credited with creating the first animation in America 

and was among the first in the world to use stop-motion as a storytelling technique. In 1896, 

Blackton, a reporter for the New York Evening World, was sent to interview Thomas Edison 

about his brand new Vitascope invention. In an age where wooing reporters was critical to 

success, Edison took Blackton to Black Maria, his studio-cabin, and created an impromptu 

film of Blackton doing a lightning sketch of Edison himself. Blackton became so infatuated 

with the technology that he soon founded the American Vitagraph Company and began 

producing films, debuting with The Enchanted Drawing in 1900. 

In the film, previously featured here, Blackton sketches a face, cigars, and a bottle of wine, 

then "removes" these last drawings as real objects so that the face appears to react. 

Although the stop-motion sequence isn't considered "true" animation in technical terms the 

way Little Nemo, which Blackman co-directed with McCay, is, the technique offered an early 

glimpse of what animation could become. 

- Winsor McCay (1869-1964)  

Cartoonist and artist Winsor McCay (1869-1964) is often considered one of the fathers of 

"true" animation. 

His 1911 film, Winsor McCay, the Famous Cartoonist of the N.Y. Herald and His Moving 

Comics, also referred to simply as Little Nemo and featured here last week, contains two 

minutes of pure animation at around 8:11, using sequential hand-illustration in a novel way 

not seen in previous films. 

 

 

http://en.wikipedia.org/wiki/J._Stuart_Blackton
http://en.wikipedia.org/wiki/Edison%27s_Black_Maria
http://www.brainpickings.org/index.php/2010/03/23/the-enchanted-drawing/
http://en.wikipedia.org/wiki/Winsor_McCay
https://www.theatlantic.com/life/archive/2011/06/the-first-true-animation-celebrating-winsor-mccay/241284/
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- John Bray (1874-1978)  

Founder of the first animation studio/factory. 1914 Earl Hurd patented the use of clear cels 

over background. Hurd and Bray formed the Hurd and Bray Processing Company 1914. With 

additional patent obtained by Bray, the company monopolized the animation process. The 

patents expired in 1932. Much of what Bray claimed to have invented have been credited to 

McCay and others. 

- RMax& David Fleischer (1883- 1972, 1884-1979) (Fleischer Brother) 

Max Fleischer invented the rotoscope technique. Fleischer Studios, headed by Dave and 

Max Fleischer, were responsible for Betty Boop, Popeye and Superman.Betty was the first 

featured female character in American animation. In 1934, the Hays Code (censorship for 

film) was enacted in Hollywood and Betty lost most of her charm 

- Walt Disney (1901-1966) 

Walt Disney is a famous business, an American business man design famous characters. He 

was an animator and cartoonist; a major figure knows as the co-founder of the Walt Disney 

Company. Film producer and showman but the main skill was he was an innovator of 

animation designs. In 1923 he created a short film which is very well known. It was called 

Alice in wonderland which had actress interacting with animated characters. 

 Key frame animation 

In media production, a key frame or keyframe is a location on a timeline which marks the 

beginning or end of a transition. It holds special information that defines where a transition 

should start or stop. The intermediate frames are interpolated over time between those 

definitions to create the illusion of motion. 

- What does In-Betweening (Tweening) mean? 

Inbetweening is the process of creating transitional frames between two separate objects in 

order to show the appearance of movement and evolution of the first object into the 

second object. It is a common technique used in many types of animation. The frames 
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between the key frames (the first and last frames of the animation) are called “in-

betweens” and they help make the illusion of fluid motion. 

- Clean-Up  

Clean-up animation is the process of creating the final drawings you see in the finished film. 

It does not necessarily mean a "clean" fine line. The artist, usually a team of artists, uses key 

drawings and animation charts from the animator, making it appear as though one artist 

has created the whole film. 

Pen 

The Pen tool provides feedback about its current drawing state by displaying different 

pointers, The Pen Tool is used to draw a line, a path, or a series of lines. It is also used to 

manipulate existing lines. ... You can use the Pen tool to draw one line, many lines, or a 

shape. You can draw a line that stands by itself. You can draw a series of lines attached to 

each other 

- Ink 

The Ink animation is entirely a Chinese-style animation, the ancient art of Oriental ink was 

used in animation creation, in order to achieve the novel prospect of indifferent and quiet. It 

can be described as a great creation by the Chinese animation artists. As time went on, the 

three-dimensional ink animation has become a product of the digital age, which was based 

on the tradition of bold ink painting and formed a strong artistic trends. 

- Multi-layer camera stand 

The multiplane camera is a motion-picture camera used in the traditional animation 

process that moves a number of pieces of artwork past the camera at various speeds and at 

various distances from one another. This creates a sense of parallax or depth. 

The camera created the illusion of depth, which helped make animated films look more 

interesting and realistic 
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 History of computer animation 

 Early computers 

The category of early computers contains the computer systems made in the early era (i.e., 

the era in modern computer history defined as the period from the late 1930s to the early 

1960s) utilizing mechanical, vacuum tube, discrete transistor, or other pre-integrated circuit 

technology. 

 Pioneers of computer Graphics 

- John Whitney, Sr.(1918-1996) 

Pioneer computer animator John Whitney Sr. in 1959, operating one of the first computer-

graphics engines, a mechanical analogy computer built largely from surplus World War II 

anti-aircraft guidance hardware. The camera is in the upper left, aiming down through the 

apparatus that "paints" the film with light. Photo by Charles Eames 

-  Charles Csuri (1922- ) 

Charles A. Csuri is an artist and computer graphics pioneer and Professor Emeritus, at The 

Ohio State University. ... Chrysler, movie actor Jose Ferrer, pop artist Roy Lichtenstein and 

sculptor George Segal. In 1964, he experimented with computer graphics technology and in 

1965 he began creating computer animated films. He was described by the Smithsonian 

magazine as the father of digital art and computer animation. 

 

https://en.wikipedia.org/wiki/Computer
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 Perfecting photorealism 

In the short history of computer graphics, a number of techniques have been developed to 

create photo-realistic images of computer generated 3D objects. 

 

Example of Photorealism 

 Seeking non-photorealism 

Techniques to generate non-photorealistic images started showing up in the 90s, giving 

artists a wider range of styles to select 

 

 Ancient Animation tools 

 Shadow puppets  

Shadow puppets are figures that are placed between a light and a screen. Moving them 

creates the illusion of moving images on the screen. An experienced puppeteer can make 
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figures appear to walk, talk, fight and dance. Shadow puppetry is a popular form of 

entertainment in countries all over the world.  Shadow puppets can be made from a wide 

variety of materials, though. Today, you might see shadow puppets made out of paper, 

plastic, wood or cloth. 

 

 Flipbook 

A flip book or flick book is a book with a series of pictures that very gradually change from 

one page to the next, so that when the pages are turned rapidly, the pictures appear to 

animate by simulating motion or some other change. Flip books are often illustrated books 

for children, but may also be geared towards adults and employ a series of photographs 

rather than drawings. Flip books are not always separate books but may appear as an added 

feature in ordinary books or magazines, often in the page corners. Software packages and 

Websites are also available that convert digital video files into custom-made flip books 

 

 

 



Page 9 of 74 
 

 Thaumotrope 

A thaumatrope is an optical toy that was popular in the 19th century. A disk with a picture 

on each side is attached to two pieces of string. When the strings are twirled quickly 

between the fingers the two pictures appear to blend into one due to the persistence of 

vision. 

 

 Phenakistiscope  

The phénakisticope (better known as phenakistiscope or the later misspelling 

phenakistoscope) was the first widespread animation device that created a fluid illusion of 

motion. Like a GIF animation, it can only show a short continuous loop 
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 Zoetrope   

A zoetrope is one of several pre-film animation devices that produce the illusion of motion 

by displaying a sequence of drawings or photographs showing progressive phases of that 

motion. 

 

 

 Photograph 

The word photography derives from the Greek photos ("light") and grapher ("drawing"). 

The term was coined by Hercules Florence, a French painter and inventor, who used it in his 

diary to describe the process. Photos is also the root of words such as photon or 

photophobia (fear of light) 
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Learning Outcome 1.2: Apply Principles and Types of Animation 

 The 12 Basic Principles of Animation 

1) Squash and Stretch 

Squash and stretch is debatably the most fundamental principle. Look at what happens 

when a ball hits the ground. The force of the motion squashes the ball flat, but because an 

object needs to maintain its volume, it also widens on impact. This what’s called squash and 

stretch. This effect gives animation an elastic life-like quality because although it may not 

seem like it, squash and stretch is all around you. All shapes are distorted in some way or 

another when acted upon by an outside force; it’s just harder to see in real-life. Squash and 

stretch imitates that and exaggerates it to create some fun. 

2) Anticipation 

Imagine you’re about to kick a soccer ball. What’s the first thing you do? Do you swing your 

foot back to wind up? Steady yourself with your arms? That’s anticipation. 

Anticipation is the preparation for the main action. The player striking the soccer ball would 

be the main action, and the follow-through of the leg is well… the follow through. 

3) Staging 

When filming a scene, where do you put the camera? Where do the actors go? What do you 

have them do? The combination of all these choices is what we call staging. 

Staging is one of the most overlooked principles. It directs the audience’s attention toward 

the most important elements in a scene in a way that effectively advances the story. 

4) Straight Ahead Action and Pose-to-Pose 

These are two ways of drawing animation. Straight ahead action is where you draw each 

frame of an action one after another as you go along. With pose-to-pose, you draw the 

extremes – that is, the beginning and end drawings of action – then you go on to the middle 

frame, and start to fill in the frames in-between. 
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Pose-to-pose gives you more control over the action. You can see early on where your 

character is going to be at the beginning and end instead of hoping you’re getting the timing 

right. By doing the main poses first, it allows you to catch any major mistakes early. The 

problem with it is that sometimes it’s too neat and perfect 

Straight ahead action is less planned, and therefore more fresh and surprising. The problem 

with it is that it’s like running blindfolded… you can’t figure out where you’re supposed to 

be at any one time. 

Mastering both techniques and combining them is the best approach to being a successful 

animator because then you can get both structure and spontaneity.  And incidentally, this 

distinction is just as important in computer animation, where molding a pose at each key 

frame is the equivalent of making a drawing. 

5) Follow-Through and Overlapping Action 

When a moving object such as a person comes to a stop, parts might continue to move in 

the same direction because of the force of forward momentum. These parts might be hair, 

clothing, jowls, or jiggling flesh of an overweight person. This is where you can see follow-

through and overlapping action. The secondary elements (hair, clothing, fat) are following-

through on the primary element, and overlapping its action. 

Follow-through can also describe the movement of the primary element though. If you land 

in a crouch after a jump, before standing up straight, that’s follow-through. 

Take a look at an example from a video we did for View Boost. Watch the sleeves of the 

“Cheese Jedi’s” cloak when he swings his lightsaber. They move with the momentum of the 

action, but when it’s over, the sleeves continue to go before settling to a stop. 

6) Ease in, Ease Out 

When you start your car, you don’t get up to 60 mph right away. It takes a little while to 

accelerate and reach a steady speed. In animation speak, we would call this an Ease Out. 

https://vimeo.com/48972495
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Likewise, if you brake, you’re not going to come to a full stop right away. (Unless you crash 

into a tree or something.) You step on the pedal and decelerate over a few seconds until 

you are at a stand-still. Animators call this an Ease In. 

Carefully controlling the changing speeds of objects creates an animation that has a superior 

believability. 

7) Arcs 

Life doesn’t move in straight lines, and neither should animation. Most living beings – 

including humans – move in circular paths called arcs. 

Arcs operate along a curved trajectory that adds the illusion of life to an animated object in 

action. Without arcs, your animation would be stiff and mechanical. 

8) Secondary Action 

Secondary actions are gestures that support the main action to add more dimension to 

character animation. They can give more personality and insight to what the character is 

doing or thinking. 

9) Timing 

Timing is about where on a timeline you put each frame of action. To see what this means in 

action, let’s look at the classic animator’s exercise: the bouncing ball that we saw earlier 

when we were talking about squash and stretch. (The reason this is a popular assignment is 

that there is a lot of wisdom to be gained from it!) 

10) Exaggeration 

Sometimes more is more. Exaggeration presents a character’s features and actions in an 

extreme form for comedic or dramatic effect. This can include distortions in facial features, 

body types, and expressions, but also the character’s movement. Exaggeration is a great 

way for an animator to increase the appeal of a character, and enhance the storytelling. 
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11) Solid Drawing 

Solid drawing is all about making sure that animated forms feel like they’re in three-

dimensional space. 

12) Appeal 

People remember real, interesting, and engaging characters. Animated characters should be 

pleasing to look at and have a charismatic aspect to them; this even applies to the 

antagonists of the story.Appeal can be hard to quantify because everyone has a different 

standard. That said, you can give your character a better chance of being appealing by 

making them attractive to look at. 

Play around with different shapes and proportions of characters to keep things fresh. 

Enlarging the most defining feature of a character can go a long way to giving the character 

personality. Strive for a good balance between detail and simplicity. 

 Animation types 

 Traditional animation (2D, Cel, Hand Drawn) 

Traditional animation usually refers to animation hand-drawn on paper. It was the process 

used for most of the productions throughout the 20th century. An animator draws the 

characters, layout and backgrounds on paper.An animator draws the characters, layout and 

backgrounds on paper. Each drawing in the animation would be slightly different than the 

one before it and the one following it, creating the illusion of movement when everything is 

put onto film. Examples Traditional Animation Software:  Toon Boom Harmony, TVPaint 

 2D vector based animation  

Nowadays there are new ways to create 2D animation using a 2D digital puppets. These are 

2D characters which are built with a system of bones and controls that can be manipulated 

in a way similar to a 3D character rig. The difference between 2D rigged characters and 

hand-drawn characters can get a bit blurry. Programs like Toon Boom Harmony and Adobe 

Animate CC let you seamlessly mix and match hand-drawn animation with 2D puppet 

techniques, sometimes even within the same character. 

https://www.bloopanimation.com/toon-boom-animation/
https://www.bloopanimation.com/animate-cc-animation/
https://www.bloopanimation.com/animate-cc-animation/
https://www.bloopanimation.com/animate-cc-animation/
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 3D computer animation (CGI, Computer animation) 

3D, also referred to as CGI (computer generated imagery), is the most popular type of 

animation for feature films currently, and it's become common in TV and short films as well. 

This is also the same type of animation used to create digital characters for live-action films 

and animation for video games. Instead of drawn or constructed with clay, characters in 3D 

animation are digitally modelled in the program, and then fitted with a ‘skeleton’ that 

allows animators to move the models. Animation is done by posing the models on certain 

key frames, after which the computer will calculate and perform an interpolation between 

those frames to create movement. When the modelling and/or animation is complete, the 

computer will render each frame individually, which can be very time-consuming, 

depending on the quality of the images needed. A 3D animator will spend most of their time 

looking at curves that represent the movement of different body parts over time. Another 

big difference with 3D animation is that unlike traditional animation, the character’s body 

parts are always present and should be taken to consideration. Example of 3D animation 

software: Autodesk Maya; Blender: Cinema 4D. 

 Motion graphics (Typography, Animated Logos) 

Motion graphics focuses on making dynamic and interesting presentations of moving text 

logos and basic illustrations. Motion graphics can be both 2D and 3D, and you'll find them 

everywhere in commercials, explainer videos, sporting events, the news and other TV 

productions. Proper character animation is generally outside the scope of motion graphics, 

but many of the core animation principles apply to motion graphics too. The process of 

creating Motion Graphics depends on the programs used, since video editing softwares 

often have different UI or settings, but the idea is the same. Motion Graphics usually 

involves animating images, texts or video clips using key framing that are tweened to make 

a smooth motion between frames. Example of Motion graphics software: Adobe After 

Effects, Cinema 4D. 

 Stop motion (Claymation, Cut-Outs) 

Stop motion is an animated filmmaking technique in which objects are physically 

manipulated in small increments between individually photographed frames so that they 

https://en.wikipedia.org/wiki/Animation
https://en.wikipedia.org/wiki/Filmmaking


Page 16 of 74 
 

will appear to exhibit independent motion or change when the series of frames is played 

back. Any kind of object can thus be animated, but puppets with movable joints (puppet 

animation) or plasticine figures (clay animation or Claymation) are most commonly used. 

Puppets, models or clay figures built around an armature are used in model animation. Stop 

motion has several variants, but they all involve manipulating real world objects. These 

objects are moved slightly, and photographed one frame at a time. When shown in 

sequence, these frames create the illusion of movement. Example of stop animation 

software: Dragon frame, Stop Motion Studios 

Learning Outcome 1.3: Describe the production process of animation 

 2D animation production process: 

 Creative development:  

 Scripting 

Script Writing. Script writing, sometimes called Screenwriting, involves creating an outline 

of all of the events taking place in an animation. This means detailing all of the audio such 

as dialogue, sound effects and music score 

 Storyboarding 

A storyboard is a graphic organizer that consists of illustrations or images displayed in 

sequence for the purpose of pre-visualizing a motion picture, animation, motion graphic or 

interactive media sequence. 

 

 

 Animatic 

An animatic is defined as series of images played in sequence, often with a soundtrack. In 

essence, it's an animated storyboard. Animatic are created by playing a series of images in 

order and changing the timing on each frame. Timings changes are used to create a sense of 

pace. 

https://en.wikipedia.org/wiki/Plasticine
https://en.wikipedia.org/wiki/Clay_animation
https://en.wikipedia.org/wiki/Armature_(sculpture)
https://en.wikipedia.org/wiki/Model_animation
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 Production: 

 Voice over recording  

Voice-over (also known as off-camera or off-stage commentary) is a production technique 

where a voice—that is not part of the narrative (non-diegetic)—is used in a radio, television 

production, filmmaking, theatre, or other presentations. On most cases though, voice over 

will be recorded first by reading a script, then the animation will be done to follow 

the animation. Some producers, like Disney, also asks the actor to actually perform the 

action so they can do a better voice take, and record more than just a couple of takes of it. 

 

 Character creation  

Character creation (also character generation or character design) is the process of defining 

a game character or other character. Typically, a character's individual strengths and 

weaknesses are represented by a set of statistics. Games with a largely fictional setting may 

include traits such as race and class. Games with a more contemporary or narrower setting 

may limit customization to physical and personality traits 

 Key animation  

A key animation is an act of producing the principal key frames of an animation. 

Basically key animation are the essential frames that mark a distinct position or expression 

of a character in a particular scene. In other words, it is the structure of an animated scene. 

 lighting  

Cinematic lighting is a film lighting technique that goes beyond the standard three-

point lighting setup to add drama, depth, and atmosphere to the story. 

Cinematic lighting utilizes lighting tricks like bouncing light, diffusing light, and adjusting 

color temperatures. 

 

 

https://en.wikipedia.org/wiki/Player_character
https://en.wikipedia.org/wiki/Statistic_(role-playing_games)
https://en.wikipedia.org/wiki/Fantasy_race
https://en.wikipedia.org/wiki/Character_class
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 Background painting  

Background is called the matrix of a painting. Something that holds the foreground or main 

subject to our focus. Background painting is the process of animation by establishing the 

color, style, and mood of a scene drawn by an animation layout artist. The methods used 

can either be through traditional painting or by digital media such as Adobe Photoshop. 

Traditional methods involved painting entire production scenes for a television 

program or film. Current methods may involve painting primarily background keys or 

the establishing shot while production background artists paint the corresponding 

background paintings 

  Rendering 

3D Character Animation renders may include photorealistic effects or non-

photorealistic rendering. Rendering is the final process of creating the actual 2D image 

or animation from the prepared scene. This is the procedure where the computer compiles 

the animation work in video format which takes some time. 

 Post-Production 

 Special effects  

Special effects (often abbreviated as SFX, SPFX, F/X or simply FX) are illusions or visual tricks 

used in the theatre, film, television, video game and simulator industries to simulate the 

imagined events in a story or virtual world. 

 Editing Sounding  

We describe sound editing as an art of producing great quality sounds for mixing, 

implementation and processing. In simpler words, sound editing is a laborious task of 

making noisy and lousy recordings sound good. It is one of the processes that make the 

project whole 

According to Michael Geisler, “Sound effects play an important role in conveying action. 

Music helps express emotion.” This goes to show that adding sound effects to 

our animation gives life and meaning to the characters as it move, talk, cry, shout, scream 

and the like. ... It in 2D or 3D animation. 

 

https://en.wikipedia.org/wiki/Animation
https://en.wikipedia.org/wiki/Page_layout
https://en.wikipedia.org/wiki/Painting
https://en.wikipedia.org/wiki/Digital_media
https://en.wikipedia.org/wiki/Adobe_Photoshop
https://en.wikipedia.org/wiki/Television_program
https://en.wikipedia.org/wiki/Television_program
https://en.wikipedia.org/wiki/Television_program
https://en.wikipedia.org/wiki/Film
https://en.wikipedia.org/wiki/Establishing_shot
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 Color styling  

A color styling is a process of chooses the colors for characters, props, and effects in 

a cartoon or animation. It's a full time job because you have to do that for every single 

character, prop, or effect in every single lighting situation that happens in a show 

 Final rendering 

While rendering stills will allow you to view and save the image from the render buffer 

when it is complete, animations are a series of images, or frames, and are automatically 

saved directly out to a drive after being rendered. After rendering the frames, you may need 

to edit the clips, or first use the Compositor to do green-screen masking, matting, color 

correction, DOF, and so on to the images. That result is then fed to the Sequencer where the 

strips are cut and mixed and a final overlay is done. Finally, you can render out from the 

Sequencer and compress the frames into a playable movie clip. 

  Product delivery 

This the platforms by which you can save your animation. We can include the following:CD, 

DVD, Film, Games console, Internet, Kiosk, Mobile phone, PDA (personal digital assistant) 

Learning Unit 2: Build 2D Character and Environment for            

Animation 

Learning Outcome 2.1: Describe illustration design software 

 Categories of Illustration design software:   

 Vector based software: 

Vector based programs are applications that allow its user to create and manipulate 

digital images through commands, both geometric and mathematical, resulting in a 

different type of design creation than a drawing that is made with clicks and strokes 

Ex: - Adobe illustrator  

      - Inkscape  

 



Page 20 of 74 
 

 Pixel based software 

Raster images are created with pixel-based programs or captured with a camera or 

scanner. They are more common in general such as jpg, gif, png, and are widely used on 

the web. Vector graphics are created with vector software and are common for images 

that will be applied onto a physical product. 

Ex: - Adobe Photoshop 

 

 Compatibilities of illustration design software with hardware:  

 Installation of illustration design software  

 Adobe illustrator  

The following are the minimum requirement to install Adobe Illustrator on Windows 

Operating System: 

 RAM of the System needs to be minimum 2GB for 32 Bits and 4GB for 64 bits 

 The processor recommended is Multicore Intel Processor with 32bit or 64-bit support. 

An AMD Athlon 64 processor will also work for installing Adobe Illustrator. 

 An Operating System with Windows 7 with Service pack 1 installed. 

 The resolution of the monitor must be 1024 X 768 minimum. 

 Minimum 2GB of Hard disk is required for the program installation. A Graphics Card is 

also recommended before installation 

 An OpenGL 4.x is also recommended for the smooth working of the program. 

The following are the minimum requirement to install Adobe Illustrator on MAC 

Operating System 

 4GB of RAM is required 

 MAC OS version 10.13, 10.12. 1014 is the minimum required for smooth workings of 

the software 

 A Multicore Intel Processor of 64 bit is also a minimum requirement for Adobe 

Illustrator to work on Mac OS 

 A 2GB of RAM is minimum required for installation of the product, while an extra 

space is required after installation 

 An OpenGL 4.0 or Greater is required, while it is also recommended to have a 

minimum of 1GB VRAM Space to use GPU Actively 

 A resolution of 1024 X 768 is also required.  

 A running Internet Connection for licensing and registration is also recommended. 
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 Adobe Photoshop 

Adobe Photoshop CS6 - Windows Install 

1. Open the Photoshop Installer. Double-click Photoshop_13_LS16. 

2. Choose Location for Download. Click Next. ... 

3. Allow the Installer to Load. This may take several minutes. 

4. Open the "Adobe CS6" Folder. ... 

5. Open the Photoshop folder. ... 

6. Open the Adobe CS6 folder. ... 

7. Open the Set Up Wizard. ... 

8. Allow Initializer to Load. 

 Inkscape 

1. Using a Web browser, go to the Inkscape website’s download page for Windows and 

select the best download for your system. If you are unsure if you need the 32-bit or 

64-bit version, read the section about Identifying Your System Architecture first. 

2. Select an installation method from the available choices (exe, msi, portable) and wait 

for it to download. You should either see a window giving you the option to save the 

file or a pop-up will appear at the bottom of your web browser with the file’s name 

and a timer stating how long until the download is complete. 

3. Once the download is complete, either click on the file in the lower left corner of 

your screen to start the installation process or, if need be, go to your file explorer 

and open your downloads folder and select the file from there. It should be the first 

file at the top of the folder. 

4. If you get a User Account Control pop-up from Windows similar to the following one 

click “OK” and wait for the Inkscape installation program to start. 

5. Select what language you want to use during the installation and click OK. Then click 

next on both the following welcome screen and license agreement screen. 

6. On the Choose Components screen you can select which features you want to install 

or not install. In most cases the default options should provide all that the user 

needs, so click next. 
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7. On the Choose Install Location window leave the destination folder as C:\Program 

Files\Inkscape and click Install unless you want Inkscape to be installed in a specific 

location on your computer. 

8. Once you click Install, a progress bar will appear showing how long it will take for 

your program to install. 

9. After the installation is complete, click Finish and the installer will automatically 

open Inkscape for you and you are ready to begin working with Inkscape. 

 Description of Size and interface’s resolution 

In order to handle an increase in data flow, we need wider interfaces, higher resolution 

interfaces, higher bandwidth interfaces, with those not in our community. 

To survive, interfaces must quickly flow from spaces of high-resistance and poor usability to 

spaces that reduce the number of interface changes needed to get to relevant data.  

1) Environments are becoming aware of relevant information, and are able to pull context-

aware data into play when necessary.  

- (Windows) Choose Edit > Preferences > User Interface. 

- (macros) Choose Illustrator > Preferences > User Interface. 

 

 

2) Adjust the UI Scaling slider. A preview of the scaled UI is displayed in the Preferences 

dialog box. 
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3) Select the Scale Cursor Proportionately option to scale the cursor icons in proportion to 

the UI. 

4) To apply this setting, relaunch Illustrator. If you do not relaunch Illustrator, the changes 

will take effect the next time you launch Illustrator. 

 

 Install software utilities  

 DirectX 

Microsoft DirectX is a collection of application programming interfaces (APIs) for handling 

tasks related to multimedia, especially game programming and video, on Microsoft 

platforms. ... Direct3D is also used by other software applications for visualization 

and graphics tasks such as CAD/CAM engineering 

To identify your graphics driver in a DirectX* Diagnostic (DxDiag) report: 

1. Start > Run (or Flag + R) Note: Flag is the key with the Windows* logo on it. 

2. Type DxDiag in the Run Window. 

3. Press Enter. 

4. Navigate to the tab listed as Display 1. 

5. The driver version is listed under the Driver section as Version. 

 

 

 Drivers  

Before the GPU can be used for intensive workloads like gaming, and graphics, you need to 

get new drivers installed so Windows and software can effectively communicate with 

the card 

Graphics device drivers are written for specific hardware to work within a specific operating 

system kernel and to support a range of APIs used by applications to access 

the graphics hardware. ... The driver is made up of a compiler, a rendering API, and software 

which manages access to the graphics hardware.  

Intel HD Graphics Driver is responsible for running your graphics, your display. Without it, 

your screen would be black and you would never be able to see anything. If you did uninstall 

it, it might use the standard VGA adapter driver, which would still take up some space but 

your resolution would be terrible. 
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 Antivirus 

Antivirus softwares are programs that help protect your computer against most viruses, 

worms, Trojan horses, and other unwanted invaders that can make your computer "sick." 

Viruses, worms, and the like often perform malicious acts, such as deleting files, accessing 

personal data, or using your computer to attack other 

If you're running Windows, macOS/OS X or Android, you absolutely do need the 

best antivirus software. ... There's no good reason not to have it: Many AV programs 

have little system-performance impact, and many good ones are free. 

Example of best antivirus: Bitdefender, McAfee, BullGuard, Norton Lifelook, Kaspersky, 

Avasta 

 

Learning Outcome 2.2: Trace and edit character and environment 

 Character design details 

 Attributes and proportions 

Apart from the story aspect of a character, the design aspect plays a very important role. 

The shapes & volumes used while designing the character and the poses & expressions of a 

character; all this information helps us to create the right attitude for the character design. 

 

An attribute of a character refers to its characteristics. One has to keep in mind how the 

character is going to perform in the film and its behavior in the story. Drawing a character, 

keeping the above things in mind; will add more life to the character. 

 

Some of the basic things that one needs to know about the characters are: 

 Age 

 Moods and 

 Behaviorspatterns (whether the character is happy, excited, sad or evil). 

Once we know about this information we can make the audience connect with our 

character.Few reminders: 
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 While drawing a character one of the most important aspects is its proportions. 

What is the proportion of your character in comparison to the world that he belongs 

to? 

 The silhouette of a character and the shapes used to draw the character defines the 

volumes of    our character. 

  Also the volumetric study of a character is very important from the animation point 

of view as    well as it becomes a reference for the animator to keep the consistency 

in his drawings while designing the character several times. 

 

 Expressions 

A character’s face is an index of his personality. Facial expressions are the key to express 

emotions apart from body language. Technically, the face has many numbers of muscles 

and combinations of these muscles make an expression. 

When a character is happy, sad, cheerful, angry, scared or shocked the face literally morphs 

and creates those emotions using the combination of eyes and mouth shapes. In our face 

the three major elements that helps express an emotion effectively are eyes, eyebrows and 

mouth. 

• While trying to draw a characters face we can accentuate the emotions by exaggerating 

the proportions and going to the extremes of one’s face. 

• Having a reference or a mirror by your side is always helpful for drawing the expressions 

correctly. 
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Image for Expression 

 

 Model sheet 

A ‘Model Sheet’ is a reference sheet of a character in which we draw a front profile, side 

profile, 3/4th view and a back view of the character. This chart helps us know the 

proportions, gestures, appearances and the way our character looks from various angles. 

• It’s a character designer’s job to make a ‘cleaned up’ model sheet before it is given to the 

   animator. 

• This character chart will help the animator draw his character several times keeping the 

size,    form and the volume of the character consistent throughout the film. 

 

 

Images for Model sheet 

 Poses and gestures 

To draw a character and make it act is the most 

important and exciting part of the animation 

process. Before animating a character, one 

should know about the character’s behaviour 

which generally comprises of:  

• How the character responds to various 

situations,  

• How he poses himself and 

• what are the gestures he makes to convey an action. 
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While drawing the poses and gestures keeping the following things in mind will help:  

1. The line of action that follows his body. 

2. The arcs while he is doing an action. 

3. The balance and weight shift that happens while he pauses or does a small change in 

his gestures. 

It’s advisable always to act out the performance as it becomes a good reference for the 

posing. 

• Knowing every detail of your character will help you spot small nuances while animating 

the character. 

• A small change in gesture will speak a lot about the character’s actions. 

• Keeping an action pose in mind while drawing will help in knowing the body dynamics and 

then it becomes easier for the animator to know how the body of the characters behaves. 

 

 

 

 Colors 

Colors add life to a visual and deciding upon a color scheme for a character will indirectly 

decide the mood of the character and the scene. 

So when we start with coloring a character we need to keep the following things in mind: 

 

 Our character’s skin tone:  

Which will be derived from the place he belongs to. 
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 Color for clothes and accessories:  

Situation dependent and also use reference for choosing the colors. 

 Swatches:  

Once the colors for each element of the character are finalized a color swatch is made 

which    is a palette of colors of the character. 

  Time of the Day (shadow):  

The color palette will vary according to the time of the day or lighting of the scene. 

Hence,   separate color swatches should be made according to the time and space of the 

shot. Once this is done a color reference model is made which is basically a character 

completely filled with flat color tones. Also, there are three aspects in tonal values:  

• Midtones,  

• Shadows and 

• Highlights. 

So while deciding the color reference model, the colors for the highlights (lighter areas) 

and shadows (darker areas) are defined. Usually for cartoon animation two shades 

(Midtones and Highlights) are easier to work on while coloring. 

The more detailed the coloring is, the tedious the process of ink and paint becomes. 

Once the color model is ready it is sent to the ink and paint department for coloring the 

cleaned up shots. 

 

 

 Creation of Project 

 Naming of project files 

Before you start creating your project you need give your Project a name which will identify 

it from others 

 Selection of location 

After naming the project it is also important to choose the location to which you will save 

your animation project 



Page 29 of 74 
 

 Set artboard  

The artboard is the “canvas” that you create your artwork on in Adobe Illustrator. You can 

make it any size you like, and can create multiple artboards. Illustrator is a very fluid 

program, meaning that you can move art on or off artboards. In the Tools panel is a 

dedicated tool called the Artboard tool (Shift-O). Activating the Artboard 

tool puts Illustrator into artboard editing mode. Once activated, the artboard has a 

bounding box, grab handles, crop marks, and a nameplate appearing with it in the 

workspace. 

 

 Creation of shape Vectors 

 The rectangle tool 

How to choose a fill and stroke color and how to change the appearance of the stroke, let's 

learn how to actually draw vector shapes! We'll start with the first tool in the list, 

the Rectangle Tool. I'll select it from the Tools panel: 

The Rectangle Tool lets us draw simple four-sided rectangular shapes. To draw one, start by 

clicking in the document to set a starting point for the shape. Then, keep your mouse button 

held down and drag 

diagonally to draw the rest 

of the shape. As you drag, 

you'll see only a thin 

outline (known as 

the path) of what the 

shape will look like: 

 

 The Rounded Rectangle tool 
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The Rounded Rectangle Tool is very similar to the standard Rectangle Tool except that it lets 

us draw rectangles with rounded corners. We control the roundness of the corners using 

the Radius option in the Options Bar. The higher the value, the more rounded the corners 

will appear 

 

 

Once you've set your radius, drawing a rounded rectangle is exactly the same as drawing a 

normal rectangle. Start by clicking inside the document to set a starting point for the shape, 

then keep your mouse button held down and drag diagonally to draw the rest of it. Just as 

we saw with the Rectangle Tool, Photoshop will display only the path outline of the shape as 

you're dragging 

 

 

 The Ellipse Tool 

Photoshop's Ellipse Tool lets us draw elliptical or circular shapes. I'll select it from the Tools 

panel: 
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Just as with the other shape tools we've looked at, to draw an elliptical shape, click inside 

the document to set a starting point, then keep your mouse button held down and drag 

diagonally to draw the rest of it: 

 

 

 

 

 

 The Polygon Tool 

The Polygon Tool is where things start to get interesting. I'll select it from the Tools panel: 

While Photoshop's Rectangle Tool is limited to drawing four-sided polygons, the Polygon 

Tool lets us draw polygonal shapes with as many sides as we like! It even lets us draw stars, 

as we'll see in a moment 
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 Free transform tool 

Transforming scales, rotates, skews, stretches, or warps an image. You can apply 

transformations to a selection, an entire layer, multiple layers, or a layer mask. You can also 

apply transformations to a path, a vector shape, a vector mask, a selection border, or an 

alpha channel. Transforming affects image quality when you manipulate the pixels. To apply 

non-destructive transformations to raster images, use Smart Objects. (See Work with Smart 

Objects.) Transforming a vector shape or path is always non-destructive because you’re only 

changing the mathematical calculations producing the object. 

 

 

 

 

 Deleting Anchor points 

To delete an anchor point: 

 Select the Pen tool or the Delete Anchor Point tool  and click over the anchor point.  

Note: The Pen tool changes to Delete Anchor Point tool as you position it over an anchor 

point. 

 Select the point with the Direct Selection tool and click Remove Selected Anchor 

Points  in the Control panel. 

 

https://helpx.adobe.com/photoshop/using/create-smart-objects.html
https://helpx.adobe.com/photoshop/using/create-smart-objects.html
https://helpx.adobe.com/photoshop/using/create-smart-objects.html
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 Tracing of imported sketches with tool  

 

 Pen tool 

1. Select the Pen tool ( ). 

2. Position the Pen tool where you want the straight segment to begin, and click to 

define the first anchor point (do not drag) 

Notes: 

▪ The first segment you draw will not be visible until you click a second anchor point.  

▪ If direction lines appear, you’ve accidentally dragged the Pen tool; 

choose Edit > Undo, and click again. 

3. Click again where you want the segment to end (Shift-click to constrain the angle of 

the segment to a multiple of 45°). 

4. Continue clicking to set anchor points for additional straight segments.The last 

anchor point you add always appears as a solid square, indicating that it is selected. 

Previously defined anchor points become hollow, and deselected, as you add more 

anchor points. 

5. Complete the path by doing one of the following: 

▪ To close the path, position the Pen tool over the first (hollow) anchor point. A 

small circle appears next to the Pen tool pointer  when it is positioned 

correctly. Click or drag to close the path. 

▪ To leave the path open, Ctrl-click (Windows) or Command-click (macOS) 

anywhere away from all objects. 
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▪ To leave the path open, you can also select a different tool, or 

choose Select > Deselect. You can also simply press Enter or Return to leave 

the path open. 

 

 

 

 

 Pencil tool 

The Pencil tool lets you draw open and closed paths as if you were drawing with a pencil 

on paper. It is most useful for fast sketching or creating a hand-drawn look. Once you 

draw a path, you can immediately change it if needed. 

 

Anchor points are set down as you draw with the Pencil tool; you do not determine 

where they are positioned. However, you can adjust them once the path is complete. 

The number of anchor points set down is determined by the length and complexity of 

the path and by tolerance settings in the Pencil Tool Preferences dialog box. These 

settings control how sensitive the Pencil tool is to the movement of your mouse or 

graphics-tablet stylus. 
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 Brush tool 

1. Click and hold the 

Shaper tool ( ). Select 

the Pencil tool  

 

 

 

 

 

 

 

 

 

2. Position the tool where you want the path to begin, and drag to draw a path. The 

Pencil tool ( ) displays a small x to indicate drawing a freeform path. 

As you drag, a dotted line follows the pointer. Anchor points appear at both ends of 

the path and at various points along it. The path takes on the current stroke and fill 

attributes, and remains selected by default. 

 

 Click and drag technique 

First, press V to get the Move tool, then in the Options Bar turn on the checkbox for Auto 

Select Layer. Now, click-and-drag within your image and any layer that falls within your 

selection becomes active. Now you can move them as one unit. 

 Click and convert technique 

Move the Direct Selection tool over the anchor point until the pointer displays a hollow 

square for unselected and filled square for selected paths in a magnified state, and then 

click the anchor point. Shift-click additional anchor points to select them. Select the Lasso 

tool and drag around the anchor points. This will convert tool line 
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Learning Outcome 2.3: Export the character and the environment 

 

 Output file format determination 

 Raster Image format 

When you talk about pixels, you really are talking about raster images. Raster images can be 

low to high quality images containing pixels. What we save as a bitmap are all photographic 

images and, for instance, files displayed on web pages (with the exception of Flash 

animations, which may combine both raster and vector elements). 

 

 JPG/JPEG (acronym for Joint Photographic Experts Group which created the format) 

JPG/JPEG is the most popular raster graphic file format using effective compression 

algorithms which enable you to achieve a small file size without quality loss (or with 

acceptable quality loss). When you save a JPG file you can select a compression level by 

adjusting the file quality to file size ratio. 

JPG is most commonly used on web pages (along with GIF and PNG). 

 GIF (Graphics Interchange Format)  

A very well-known format is also GIF. As opposed to JPG, it is rather not used to save photos 

but graphics/illustrations. The reason for that is the limited number of colours, i.e. 256, 

whereas JPG supports a full 24-bit palette (16.7 m colours). 

One of the colours in the palette of a GIF file can be transparent, which is why it is possible 

to see the background in selected places of the rectangular graphic area. 

 PNG (Portable Network Graphics)  

The third of the “Internet” bitmap image formats, which is still relatively not much popular. 

From historical perspective, it is a successor of the GIF format. Most liked by the creators of 

web pages because of its intelligent transparency handling: you can round off the edges 

meeting the background and use such effects as shadows. 
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 TIF/TIFF (Tagged Image File Format)  

A format used basically only for printing. As opposed to JPG, only lossless compression is 

used in TIF files, which means their sizes are usually much larger. Instead, they contain much 

more additional information (paths, alpha channels, comments) that is used by printing 

devices. 

 BMP (BitMaP)  

The basic raster format, which is now rarely used. In practice, it is a pure bitmap, i.e. a list of 

pixels with their colours being defined and with minimum compression. BMP files are 

unnecessarily large and additionally, they are not displayed by all Internet browsers. 

 Vector Image format 

Vector graphics contains shapes composed of curves (vectors) and fillings. That is why 

projects delivered in a vector form can be freely scaled (also up) with no harm to their 

quality. Vector formats are the best for logos: such a file may be used both on a business 

card and on a billboard. 

 EPS (Encapsulated PostScript)  

A universal format supported by most vector graphics programs. Visual identification 

elements, such as logos, are best to be saved in this format. 

 AI and CDR 

Frequent vector files created by two most popular vector graphics programs, Adobe 

Illustrator and Corel Draw respectively. The most recent versions of the programs can 

import files of their “competitor”. 

 SVG (Scalable Vector Graphics)  

A vector file format created with the Internet in mind and supported by Internet 

browsers (some require that an add-on be installed). Despite that it is still not much 

popular. 
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A specific format is PDF (Portable Document Format); on the one hand, it is rather a 

document than graphic format but on the other hand, it may include both vector and 

raster elements and additionally, it is very versatile. That is why it is often used for 

printing and especially digital printing. 

Learning Unit 3: Create 2d Digital Animation 

Learning Outcome 3.1: Describe animation software 

 Types of 2D animation software 

 Facial animation software 

Facial animation software is a technology that scans the face and detects facial 

expressions to recreate them as a computer graphic. Facial animation software uses the 

device’s camera to scan the shape of a person’s face, eyes, and mouth, and projects 

expressions and emotions onto a digital cartoon character. The following are Examples 

 CrazyTalk 

CrazyTalk is an easy-to-use facial animation software with which you can make great talking 

animations – with 3D characters or 2D characters. The program allows you to upload a pre-

recorded audio or even text and then, the character lip-syncs the words accordingly. You 

can play with the characters’ look and apply mouth, head, and eye movement. 

 Toom Boom animation 

Toon Boom is an innovative piece of software that allows you to create animation and 

storyboarding. Toon Boom's software lets you design and create professional, industry-

grade graphics. The Canadian-based company has been used by many well-known 

animation producers such as Disney, Nickelodeon, and Warner Bros. 

 Video animation software 

 Adobe After Effect 
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Adobe After Effects is a digital visual effects, motion graphics, and compositing application 

developed by Adobe Systems and used in the post-production process of film making, video 

games and television production. Among other things, After Effects can be used for keying, 

tracking, compositing, and animation 

 

 OpenToonz 

Software for the production of 2D animation. Based on the software "Toonz", developed by 

Digital Video S.p.A. in Italy, OpenToonz has been customized by Studio Ghibli, and used for 

the creation of its works for many years. OpenToonz can be used free of charge for both 

commercial and non-commercial projects 

 Tvpaint Animation 

TVPaint Animation is a 2D software based on bitmap technology. ... Feel free to 

mix animation on paper and digital animation, do rotoscopy, use different software or 

simply make your project with TVPaint Animation entirely. 

 Web animation Software 

 Adobe Animate 

Adobe Animate (formerly Adobe Flash Professional, Macromedia Flash, and FutureSplash 

Animator) is a multimedia authoring and computer animation program developed 

by Adobe Systems. ... The program also offers support for raster graphics, rich text, audio 

and video embedding, and ActionScript scripting. 

 Adobe Fireworks 

Adobe Fireworks (formerly Macromedia Fireworks) is a discontinued bitmap and vector 

graphics editor, which Adobe acquired in 2005. Fireworks is made for web designers for 

rapidly creating website prototypes and application interfaces. 

 Hand drawn animation software 

 Pencil 2D 
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Pencil2D is an animation/drawing software for macOS, Windows, and Linux. It lets you 

create traditional hand-drawn animation (cartoon) using both bitmap and vector 

graphics. Pencil2D is free and open source. 

 Animation paper 

When animating, you often find that you are working with four or more layers of paper. A 

level of translucency is necessary to see all the drawings. Professional animation paper is 

made with this in mind. It also comes in different sizes. Most professional animation 

paper comes with 3 punched holes. 

 Vector Based 2D animation  

 Adobe Edge Animate 

Adobe Edge Animate CC is a brand new software tool that allows everyone from beginners 

to expert web designers to create animated web content. 

 Adobe Character Animator 

Adobe Character Animator is an Emmy-award-winning desktop application software 

product that combines live motion-capture with a multi-track recording system to control 

layered 2D puppets drawn in Photoshop or Illustrator. 

 Moho anime studio 

Moho (previously marketed as Anime Studio) is a proprietary vector-based 

2D animation application distributed by Smith Micro Software. Moho is available for 

Windows and macOS in English, German, Japanese, and Spanish. (A Linux Version is no 

longer available). 

 Synfig studio 

Synfig is a powerful, industrial-strength vector-based 2D animation software package, 

designed from the ground-up for producing feature-film quality animation with fewer 

people and resources. Open-source 2D vector graphics solution that provides vector 

tweening, various layers and filters to create any animation and artwork. 
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 Compatibilities of animation software with hardware 

 System requirements 

 Minimum Requirements 

In a lot of ways, an animation battle station is a lot like a gaming computer. You need fast 

graphics rendering and a lot of processing power. To that end, the things you'll want to 

focus on: 

RAM - You'll want at least 8 GBs. I'm running 4 right now and it is slow. Optimally, you'll run 

16 GBs or more. More is always better when it comes to RAM. You can never have too much 

RAM.content 

Processor - i5/i7 or AMD FX. Animation is one of the few areas where the i7 really gets to 

shine. The multithreading helps divide rendering tasks into smaller, more manageable 

chunks. They're still much more expensive, though, so gaming-level processors should do 

you fine. 

Graphics card - Does a lot of the animation heavy lifting so your processor doesn't have to. 

If you're working with Maya for example;" Most other programs shouldn't run into major 

issues. I'd suggest something in the GTX-1060+ range. The bigger it is the better graphics 

you get. 

 
 
 Installation of animation software 

 
 Installation of Adobe animate 

Adobe Animate CC Features 
 
▪ Adobe Animate CC Simple & Fast Download! 
▪ Works with All Windows (64/32 bit) versions! 
▪ Adobe Animate CC Latest Version! 
▪ Fully compatible with Windows 10 

 

Adobe Animate CC App Preview 
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How to Install Adobe Animate CC on Windows 10 

There are so many ways that we can do to have this app running into our Windows OS. So, 

please choose one of the easy method on below 

Method 1: Installing App Manually 

Please note: you should download and install programs only from trusted publishers and 

retail websites. 

1. First, open your favourite Web browser, you can use Brave Browser or any other 

Browser that you have 

2. Download the Adobe Animate CC installation file from the trusted link on above of this 

page 

3. Or you can download via this link: Download Adobe Animate CC 

4. Select Save or Save as to download the program. Most antivirus programs like Windows 

Defender will scan the program for viruses during download. 

● If you select Save, the program file is saved in your Downloads folder. 

● Or, if you select Save as, you can choose where to save it, like your desktop. 

5. After the downloading Adobe Animate CC completed, click the .exe file twice to running 

the Installation process 

6. Then follow the windows installation instruction that appear until finished 

7. Now, the Adobe Animate CC icon will appear on your Desktop 

8. Click on the icon to running the Application into your windows 10 pc/laptop. 
 

 Installation of Adobe after effect 

https://windows-1.com/get/adobe-animate-cc/url/aHR0cHM6Ly9jcmVhdGl2ZS5hZG9iZS5jb20vcHJvZHVjdHMvZG93bmxvYWQvYW5pbWF0ZQ==
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Installing the software 

Before installing Adobe After Effects software, review the complete system requirements. 

In addition to the full version of Adobe After Effects, you can also install additional copies on 

additional computers to use as After Effects render engines to assist with network 

rendering.  

Installing a render-only instance of Adobe After Effects CC 

Before you start: 

If you have installed Creative Cloud applications on two computers, sign out of one of them 

by opening any of the applications and choosing Sign Out from the Help menu. 

You can sign back into Creative Cloud on this computer after the render-only instances of 

After Effects are installed. 

To install a render-only instance of After Effects CC, do the following: 

1. Go to the product page to download and install After Effects CC. 

2. When the installation is complete, start After Effects. 

3. Choose Sign Out from the Help menu. 

4. Quit After Effects. 

5. Create and place the ae_render_only_node.txt file as described in this blog post. 

Limitations of the trial version 

The trial version of After Effects includes all of the codecs that are included with the full 

version of After Effects. This means that you can import and export to all of the supported 

file formats using the trial version.  

The trial version of After Effects also includes the Key light plug-in, mocha-AE, mocha shape, 

Cycore (CC) effects, and Color Finesse.  

If your installation of After Effects is missing some third-party components, contact your 

system administrator to ensure that all licensed components have been installed correctly. 

Activate the software 

A single-user retail license activation supports two computers. For example, you can install 

the software on a desktop computer at work and on a laptop computer at home. 

For more information on product licensing and activation, see the Read Me file or go to 

the Adobe website 

 

https://helpx.adobe.com/after-effects/system-requirements.html
http://blogs.adobe.com/aftereffects/2012/06/codecs-and-the-render-engine-in-after-effects-cs6.html
http://www.adobe.com/go/activation
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Learning Outcome 3.2: Create 2D digital animation project 

 Adobe animate new project creation 

 Setup 

Workspace 

You create and manipulate your documents and files using various elements, such as panels, 

bars, and windows. Any arrangement of these elements is called a workspace. The 

workspaces of the different applications in Adobe Creative Suite 5 share the same 

appearance so that you can move between the applications easily. You can also adapt each 

application to the way you work by selecting from several preset workspaces or by creating 

one of your own. 

1. The default setting shows panels appearing on a "dock" at the right of the Animate 

window. The panels are arranged into three columns. At the far right is the Tool Panel. 

Next to it is an expanded column of panels. To the left is a column showing only panel 

icons 

2. Animate has a lot of panels, so like many Adobe design programs, there are built-in 

"workspaces" that activate different configurations of panels based on task. The 

Workspace menu can be accessed in the menu bar above the panel dock. For this 

tutorial, I'll choose Designer. 
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3. The Designer Workspace arranges panels on both the left and right of the stage 

 

4. Custom workspaces can be created by first rearranging the panels to the desired 

configuration. In this example I want just the Tool Panel on the left, with all other panels 

arranged in two columns to the right. First, I'll click and hold on the panel name, 

Properties, and drag it over to the right of the CC Libraries Panel. A blue highlight 

appears, indicating that the Properties Panel is being grouped with the Library and CC 

Libraries Panels. 

 

5. I also want to close a panel, so first I'll detach it by clicking and holding on the panel 
name, CC Libraries, and dragging it away from the panel dock so it's free-floating. Now I 
can click the Close button. 
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In Animate, you can work with a variety of file types, each of which has a separate purpose: 

 FLA files, the primary files you work with in Animate, contain the basic media, timeline, 

and script information for a Animate document. Media objects are the graphic, text, 

sound, and video objects that comprise the content of your Animate document. 

The Timeline is where you tell Animate when specific media objects should appear on 

the Stage. You can add ActionScript code to Animate documents to more finely control 

their behaviour and to make them respond to user interactions. 

 Uncompressed XFL files are similar to FLA files. An XFL file, and the other associated files 

inside the same folder, are simply the uncompressed equivalent of a FLA file. This format 

makes it easier for groups of users to work on different elements of an Animate project 

at the same time. For more information, see working with uncompressed XFL files. 

 SWF files, the compiled versions of FLA files, are the files you display in a web page. 

When you publish your FLA file, animate creates a SWF file. 

 The Animate SWF file format is an open standard that other applications support. For 

more information about Animate file formats, see www.adobe.com/go/flashplayer. 

 AS files are ActionScript files—you can use these to keep some or all of your ActionScript 

code outside of your FLA files, which is helpful for code organization and for projects 

that have multiple people working on different parts of the Animate content. 

 SWC files contain the reusable Animate components. Each SWC file contains a compiled 

movie clip, ActionScript code, and any other assets that the component requires. Note: 

SWC files cannot be imported into Animate. 

 ASC files are files used to store ActionScript that will be executed on a computer running 

Adobe Media Server. These files provide the ability to implement server-side logic that 

https://helpx.adobe.com/animate/using/documents.html#working_with_uncompressed_xfl_files
http://www.adobe.com/go/flashplayer
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works in conjunction with ActionScript in a SWF file. Note: ASC files are not supported 

with Animate. 

 JSFL files are JavaScript files that you can use to add new functionality to the Animate 

authoring tool. 

 APR files lets you bundle the canvas publish template along with it’s publish profile 

settings. Going forward, any new asset linked to a publish profile is bundled and shared 

as well. For more information, see Publish settings. 

 

Size setting for adobe animate 

To have your Stage fill the entire browser window, set the Stage width and height to 100%, 

as shown in this figure. To have your Stage fill half the browser window, set the Stage to 

50%; and so on, depending on how much of the browser window you want 

your animation to occupy. 

 

 Keyboard shortcut for adobe animate 

https://helpx.adobe.com/animate/using/publish-settings.html
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Edit and modify 

Action Mac Windows 

Group 
 +   +  

Ungroup 
 + +   + +  

Break Apart 
 +   +   

Paste in Place 
 +  +   +  +  

Duplicate 
 +   +  

Select All 
 +   +  

Deselect All 
 +  +   +  +  

Import Library 
 +  +   +  +  

Align Window 
 +   +  

Save As 
 +  +   +  +  

Scale and Rotate 
 +  +   + +  

Remove Transform 
 +  +   +  +  

Move Ahead 
 +   +  
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Move Behind 
 +   +  

Bring to Front 
 +  +   +  +  

Send to Back 
 +  +   +  +  

Show or hide 
Transform Panel  +   +  

Narrower 
letterspacing 
(kerning) 

 + +   + +  

Wider letterspacing 
(kerning)  + +   + +  

File 

Action Mac Windows 

Import 
Image/Sound/etc...  +   +  

Export Movie 
 +  +  

+  

 +  +

  +   

Open as Library 
 +  +   +  +  

 

Windows  

Action Mac Windows 

Show/Hide Library 
 +   +  

Comment selection 
 +   +  



Page 51 of 74 
 

Toggle between 
Edit Movie and Edit 
Symbol Mode 

 +   +  

Show/Hide 
Timeline  +     +   +  +  

 

 Setting of the scene 

 New layer creation 

1. Click the new layer button at the bottom of the timeline. 

2. Select Insert > Timeline > Layer. 

3. Right-click (Windows) or control+click (Macintosh) a layer name in the timeline and 

select Insert Layer from the context menu. 

 

 Background creation 

Working with Layers for Background Content 

The next step is to introduce layers to the animation. As I mentioned earlier, you can use 

layers to animate content, but right now we're going to create a layer to hold background 

content in the animation. That is, we'll create content that will show throughout the 

animation–without changing. 

1. In the Layers panel, double-click the first layer (Layer 1) and change its name to curtain. 

2. Create a new layer named background beneath the curtain layer. 

3. Add content that won't move and will be present in all frames of the animation.  

 

 Character and environment files importation from illustration design software 
 
 Selection of supported file format 

 
 Vector graphics  

A vector graphic consists of shapes, curves, lines, and text which together make a picture. 

Examples of vector graphic formats are PICT, EPS, and WMF as well as PostScript and 

TrueType fonts.  
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 Bitmaps  
A bit map (often spelled "bitmap") defines a display space and the color for each pixel or 

"bit" in the display space. A Graphics Interchange Format and a JPEG are examples 

of graphic image file types that contain bit maps. 

 Sequences  
An Animation Sequence is a single animation asset that can be played on a Skeletal Mesh. 

... By playing these keyframes back in sequence, with blending between them, the bones of 

a Skeletal Mesh can be smoothly animated. Each Animation Sequence asset targets a 

specific Skeleton and can only be played on that Skeleton 

 Images 
The Animated Portable Network Graphics (APNG) file format is an extension to the Portable 

Network Graphics (PNG) specification. It allows for animated PNG files that work similarly 

to animated GIF files, while supporting 24-bit images and 8-bit transparency not available 

for GIFs 

 
 Import Options 

 
 Import to stage  

Animate lets you import artwork in various file formats either directly to the Stage, or to the 
library. 

Import a file into Animate 

1. Do one of the following: 
 
 To import a file directly into the current Animate document, select File > Import > 

Import to Stage. 

 To import a file into the library for the current Animate document, select File > 

Import > Import to Library. (To use a library item in a document, drag it onto the 

Stage.) 

 

2. Select a file format from the Files of Type (Windows) or Show (Macintosh) pop-up menu. 

3. Navigate to the desired file and select it. If an imported file has multiple layers, Animate 

might create new layers (depending on the import file type). Any new layers appear in 

the Timeline. 

4. Click Open. 

5. If the name of the file you are importing ends with a number and additional sequentially 

numbered files are in the same folder, do one of the following.  

 
Note: (Windows 8 only) if a PSD file containing text is imported with the Vector Outline 

option selected, you cannot edit the anchor points for the vector object. This is observed 

with PSD files that were created using fonts unavailable in Windows 8. 
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 To import all the sequential files, click Yes. 

 To import only the specified file, click No. 

The following are examples of filenames that can be used as a sequence: 

Frame001.gif, Frame002.gif, Frame003.gif 

Bird 1, Bird 2, Bird 3 

Walk-001.ai, Walk-002.ai, Walk-003.ai 

 
 

 Import to library  
 

The library in an Animate document stores media assets that you create in 

the Animate authoring environment or import to use in the document. You can create 

vector artwork or text directly in Animate; import vector artwork, bitmaps, video, and 

sound; and create symbols 

 
 Open external library  

 
From the current document,  
Select File > Import > Open External Library. Navigate to the Animate file whose library you 
want to open and click Open.  
 
The selected file's library opens in the current document, with the filename at the top of 
the Library panel 
 

 Import video 
 
a) Select File > Import > Import Video to import the video clip into the current Animate 

document. 

b) Select the video clip to import. You can select either a video clip located on your local 

computer, or enter the URL of a video already uploaded to a web server or Adobe Media 

Server 

c) Select a skin for your video clip.  

d) The Video Import Wizard creates an FLVPlayback video component on the Stage that 

you can use to test video playback locally. When you finish creating your Animate document 

and want to deploy the SWF file and video clip, upload the following assets to the web 

server or Adobe Media Server hosting your video: 

● If you are using a local copy of the video clip, upload the video clip (which is located in 

the same folder as the source video clip you selected with a .flv extension). 
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 Animation Techniques 
 
 Working with motion Tweens 

 
Motion Tween. A motion tween is a feature available in Adobe Flash (formerly 

Macromedia Flash) that allows you to easily animate the motion of an object. ... Then 

select the number of frames in the timeline you would to use for the duration of 

the animation. 

Animate allows you to work with Motion Tweens as XML files. Natively, animate allows 

you to apply the following commands on any Motion Tween: 

• Copy Motion as XML 

• Export Motion as XML 

• Import Motion as XML 

 
 Copy Motion as XML 

 
Allows you to copy Motion properties applied to any object on the Stage at a said frame. 

1. Create a Motion Tween. 

2. Select any keyframe on the Timeline. 

3. Go to Commands > Copy Motion as XML. 

The Motion property is copied to the clipboard as XML data, you can then use any text 

editor to work on the XML file. 

 
 Export Motion as XML 

 
Allows you to export Motion properties applied to any object on the stage to an XML file 
that can be saved. 
1. Create a Motion Tween. 
2. Go to Commands > Export Motion as XML. 
3. Browse to a suitable location where you want to save the file. 
4. Provide a name for the XML file, and click Save. 
The Motion tween is exported as an XML file at the specified location. 
 

 Import Motion as XML 
 
Allows you to import an existing XML file that has Motion properties defined. 
 

1. Select an Object any object on the Stage. 
2. Go to Commands > Import Motion as XML. 

3. Browse to the location, and select the XML file. Click Ok. 

4. On the Paste Motion Special dialog, select the properties that you want to apply 

on the selected object. 

5. Click Ok. 
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 Shape tweening 
 
In shape tweening, you draw a vector shape at one specific frame in the Timeline, and 

change that shape or draw another shape at another specific frame. Animate then 

interpolates the intermediate shapes for the frames in between, creating 

the animation of one shape morphing into another 

 

 Creating a shape tween 

The following steps show how to create a shape tween from frame 1 to frame 30 of the 

timeline. However, you can create tweens in any part of the timeline that you choose. 

 
1. In frame 1, draw a square with the Rectangle tool. 

2. Select frame 30 of the same layer and add a blank keyframe by choosing Insert > 

Timeline > Blank Keyframe or pressing F7. 

3. On the stage, draw a circle with the oval tool in frame 30. 

Now, you have a keyframe in frame 1 with a square and a keyframe in frame 30 with 

a circle. 

4. In the Timeline, select one of the frames in between the two keyframes in the layer 

containing the two shapes. 

5. Choose Insert > Shape Tween. 

Animate interpolates the shapes in all the frames between the two keyframes. 

6. To preview the tween, scrub the play head across the frames in the Timeline, or 

press the Enter key. 

7. To tween motion in addition to shape, move the shape in frame 30 to different 

location from frame 1. 

Preview the animation by pressing the Enter key. 

8. To tween the color of the shape, make the shape in frame 1 a different color from 

the shape in frame 30. 

9. To add easing to the tween, select one of the frames and enter a value in the Ease 

field of the Property inspector. 

To ease the beginning of the tween, enter a negative value. To ease the end of the 
tween, enter a positive value. 

 
 Create ease presets or custom eases 

 
Ease presets are pre-configured eases that can be applied to an object on the stage. 
 

A set of commonly used ease presets are available for shape tween. You can select the 

preset from a list of ease presets and apply it to the selected property. You can also 

apply a custom ease to a shape tween. 
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1. Click the layer that contains a shape tween in the timeline of Animate. 
 

2. To open the tweening properties, click the Tweening category in the property 

panel. 

 

 

3. Select the ease preset of your choice from the ease type pop-up dialog. Double-

click the preset type to apply.  

If you choose to apply classic ease, you can also increase or decrease the 

intensity of ease by moving the slider.  

 

 

4. Click the edit icon next to Ease to apply a custom ease.  
 
The Custom Ease dialog displays a graph representing the degree of motion over 

time. The horizontal axis represents frames, and the vertical axis represents 

percentage of change. The first keyframe is represented as 0%, and the last 

keyframe is represented as 100%. 

The slope of the graph’s curve represents the rate of change of the object. When 

the curve is horizontal (no slope), the velocity is zero; when the curve is vertical, 

an instantaneous rate of change occurs. 
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You can save a custom ease and reuse it by choosing your customized ease from 
the Custom list. Click the Save and Apply button in edit mode after making the 
changes. In the following screenshot, you can find the customized ease preset 
with the name MyEase1. 
 
 

 
 
You can use the preset eases across multiple spans in the timeline by selecting 
the corresponding spans and applying the ease. 
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Apply easing preset for multiple span 
 

 Controlling shape changes with shapes hint 
 

1. Select the first keyframe in a shape-tweened sequence. 

2. Select Modify > Shape > Add Shape Hint. The beginning shape hint appears as a red 

circle with the letter a somewhere on the shape. 

3.  Move the shape hint to a point to mark. 

4. Select the last keyframe in the tweening sequence. The ending shape hint appears as a 

green circle with the letter a somewhere on the shape. 

5. Move the shape hint to the point in the ending shape that corresponds to the first point 

you marked. 

6. To view how the shape hints, change the shape tweening, play the animation again. To 

fine-tune the tweening, move the shape hints. 

7. To add more shape hints, repeat this process. New hints appear with the letters that 

follow (b, c, and so on). 

 
View all shape hints 
 
-Select View > Show Shape Hints. The layer and keyframe that contain shape hints must 
be active for Show Shape Hints to be available. 

 
Remove a shape hint 
 
-Drag it off the stage. 

 
Remove all shape hints 
 
-Select Modify > Shape > Remove All Hints. 
 

 Adding shape tween to strokes with variable width 
 
Animate allows you to add shape-tween to strokes with variable width. Earlier, animate 

only supported creating shape tweens for solid uniform strokes and shapes. This limited 

designer from creating shape tweens for non-uniform strokes, such as strokes enhanced 

using the variable width tool. Tweening strokes with variable width greatly expands the 

design possibilities within Animate. 
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Adding shape tweens to fancy strokes is not different from tweening a shape or a solid 

uniform stroke. The workflow needs that you define the start and final shape of the 

tween, and Animate creates the transitional frames of the tween. 

 

About variable width tool 

Variable width tool allows you to enhance uniform solid strokes to create beautiful and 

fancy strokes. For information on how to enhance strokes using the variable width tool, 

see Enhancing strokes and shapes using the Variable Width tool. 

 
Adding shape tween to variable width strokes 
 

1. In Animate CC, draw a line using the Line tool. 

 
2. Use the Variable Width tool to add width at the middle of the stroke (see 

below figure). For information on using variable width tool, see Enhancing 
strokes using Variable Width Tool. 

 
3. Select another frame on the timeline, for example frame 30, and create the 

final shape of the stroke for your tween. 

https://helpx.adobe.com/animate/using/draw-simple-lines-shapes.html#main-pars_header_0
https://helpx.adobe.com/animate/using/draw-simple-lines-shapes.html#main-pars_header_0
https://helpx.adobe.com/animate/using/draw-simple-lines-shapes.html#main-pars_header_0
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4. Right-click any frame between 1 to 30, and select Create Shape Tween. 

 
 Frames and keyframes 

 
Overview 

Adobe Animate documents divide lengths of time into frames similar to films. Frames are at 

the core of any animation, dictating each segment of time and movement. The total number 

of frames in your movie, and the speed at which they are played back, together determine 

your movie's overall length. A brief description of some of the concepts on frames is 

explained below for your reference. 

 

 Frames 

In the timeline, you work with the frames to organize and control the content of your 

document. You place frames in the timeline in the order you want the objects in the frames 

to appear in your finished content. 

 

 Keyframe 

A keyframe is a frame where a new symbol instance appears in the timeline. A keyframe can 

also be a frame that includes ActionScript® code to control some aspect of your document. 

You can also add a blank keyframe to the timeline as a placeholder for symbols you plan to 

add later or to explicitly leave the frame blank. 

 

Using keyframe you can set a position, add anchor points, actions, comments and so on. 
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 Span 
Span-based frame selection allows you to select a range of frames between two keyframes 
with a single click. 

 
 Static frame span 

In static frame span, same content is available for entire duration of span. You can use this 
type of span whenever you need to display graphics for fixed amount of time.  

 
 Tweened frame span 

In tweened frame span, the content changes within the span for each frame. You can use 
this type of span for animations. 

 

 
 
Add or insert frames in the timeline 
 
To insert a new frame, select Insert > Timeline > Frame (F5). 
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To create a keyframe, select Insert > Timeline > Keyframe (F6), or right-click (Windows) 

or Control-click (Macintosh) the frame where you want to place a keyframe, and select 

Insert Keyframe from the context menu. 

 

 
 
To create a blank keyframe, select Insert > Timeline > Blank Keyframe, or right-click 

(Windows) or Control-click (Macintosh) the frame where you want to place the 

keyframe, and select Insert Blank Keyframe from the context menu. 

 

 Image and sounds incorporation 
 
 Supported sound file formats 

 
Animate stores sounds in the library along with bitmaps and symbols. You need only one 

copy of a sound file to use that sound multiple ways in your document. 

If you want to share sounds among Animate documents, you can include the sounds in 

shared libraries. 

Animate includes a Sounds library containing many useful sounds that can be used for 

effects. To open the Sounds library, choose Window > Common Libraries > Sounds. To 

import a sound from the Sounds library to your Animate file, drag the sound from the 

Sounds library to the Library panel of your Animate file. You can also drag sounds from the 

Sounds library to other shared libraries. 

 
Supported sound file formats 
 
You can import the following sound file formats into Animate: 

▪ Adobe Sound (.asnd). This is the native sound format of Adobe® Soundbooth™. 
▪ Wave (.wav) 
▪ AIFF (.aif, .aifc) 
▪ mp3 

 
You can import these additional sound file formats: 

▪ Sound Designer® II (.sd2) 
▪ Sun AU (.au, .snd) 
▪ FLAC (.flac) 
▪ Ogg Vorbis (.ogg, .oga) 
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Sounds can use large amounts of disk space and RAM. However, mp3 sound data is 

compressed and smaller than WAV or AIFF sound data. Generally, when using WAV or AIFF 

files, it’s best to use 16-22 kHz mono sounds (stereo uses twice as much data as mono), but 

Animate can import either 8- or 16-bit sounds at sample rates of 11, 22, or 44 kHz. Sounds 

recorded in formats that are not multiples of 11 kHz (such as 8, 32, or 96 kHz) are resampled 

when imported into Animate. Animate can convert sounds to lower sample rates on export. 

 
 Import and synchronize sounds in Animate 

 
Adobe Animate offers several ways to use sound. Make sounds that play continuously, 

independent of the Timeline, or use the Timeline to synchronize animation to a sound track. 

Add sounds to buttons to make them more interactive, and make sounds fade in and out for 

a more polished sound track. 

 

There are two types of sounds in Animate: event sounds and stream sounds. An event 

sound must download completely before it begins playing, and it continues playing until 

explicitly stopped. Stream sounds begin playing as soon as enough data for the first few 

frames has been downloaded; stream sounds are synchronized to the Timeline for playing 

on a website. 

 
Importing sounds 

You place sound files into Animate by importing them into the library or directly importing 

them to stage. 

 

The File > Import > Import to Library menu option places the audio only in the library, and 

not on the timeline. 

 

When you import an audio file using File > Import > Import to Stage menu option or by 

dragging and dropping the audio file directly to the timeline, the audio will be placed on 

active frame of the active layer. If you drag and drop multiple audio files, only one audio file 

will be imported because one frame can contain only one audio.  

 

To import audio, use one of the following methods: 

 
▪ To import an audio file to library, select File > Import > Import To Library and select 

the audio file that you want to import. 

▪ To import an audio file to stage, select File > Import > Import To Stage and select the 

audio file that you want to import.  

▪ Drag-and-drop the audio file directly to the stage. 
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 Synchronize a sound with animation 
 
To synchronize a sound with animation, you start and stop the sound at keyframes. 

 
1. Add a sound to the Timeline in its own layer (see above for instructions). 

2. To synchronize this sound with an event in the scene, create a beginning keyframe 

for the sound that corresponds to the keyframe of the event in the scene that you 

want to trigger the sound. You can select any of the synchronization options 

described above (see Add a sound to the Timeline). 

3. Create a keyframe in the sound layer’s Timeline at the frame where you want the 

sound to end. A representation of the sound file appears in the Timeline. 

4. Select Window > Properties, and click the arrow in the upper-right corner to expand 

the Property inspector 

5. In the Property inspector, select the same sound from the Sound pop-up menu. 

6. Still in the Property inspector, select Stop from the Sync pop-up menu. 

When you play the SWF file, the sound stops playing when it reaches the ending 

keyframe. 

7. To play back the sound, drag the playhead in the Timeline. 

 
Editing sounds 
Editing a sound in Animate  

 
In Animate, you can define the starting point of a sound or control the volume of the sound 

as it plays. You can also change the point at which a sound starts and stops playing. This is 

useful for making sound files smaller by removing unused sections. 
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1. Add a sound to a frame, or select a frame that already contains a sound. 
2. Select Window > Properties. 

 

 
3. Click the Edit button on the right side of the Property inspector. 

4.  Do any of the following: 

 To change the start and end points of a sound, drag the Time In and Time Out 

controls in the Edit Envelope. 

 To change the sound envelope, drag the envelope handles to change levels at 

different points in the sound. Envelope lines show the volume of the sound as it 

plays. To create additional envelope handles (up to eight total), click the envelope 

lines. To remove an envelope handle, drag it out of the window. 

 To display more or less of the sound in the window, click the Zoom In or Out buttons. 

 To switch the time units between seconds and frames, click the Seconds and Frames 

buttons. 

 To hear the edited sound, click the Play button. 

 

 Application of effects and colors 
 
 Visual effects 
 
VFX or Visual Effects are a way of mixing real film shooting with false or animated images. 

For instance, a movie that shows the hero jumping off the ground and flying into the air, is 

created using VFX. Almost every single movie these days uses VFX. 

 
 Explosion 

Explosion Effects. Explosion effects generally include those of overpressure, thermal effects, 

energized projectiles (fragments, debris, and missiles), ground shock, and cratering. Ground 

shock and cratering will not be discussed further in this paper 

 

 Water splashing  
 

In fluid mechanics, a splash is a sudden disturbance to the otherwise quiescent free surface 

of a liquid (usually water). The disturbance is typically caused by a solid object suddenly 

hitting the surface, although splashes can occur in which moving liquid supplies the energy. 
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 Smoking 

Smoke VFX is a 4K Motion Graphic clip that comes with an alpha channel, ready to use in 
your hottest projects. Composite on to your footage to create stunning titles and 
transitional effect, or to give your viewers the impression of an actual fire 
 Sound effects 

 
 Timbre  

In music, timbre also known as tone color or tone quality (from psychoacoustics), is the 

perceived sound quality of a musical note, sound or tone. Timbre distinguishes different 

types of sound production, such as choir voices ... and electric piano, performers can change 

the timbre using effects units and graphic equalizers 

 

 Pitch  
The quality of a sound governed by the rate of vibrations producing it; the degree of 

highness or lowness of a tone. 

 Volume 
When talking about sound waves, the volume is the perception of loudness from the 

intensity of a sound wave. The higher the intensity of a sound, the louder it is perceived in 

our ears, and the higher volume it has. 

 Rhythm 
Rhythm is one of the most complex features of sound. Rhythm involves a beat or pulse a 

pace or tempo and a pattern of accents or stronger or weaker beats. 

 Tempo 
Tempo is how fast or slow a piece of music is performed, Tempo generally is measured as 

the number of beats per minute, where the beat is the basic measure of time in music. 

 Echo 
Echo.  In audio signal processing and acoustics, echo is a reflection of sound that arrives at 

the listener with a delay after the direct sound. The delay is directly proportional to the 

distance of the reflecting surface from the source and the listener. 

 

 Coloring 
 

 Color panel 
 

The Color panel lets you modify the color palette of a FLA and change the color of strokes 

and fills, including the following: 

 Import, export, delete, and otherwise modify the color palette for a FLA file by using 

the Swatches panel. 

 Select colors in hexadecimal mode. 

 Create multicolor gradients. 
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 Use gradients to produce a wide range of effects, such as giving an illusion of depth 

to a two-dimensional object. 

 
 

The Color panel contains the following controls: 
 
Stroke Color 
Changes the color of the stroke, or the border, of a graphic object. 
 
Fill Color 
Changes the color of the fill. The fill is the area of color that fills up the shape. 

 
 Swatches panel 

 
Swatches enable easy reuse and update of colors across documents. You can now create 

tagged swatches by selecting a color from your swatches. Once you create a tagged swatch 

and apply it to shapes and paths in your Animate content, changing the color in the tagged 

swatch will automatically update all the content that is using it. 

1. Click Window > Color.  

2. On the Swatches tab of the Colors panel, select the color that you want to convert to a 

tagged swatch and click the Convert to Tagged Swatch button on the bottom part of the 

panel 

 
 

3. On the Tagged Color Definition dialog box, specify the following: 
 
 A name for the new swatch. 
 Choice of solid color, linear gradient, or radial gradient. 
 A Color by specifying either the HSB values (Hue, Saturation and Brightness) or RGB 

(Red, Green, and Blue) 

 

4. When you open the Color panel after selecting the object that uses the tagged swatch, 

you will see options to edit the color properties. If you make changes to the color 



Page 68 of 74 
 

properties, the changes are automatically reflected on all the elements on stage that use 

the tagged swatch. 

5. You can double-click on a swatch or select a swatch and click Edit to open the Tagged 

Color Definition dialog box and make changes to the color in the swatch.   

6. To unlink a shape that uses a swatch from the swatch color, select the shape and then 

click the Unlink button. You can select a new color from the colors panel for the shape. 

 
 Color palettes 

 
Each Animate CC file contains its own color palette, stored in the Animate document. 

Animate CC displays a file's palette as swatches in the Fill Color and Stroke Color controls 

and in the Swatches panel. The default color palette is the web-safe palette of 216 colors. 

To add colors to the current color palette, use the Color panel. You can import and export 

both solid and gradient color palettes between Animate files, as well as between Animate 

CC and other applications. 

 

The default palette and the web-safe palette 

Save the current palette as the default palette, replace the current palette with the default 

palette defined for the file, or load the web-safe palette to replace the current palette. 

 

• To load or save the default palette, in the Swatches panel, select one of the following 

commands from the menu in the upper-right corner: 

Load Default Colors: 

Replaces the current palette with the default palette. 

 

Save As Default: 

Saves the current color palette as the default palette. The new default palette is used when 

you create new files. 

• To load the web-safe 216-color palette, in the Swatches panel, select Web 216 from the 

menu in the upper-right corner. 

In the Swatches panel, select Sort by Color from the menu in the upper-right corner. 

Organizing and reusing colors 

Swatches panel allows you to organize colors and color palettes in a hierarchical structure 
using Folders and Color Palettes. 

CREATING A FOLDER 

By default, all colors are arranged within the Default Swatches folder. You can arrange 
existing colors within folders using the Swatches panel. To create a new folder, do the 
following: 
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1. In Animate CC, select Window > Swatches 

2. On the Swatches panel, click the   button. 

3. Provide a meaningful name for the swatches folder. 

You can also create a folder by selecting a folder, color palette, or swatch and selecting the 
Duplicate as Folder option from the fly-out menu. 

CREATING A COLOR PALETTE (SWATCH GROUP) 

Color Palette is a group of swatches (colors) that signifies a color theme for your content. 
You can create color palettes within folders and add swatches to them. To create a Color 
Palette, do the following: 

1. In Animate CC, select Window > Swatches. 

2. On the Swatches panel, select any folder and click the   button to create an empty 
palette. 

3. You can drag an existing color or click the   button to add swatches to the color palette. 

You can also create a color palette by selecting a folder, color palette, or swatch and 
selecting the Duplicate as Palette option from the fly-out menu. 

CREATING OR ADDING COLORS TO A COLOR PALETTE 

You can create swatches or add existing ones to color palettes. To create a swatch, do the 
following: 

1. In Animate CC, select Window > Swatches. 

2. On the Swatches panel, select any color palette within a folder, and click the   button to 
create a swatch. A new swatch is created using the current selected fill color in the Colors 
panel. You may also select an existing swatch and click the   button to duplicate the swatch 
within the palette. 

You can also create a swatch by selecting a folder, color palette, or swatch and selecting the 
Duplicate as Swatch option from the fly-out menu. 

1. In the Swatches panel, select one of the following commands from the menu in the 
upper-right corner: 

• To append the imported colors to the current palette, select Add Colors. 

• To replace the current palette with the imported colors, select Replace Colors. 
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2. Navigate to the desired file, select it, and click OK. 

3. In the Swatches panel, select Save Colors from the menu in the upper-right corner and 
enter a name for the color palette. 

4. For Save As Type (Windows) or Format (Macintosh), select Animate Color Set or Color 
Table. Click Save. 

Learning Outcome 3.3: Export 2D animation project 

 Export Adobe Animate project 

 
 Working with multiple types of file format 

 
 FLA File (Adobe Flash Application) 

 
FLA files, the primary files you work with in Animate, contain the basic media, timeline, and 

script information for a Animate document. Media objects are the graphic, text, sound, and 

video objects that comprise the content of your Animate document. The Timeline is where 

you tell Animate when specific media objects should appear on the Stage. You can 

add ActionScript code to Animate documents to more finely control their behaviour and to 

make them respond to user interactions. 

 
 Uncompressed XFL file (Adobe flash exchange format) 

 
Uncompressed XFL files are similar to FLA files. An XFL file, and the other associated files 

inside the same folder, are simply the uncompressed equivalent of a FLA file. This format 

makes it easier for groups of users to work on different elements of an Animate project at 

the same time. For more information, see working with uncompressed XFL files. 

 

 SWF file (small web format) 

SWF files, the compiled versions of FLA files, are the files you display in a web page. When 

you publish your FLA file, Animate creates a SWF file. 

The Animate SWF file format is an open standard that other applications support. For more 

information about Animate file formats. 

 AS file (Action Script) 
 

AS files are ActionScript files—you can use these to keep some or all of your ActionScript 

code outside of your FLA files, which is helpful for code organization and for projects that 

have multiple people working on different parts of the Animate content. 

 

https://helpx.adobe.com/animate/using/documents.html#working_with_uncompressed_xfl_files


Page 71 of 74 
 

 SWC file (Shockwave component) 

WC files contain the reusable Animate components. Each SWC file contains a compiled 

movie clip, ActionScript code, and any other assets that the component requires. Note: SWC 

files cannot be imported into Animate. 

 JSFL file (JavaScript file) 

JSFL files are JavaScript files that you can use to add new functionality to the Animate 

authoring tool.JSFL files are used to automate events and workflows in the Adobe Animate 

authoring environment. 

 Export graphic and Video 
 

 PNG Sequence 

You can export a series of image files from an individual movie clip, button, or graphic 

symbol in the Library or on the Stage. During export, Animate (formerly Flash Professional) 

creates a separate image file for each frame in the symbol. If you export from the Stage, any 

transformations (for example, scaling) you have applied to the symbol instance are 

preserved in the image output. 

To export a PNG sequence: 
 

1. Select a single movie clip, button, or graphic symbol in the Library or the Stage. 

2. Right click it and choose Export PNG Sequence. 

3. In the Save As dialog, choose a location for the output and click OK. 

4. In the Export PNG Sequence dialog, set your desired options.  
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Width - The width of the image output. You can scale the output by changing this value. The 

default is the width of the symbol content. 

Height - The height of the image output. You can scale the output by changing this value. 

The default is the height of the symbol content. 

Resolution - The resolution of the image output. The default is 72 dpi. 

Colors - The bit depth of the image output. You can select 8, 24, or 32 bit. The default is 32 

bit, which supports transparency. If you select 24 bit or 8 bit, which do not support 

transparency, the Background setting changes to Stage. See below. 

Background - The color to use as the background color for the image output. This setting is 

only available when the Colors option is set to 8 bit or 24 bit. When Colors is set to 32 bit, 

the image background is always transparent. When the Colors option is set to 8 bit or 24 bit, 

the Background option defaults to the Stage color. With 8 bit or 24 bit images, you can 

change the setting to Opaque and then select a background color from the color picker. 

Alternatively, choose an alpha value for the background to create transparency. 

Smooth - Toggles whether to apply smoothing to the edges of the image output. Turn off 

this option if you are not using a transparent background and images placed on a 

background color are different from the current color of the Stage. 

5. Click Export to export the PNG sequence 
 

 JPEG Sequence 

These options match the JPEG Publish Settings options. However, the Match 

Screen matches the exported image to the size of the Animate content as it appears on your 

screen. Match Movie matches the JPEG image to the Animate content and maintains the 

aspect ratio of the original image. 

 Animated GIF 

You can export animated GIF files in Animate by performing the following steps:  

1. Go to File > Export > Export Animated GIF 

A dialog appears.  
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2. Choose your desired options in the dialog and click Done to export your animation as 
animated GIF file. 
 

 
 

 SVG File 
Exporting artwork in SVG format 
 
1. In Animate, scrub or move the play head to the appropriate frame. 
2. Select File > Export > Export Image. Or select File > Publish Settings (select the SVG Image 
option in the Other Formats section.) 
3. Enter or browse to the location where you want to save the SVG file. Ensure that you 
select SVG as the Save As type. 
4. Click Ok. 
5. On the Export SVG dialog, choose to Embed or Link to your SVG file. 
 
 Include Hidden Layers Exports all hidden layers in the Animate document. Deselecting 

Export Hidden Layers prevents all layers (including layers nested inside movie clips) 
marked as hidden from being exported in the resulting SVG. This lets you easily test 
different versions of Animate documents by making layers invisible. 

 Embed: Embeds a bitmap in the SVG file. Use this option to if you want to directly 
embed bitmaps within the SVG file. 

 Link: Provides a link to the path of bitmap files. Use this option when you do not want to 
embed, but provide link to the bitmaps from the SVG file. If you select Copy Images to 
Folder option, the bitmaps will be saved inside the images folder created at the location 
where the SVG file is exported. When Copy Images to Folder option is not selected, the 
bitmaps will be referenced in the SVG file from their original source location. In case the 
bitmap source location is unavailable then they will be embedded inside the svg file. 

 Copy Images to /Images folder: Allows you to copy the bitmap to the /Images. The 
/Images folder, if it does not already exist, is created in the export location of the SVG. 
Optimize for Character Animator: Allows you to export SVG that works well with 
Character Animator. 

6. Click Ok 
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